Results 1 to 9 of 9

Thread: zimbraMailMode problem

  1. #1
    Join Date
    Dec 2006
    Location
    Argentina
    Posts
    28
    Rep Power
    8

    Default zimbraMailMode problem

    Hi everyboy.....
    I'm using zcs-NETWORK-4.5.6 on RHEL4 and I can't set the zimbraMailMode to both (http or https).... I did the following:

    As zimbra user-
    > zmtlsctl both
    > zmprov -l gs
    zimbraMailMode: both
    zimbraMailPort: 80
    zimbraMailSSLPort: 443
    > tomcat restart
    > zmprov -l gs
    zimbraMailMode: mixed
    zimbraMailPort: 80
    zimbraMailSSLPort: 443

    Why the property value back to the previous setting??.....I did something wrong???.....

    Thanks......

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The correct command is in the wiki.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2006
    Location
    Argentina
    Posts
    28
    Rep Power
    8

    Default

    Yes but the possibles options that I get from the command are "http,https,both,mixed" (different to the options in the wiki).....

    > zmtlsctl -h
    ERROR: account.INVALID_ATTR_VALUE (zimbraMailMode must be one of: http,https,both,mixed)

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by aletomi View Post
    > zmtlsctl -h
    ERROR: account.INVALID_ATTR_VALUE (zimbraMailMode must be one of: http,https,both,mixed)
    because there really is no help for it
    su zimbra
    zmtlsctl http(s)
    zmcontrol stop
    zmcontrol start
    (or tomcat stop/start)
    Last edited by mmorse; 09-02-2007 at 01:48 AM.

  5. #5
    Join Date
    Dec 2006
    Location
    Argentina
    Posts
    28
    Rep Power
    8

    Default

    Yes but please check the output of the command zmtlsctl:

    ERROR: account.INVALID_ATTR_VALUE (zimbraMailMode must be one of: http,https,both,mixed)

    And check the output of the query to the ldap server:

    zimbraMailMode: both
    zimbraMailPort: 80
    zimbraMailSSLPort: 443

    'both' seems to be a valid option for the "zmtlsctl" command and the zimbraMailMode attribute........

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    'mixed' mode uses HTTPS for logging in and HTTP for normal session traffic
    'both' would allow HTTP or HTTPS for the entire session
    'http' is HTTP only for the entire session
    'https' is HTTPS only for the entire session
    Last edited by mmorse; 07-06-2007 at 09:14 PM.

  7. #7
    Join Date
    Dec 2006
    Location
    Argentina
    Posts
    28
    Rep Power
    8

    Default

    No, I only put "-h" to get the zmtlsctl error message and see the valid values....
    Plase, check the first post to see what I did, trying to set the zimbraMailMode value to "both"..........

    Regards and sorry if my english is bad........

  8. #8
    Join Date
    Sep 2006
    Posts
    252
    Rep Power
    9

    Default

    Actually he's right. That command should work for him and the wiki page is incomplete. Otherwise the command help message is wrong.

    He adds -h in order to see the command help message.

    Thanks,

  9. #9
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yeah, that's true. The command should know when the user is asking for help.

    Anyone want to file a bug?

Similar Threads

  1. Zimbra, WM5.0, AS + problem with regional fonts
    By wojo2000 in forum Zimbra Mobile
    Replies: 7
    Last Post: 06-25-2007, 02:04 AM
  2. strange MTA Relay Problem
    By pfuschi in forum Installation
    Replies: 0
    Last Post: 10-31-2006, 11:51 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •