Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: iCal attendee lookup using Zimbra directory

  1. #1
    Join Date
    Jan 2008
    Posts
    5
    Rep Power
    7

    Default iCal attendee lookup using Zimbra directory

    Hi,

    A disclaimer first: I am not really a Zimbra user yet... We currently only have one(1) test account at a "Zimbra service provider" to verify that it may meet our demands. :-)

    As the company's only Mac user (so far), I have had to do my own testing using our test account, and for the most part it seems to be working really nice (including iCal two-way sync, the alpha version of the Desktop AJAX client etc.).

    However, I'm having one problem that we have only been able to get our service provider to say "should be working", and that is to get the attendee availability lookup to work in iCal 3.0 (Leopard). Let me describe what I have done, and what does and does not work:
    • I have added the account in iCal for the Zimbra calender server - works great
    • I have added the Zimbra server in Directory Utility (had to do it manually), and this makes it possible to search and find any user in the Global Address List (GAL) on "our" instance of the Zimbra server, using the Apple Address Book (when in the Directories group, at least)
    • It seems that outside the Address Book, searching for - or autocompleting - a user in the GAL, does not work however. E.g. when composing an email, it doesn't search (or at least it doesn't find any results) in the GAL. This applies to Mail.app, and iCal.
    • However, if I also add the Zimbra server to the LDAP tab of the Preferences for the Address Book (even with an empty search base!), the email recipient auto-completion works perfectly.
    • Still, in iCal the following actions don't work satisfactory:
      1. Click on the Zimbra calendar in the calendar list, to make it the active calendar
      2. Double click on a day/time to add a new appointment, and name it
      3. Click on the appointment and click Edit.
      4. Click on "Add attendees...".
      5. Select Window -> Address Panel to open the address panel
      6. Select Window -> Availability Panel to open the availability panel
      7. Search for a known user in the address panel, or start writing a Zimbra user's name in the Attendees: field.


    The result of these actions is this:
    • In my experience, "0 users" is the permanent message in the Availability Panel, and searching for known users doesn't return any records either.
    • Similarily, none of the known user addresses on "our" test Zimbra server will resolve/auto-complete in the Attendees: field.
    • If I enter a complete, known-to-be-valid email address for a user in the GAL, iCal thinks it's ok (just as with any other email address), but in the availability panel (where both our test account and the other attendee is now listed) no availability information is seen (it seems that both users' calendars are completely blank).


    And what I expected was this:
    • That, at least when searching in the Address Panel, but possibly also just upon opening it, all the users in the GAL are available.
    • That when a valid user account that is in the GAL is entered as an attendee (at least when dragged-and-dropped from the Address Panel, but possibly also when just written/auto-completed in the Attendees field), the user's availability information is seen in the Availability Panel.
    • Optionally, that when writing an address that is in the GAL into the Attendees field, it auto-completes, just like in Mail.app.


    One final note: The same thing (scheduling a meeting by searching for attendees' availability) works in Outlook using the Outlook Connector, and in the web interface, so I believe that the other users' calendars are "suffienctly public" for this to be working.

    So, my questions are:
    • Did I miss any settings or preferences?
    • Is this a known bug (didn't find anything directly related in my bugzilla search), a known not-to-be-implemented feature or otherwise something known?
    • Are there any other workarounds beside the obvious, "just use the web client and/or Desktop AJAX client"?


    Oh, and the server is Zimbra 5.0.1, while I'm on Mac OS X 10.5.1.

    Thanks for your help, and sorry for the long first post... :-)

    - Erik

  2. #2
    Join Date
    Apr 2007
    Location
    Los Gatos, CA
    Posts
    138
    Rep Power
    8

    Default

    Quote Originally Posted by Erik T View Post
    [*] I have added the Zimbra server in Directory Utility (had to do it manually), and this makes it possible to search and find any user in the Global Address List (GAL) on "our" instance of the Zimbra server, using the Apple Address Book (when in the Directories group, at least)
    What setting did you use while setting this part up?

  3. #3
    Join Date
    Nov 2007
    Location
    Santa Barbara, CA.
    Posts
    109
    Rep Power
    7

    Default

    Quote Originally Posted by danielfarrelly View Post
    What setting did you use while setting this part up?
    I'm also interested in knowing!

  4. #4
    Join Date
    Jan 2008
    Posts
    5
    Rep Power
    7

    Default

    Sorry for being a bit late in the response here - Zimbra just works so fine most of the time, I seldom have to come back here to look for troubleshooting help...

    Directory Utility

    As for the Directory Utility setup, I can't recall where I got the info -- if from anywhere in particular, but I'll try to retrace my steps (as I don't really want to mess up my system by removing and re-adding the Zimbra LDAP entry from the directory list, sorry):

    • Open Directory Utility (in /Applications/Utilities/)
    • Click the padlock, if locked, to enable editing
    • Click Show Advanved Settings


    Here is the part I am sorry I don't really remember how I got to... I'll describe how it looks for me now, and first list how I believe I got it to work:

    • Click on the Services tab/button
    • Click on LDAPv3
    • Click the pencil icon
    • Click on Show options triangle
    • Click the New... button
    • Enter the URL to your Zimbra installation (rather, just the server FQDN)
    • Select/Deselect options according to your needs [SIZE="1"](I use SSL; I don't use LDAP for authentication, but I do use it for contacts)
    • Click on Continue
    • Ensure that LDAP Mappings are set to Open Directory Server, and that you enable authentication with appropriate username/password
    • I made no changes in Search Base suffix or mappings, I think...


    Ok, that's about it. If there are steps I've forgotten, they can't be all that important, as they at least haven't made any impact on the settings I can see in the Directory Utility now.

    If you have any trouble, I'd just do the first six steps above, and then go to the manual mode, and edit the rest there:
    In the Edit... window, ensure that the Connection settings are according to your needs, that in the Search & Mappings tab it tells LDAP to access Zimbra using Open Directory Server, and that the user account settings in the Security tab is correct.


    Re: Original post

    As for my original question, the most basic features kind of work now. When I now enter my colleague's complete email address and click Available Meeting Times..., I do get his (only guys working here, so far) busy/free calender alongside my own. And this works great for scheduling meetings.

    What is still missing is a working auto-completion of valid email addresses in the attendees field of the edit-an-appointment in iCal, and (I guess completely correlated) searching for users (or anything, really) in the Address Panel of iCal. The first of these shows signs of trying to do some searching/lookup/auto-completion, but fails to give me any response. The Address Panel says Open Directory Lookup, but after spending amillisecond (ca.) searching, it just says 0 people...

    Auto-completion of email addresses from the GAL works just fine when composing an email in Mail.app , and the Directory lookup works great in the Address Book, so this seems to be an iCal-thing.

    I guess I'll be submitting a feature request/bug report to Apple on this when I get some spare time on my hands, as it seems this is related to how the lookup in iCal works. Unless someone can tell me that this is a Zimbra hickup?

    Oh, and we have now been using Zimbra hosted by Telsys, since right after that first post of mine, and it works for the most part just great. I had a problem with CalDAV syncing when one of the calendars had a space in its name, and iCal doesn't always(?) show the events in the calendars that are shared with me. But, other than that, it's solid.

    And I'm sorry that I obviously have never learned to write short and concisely...

  5. #5
    Join Date
    Mar 2008
    Posts
    5
    Rep Power
    7

    Default Address Book search

    Hello, I have some question for this topic.

    While the iCal works quite well I have problem searching with the Address book.

    1) the connection does not work, how can I debug the LDAP client connections- and requests ? (I followed your step by step suggestions)
    2) May I have all the GAL from the GAL or just results from the query ? I want to send the GAL to a mobile via address book.

    Thanks in advance.

  6. #6
    Join Date
    Jan 2008
    Posts
    5
    Rep Power
    7

    Default

    @rabati:

    Just a few questions for you:
    What sort of errors do you get in Address Book? Are you hosting Zimbra yourself, or using a hosted service? Are you getting any errors in the Directory Utility?

    If you want to be bold about it, you may be able to glean some useful information about the LDAP connection (at least if it's unencrypted - which I'd usually discourage) using tcpdump (from a Terminal window). Otherwise, have you checked your Console log to see if either Address Book or the Directory Utility have output any messages there?

  7. #7
    Join Date
    Mar 2008
    Posts
    5
    Rep Power
    7

    Default

    Feedback from Directory utility or addressbook, nothing.

    Addressbook says No Matches found

    We have our internal zimbra server 5.0.*
    I have Leopard 10.5.4 on a MacBook
    LDAp ports seems OK, telnet says the port is alive.+

    Any log file available before tcpdump (I use Wireshark)

    Thanks

  8. #8
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    Based on [CalendarServer-users] delegation help? and Nabble - Calendar Server - Users - attendee lookup and AFP548 - Record Augmentation - Part 1 - The Cylinder of Destiny and /CalendarServer/trunk/doc/ical-schema.txt ? CalendarServer ? Trac it should be possible to have iCal autocomplete addresses in the Zimbra GAL. You shouldn't even need to extend the LDAP schema; variable interpolation of the uid attribute should work. I'm not getting very far without a live example of the appropriate servicelocator attributes, though. Has anyone else gotten further down this road?

  9. #9
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Quote Originally Posted by Erik T View Post
    Auto-completion of email addresses from the GAL works just fine when composing an email in Mail.app , and the Directory lookup works great in the Address Book, so this seems to be an iCal-thing.
    I am seeing the exact same thing, and I can add that this result occcurs regardless of the settings in Directory Utility.

    In other words as long as the LDAP part of Address Book preferences is configured to access the Zimbra server, both Address Book and Mail can do lookups from the GAL. For the benefit of rabati, the settings in Address Book are:

    Name: anything you like
    Server: fully qualified domain name of zimbra server
    Port: 389
    Use SSL NOT checked (at least for test purposes)
    Searchbase: ou=people,o=company
    Scope: subtree
    Authentication: none (at least for test purposes)

    However iCal doesn't find anything in the Addresses Panel, and the application /Applications/Utilities/Directory also doesn't find anything.

  10. #10
    Join Date
    Dec 2008
    Posts
    2
    Rep Power
    6

    Default

    I would be really happy to see this start working too. It's almost the only thing I get complaints about anymore... but that's probably because Zimbra is working so well in other aspects.

    Anyhow, I managed to get Zimbra entries to show up in /Applications/Utility/Directory by making a few changes to the RFC 2307 settings in Directory Utility:
    • Added "ou=people" to the "Search base" for People and switched it to search in "first level only"
    • Added "organizationalPerson" to the "map to" list for People
    This does ignore the zimbraHideInGal attribute though, so there are some funny looking entries for the ham/spam/admin users. However, there is still a piece missing! The Addresses box in iCal is still empty.

    As best I can tell, iCal not only needs people in the Directory, it needs them to have specific attributes and for there to be a record for the calendar server. The best description of the missing bits that I can find is in the mysterious ical-schema.txt file. It was linked to by Rich Graves, but has been removed from recent revisions as "no longer relevant," so here's a link to a revision right before it got removed: https://trac.calendarserver.org/brow...a.txt?rev=3389.

    Anyhow, I don't totally understand the "variable interpolation" option suggested by Rich. (Explanations welcome!) For the moment, the most straightforward approach seems to me to add the necessary attributes and computer record through a zimlet (like the zimbra_posixaccount and zimbra_samba ones do). However, I'm not quite sure where to start with these files. I'm quite new to Zimbra and some of the JS in zimbra_posixaccount makes my head swim.

Similar Threads

  1. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 12:17 PM
  2. centos 5 zimbra 4.5.6 no statistics
    By rutman286 in forum Installation
    Replies: 9
    Last Post: 08-14-2007, 09:30 AM
  3. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM
  4. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •