Results 1 to 7 of 7

Thread: Groupwise Migration Problems.

Hybrid View

  1. #1
    Join Date
    Aug 2007
    Posts
    28
    Rep Power
    8

    Default Groupwise Migration Problems.

    I did a search on Novell Migration..

    I can't seem to find too much info.

    I have a Novell Groupwise Server running right now...

    I already have all the users entered into Zimbra. Now I need to move their calendar, email history, and contacts over from Groupwise.

    I am attempting to use the Migration tool to do this.. however I have some questions and concerns.

    I need to know that I can import from Groupwise into accounts on Zimbra that have already been created.. or do I have to do this from scratch?

    I have troubles with the below screenshots also.

    I don't know what to put in the postoffice information file.

    I also am unsure as to why it can't see the LDAP server. (a problem with groupwise?)

    Anyways, thanks for reading. Here are the screenshots.
    Attached Images Attached Images

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by SurrealSystems View Post
    I can't seem to find too much info.
    -Have you gone through: /docs/ne/latest/migration_wizard_for_groupwise_installation_guide/

    username in the format cn=admin,ou=zimbra,o=z1 have any effect?

    Quote Originally Posted by SurrealSystems View Post
    I already have all the users entered into Zimbra. Now I need to move their calendar, email history, and contacts over from Groupwise.
    I need to know that I can import from Groupwise into accounts on Zimbra that have already been created.. or do I have to do this from scratch?
    During the migration, the Groupwise migration wizard performs the following tasks:
    • Creates the user account on the Zimbra server, if it does not already exist
    • Imports email messages, attachments, calendars, and contacts (possibly tasks/documents when we get to v5, so for now copy those to an email etc)

    Quote Originally Posted by SurrealSystems View Post
    I don't know what to put in the postoffice information file.
    I also am unsure as to why it can't see the LDAP server. (a problem with groupwise?)
    see the doc (sorry I can't help you anymore than that-not a groupwise user)
    Notes:
    -With the 4.5 wizards Postoffice information usage is case-sensitive
    -Also the 4.5 wizards rely on having a uid field: Bug 18334 - The GroupWise Migration tool relies on the uid LDAP field which doesn't appear to always exist
    -If you need gwtapp.dll see here GroupWiseMigration - ZimbraWiki
    -seriously don't forget about HKCU\Software\ZCSMigWiz\MaxAttachSizeMB which has a default of 10MB (just set it go 0)

    Also, your still restricted by your zimbraFileUploadMaxSize & zimbraMtaMaxMessageSize (settable via the zcs admin console). Set zimbraMtaMaxMessageSize 10% larger than the zimbraFileUploadMaxSize.

    Say both are set to 10MB (and you tell everyone they can send 10MB attachments):
    An email with a 9MB attachment and 100KB message body text. The attachment may be less than the 10MB zimbraFileUploadMaxSize, and so it'll get accepted by the file upload system. But when it's converted into a MIME message it ends up base64-encoded. Then add 100K of regular body text, and the resulting message (say 10.3MB or so) is then handed off to postfix, which checks zimbraMtaMaxMessageSize and promptly rejects the message if it's over the limit of 10MB.

    Of course set zimbraMtaMaxMessageSize even larger if you want to allow emails with multiple large attachments.
    Also, there's a spamassassin setting to not scan/spend cpu resources on really large messages that are over x value in size - adjust accordingly.
    Last edited by mmorse; 09-25-2007 at 06:24 AM.

  3. #3
    Join Date
    Aug 2007
    Posts
    28
    Rep Power
    8

    Default

    -Have you gone through: /docs/ne/latest/migration_wizard_for_groupwise_installation_guide/
    I did go through that =)

    The main problem I'm having is the Novell stuff =(

  4. #4
    Join Date
    Dec 2006
    Posts
    21
    Rep Power
    9

    Default

    Sorry I'm late to the party. Are you still having problems?

    I am doing a GW migration currently, and am pretty familiar with GW and Novell.

    From your screenshots it looks like you are trying to log into GroupWise with a Novell NDS account. That will NOT work unless your NDS account is also in GroupWise. So, in your case, you are using the Admin NDS account (from your screenshot). Look in the GroupWise system for admin (or look in the GroupWise tab in ConsoleOne under the admin object). If you don't see a GW account, that is the problem. Either create a GW account for Admin, or use some other administrative account that is in GroupWise. Once you get past that part, let me know if you have any other problems and I can try to help you.

  5. #5
    Join Date
    Aug 2007
    Posts
    28
    Rep Power
    8

    Default

    Did I have everything else right?

  6. #6
    Join Date
    Dec 2006
    Posts
    21
    Rep Power
    9

    Default

    Quote Originally Posted by SurrealSystems View Post
    Did I have everything else right?
    Well, as far as I can tell it looks ok. You can try it and make sure you can get all the way though the wizard screens, just click "Cancel" when it asks you if you want to import at the end if you don't want to do it at the time.

    I don't know what you are putting in for your LDAP stuff in the next screen after the GW screen, so I don't know if that will work for you or not. You can use cn=admin,o=wolfechev (shown in your screenshots) with the admin password and that should work. Don't try to use SSL LDAP or you may have problems. SSL LDAP wasn't supported the last I knew, although it was slated to be fixed. It might be ok now, but I'm not sure.

    Also, make sure you are using the latest version of the wizard. It should hopefully be like 4.5.7 or better. There's been a lot of work on that tool (some due to my migration, I think), and the latest one is pretty good. Earlier ones were less than stellar IMHO (duplicating sent items, unhelpful log messages, etc.). There is still a problem if your users have *a lot* of recurring appointments. You WILL get an error with some users if this is the case. It is supposed to be fixed in the next release, I believe. We are hitting that quite a bit. It is due to field sizes in the DB.
    Last edited by mclark; 09-10-2007 at 11:00 AM.

  7. #7
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default GroupWise reminder notes?

    Hae any of you had users demand carrying forward Reminder Notes? I can imagine some workarounds, but haven't taken it very far.

    I've entered an RFE at Bug 20323 - GW Reminder Notes migration

Similar Threads

  1. Groupwise migration tool fails with CONNECT_ERROR
    By lustenbe in forum Migration
    Replies: 1
    Last Post: 08-23-2007, 08:59 AM
  2. GroupWise Migration stops on message ten
    By stuartg.orion in forum Migration
    Replies: 2
    Last Post: 06-24-2007, 10:08 PM
  3. My migration from GroupWise - any suggestions?
    By stuartg.orion in forum Migration
    Replies: 3
    Last Post: 06-11-2007, 06:34 PM
  4. exchange 2000 migration problems
    By tleong in forum Administrators
    Replies: 3
    Last Post: 02-21-2007, 11:20 PM
  5. Migration problems
    By andrewl in forum Migration
    Replies: 8
    Last Post: 12-14-2006, 07:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •