Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Wrong attachment filenames after migration from Outlook

  1. #1
    Join Date
    Jan 2008
    Posts
    5
    Rep Power
    7

    Default Wrong attachment filenames after migration from Outlook

    Hello, people!
    We use Zimbra 5.0.1 on OpenSuse 10.2 x86.
    After migration PST file from Outlook2003 by Zimbra Wizard we get wrong attachment filenames encoded in windows-1251.
    Attachment filenames encoded in koi8-r are represented correctly.
    Follow origin texts of messages (for example):
    win-1251
    Content-Disposition: attachment; filename="Орлова Ольга Александровна.bmp"
    Content-Transfer-Encoding: Base64
    Content-Type: image/bmp; charset=windows-1251;
    koi8-r
    Content-Type: text/plain;
    name="=?koi8-r?B?78bJ09kudHh0?="
    Content-Transfer-Encoding: base64
    Content-Description: =?koi8-r?B?78bJ09kudHh0?=
    Content-Disposition: attachment;
    filename="=?koi8-r?B?78bJ09kudHh0?="

    How we can resolve this problem?

    Thanks

  2. #2
    Join Date
    Jan 2008
    Posts
    5
    Rep Power
    7

    Default where I can obtain source code for Migration Wizard?

    People!
    Please help!

  3. #3
    Join Date
    Feb 2008
    Location
    Moscow
    Posts
    2
    Rep Power
    7

    Default Same problem

    Hi, people.

    We have migrate from .pst file (Outlook 2003) to Zimbra OSS 5.0.1 by ZCSPSTImportWizard-5.0.1_GA_1900.exe.
    Attachment file names with cyrillic characters looks bad after migration (see screenshots, Exchange.PNG - before migration, Zimbra.PNG - after).

    We tried to migrate with imapsync - all ok.

    We think problem in shifting cyrillic symbols HEX-code to -350 (in hex).
    For example:
    "Пример", first symbol hex-code is 041f, second - 0440 & etc (before migration).
    "", first symbol hex-code is 00cf, second - 00f0 & etc (after migration).

    I attach .pst file with example message with attachment in cyrillic (test.zip).

    Please, help to resolve this problem.
    Attached Images Attached Images
    Attached Files Attached Files

  4. #4
    Join Date
    Oct 2005
    Location
    Netherlands
    Posts
    55
    Rep Power
    10

    Default

    First of all try upgrading to 5.0.2 and using the wizard from that version! There's some annoying bugs in 5.0.1 in migrations. Maybe this solves your problem right away..
    Also check bugzilla for fixes in 5.0.2 (see anouncement in forums for link).
    Good luck,
    Peter
    Using ZCS Network-edition 5.0.16 on Ubuntu 6.06.2 LTS and 8.04 LTS

  5. #5
    Join Date
    Feb 2008
    Location
    Moscow
    Posts
    2
    Rep Power
    7

    Default

    We have upgrade Zimbra to version 5.0.2 and use ZCSPSTImportWizard-5.0.2_GA_1967.exe.
    This did not give us wishful result - incorrect attachment names are remained.

  6. #6
    Join Date
    Jan 2009
    Posts
    40
    Rep Power
    6

    Default

    Hi!
    I have the same problem too. What about request to support team?

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Please try the latest version of the import tool. There have been significant improvements over 5.0.2

  8. #8
    Join Date
    Jan 2009
    Posts
    40
    Rep Power
    6

    Default

    Thanks for your offer. At this moment I use 5.0.11 version, so I'm going to update it and post my results this day.

  9. #9
    Join Date
    Jan 2009
    Posts
    40
    Rep Power
    6

    Default

    Hi, everybody!

    Yesterday I've tested last versions of the ZCS PST Import Wizard and ZCS Exchange Migration Wizard (5.0.12) and found the same issues as previously:
    - ZCS PST Import Wizard changes Cyrillic characters in attachments' names (for example 'Омск, Турист' turn into ', ';
    - ZCS Exchange Migration Wizard changes Cyrillic characters in attachments' names too (mainly, '?' or '_' symbols).

    Need help!!!

  10. #10
    Join Date
    Feb 2009
    Posts
    2
    Rep Power
    6

    Default

    Hello
    Same problem here with ZCSPSTImportWizard-5.0.12_GA_2789
    Maybe the problem is not in import wizard, but rather in web client itself, as I've noticed that Zimbra has troubles with displaying messages with body encoded in windows-1251.
    Subject is shown correctly in any encoding

Similar Threads

  1. Special chars in attachment filenames - 404
    By Brains in forum Administrators
    Replies: 2
    Last Post: 10-01-2007, 09:58 AM
  2. Replies: 4
    Last Post: 05-25-2007, 11:21 PM
  3. Issues with Outlook Calendar Migration - ics
    By soxfan in forum Migration
    Replies: 2
    Last Post: 02-28-2007, 05:50 PM
  4. Replies: 2
    Last Post: 10-26-2006, 10:45 AM
  5. Migration Client causing Outlook Problems
    By jonfehringer in forum Administrators
    Replies: 4
    Last Post: 10-04-2005, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •