Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: LDAP Cannot bind on migration to new server

  1. #1
    Join Date
    Feb 2008
    Posts
    1
    Rep Power
    7

    Default LDAP Cannot bind on migration to new server

    Getting installed packages
    Getting local config zimbra_server_hostname
    Getting local config ldap_url
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    Starting ldap...
    *** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    slapd running pid: 21509
    done.
    Getting installed services from ldap
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    slapd running pid: 21509
    slapd already running.
    Getting enabled services from ldap
    Marking zimbra-core as installed. Services for zimbra-core will be enabled.
    Marking zimbra-ldap as installed. Services for zimbra-ldap will be enabled.
    Marking zimbra-store as installed. Services for zimbra-store will be enabled.
    Marking zimbra-mta as installed. Services for zimbra-mta will be enabled.
    Marking zimbra-snmp as installed. Services for zimbra-snmp will be enabled.
    Marking zimbra-logger as installed. Services for zimbra-logger will be enabled.
    Marking zimbra-apache as installed. Services for zimbra-apache will be enabled.
    Marking zimbra-spell as installed. Services for zimbra-spell will be enabled.
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java' 2> /dev/null
    checking isEnabled zimbra-cluster
    zimbra-cluster not in enabled cache
    enabled packages zimbra-logger zimbra-store zimbra-mta zimbra-core zimbra-apache zimbra-snmp zimbra-ldap zimbra-spell
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    slapd running pid: 21509
    slapd already running.
    Getting enabled services from ldap
    Marking zimbra-core as installed. Services for zimbra-core will be enabled.
    Marking zimbra-ldap as installed. Services for zimbra-ldap will be enabled.
    Marking zimbra-store as installed. Services for zimbra-store will be enabled.
    Marking zimbra-mta as installed. Services for zimbra-mta will be enabled.
    Marking zimbra-snmp as installed. Services for zimbra-snmp will be enabled.
    Marking zimbra-logger as installed. Services for zimbra-logger will be enabled.
    Marking zimbra-apache as installed. Services for zimbra-apache will be enabled.
    Marking zimbra-spell as installed. Services for zimbra-spell will be enabled.
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    done.
    Setting defaults from existing config...
    Getting local config ldap_master_url
    Getting local config ldap_port
    Getting local config ldap_root_password
    Getting local config zimbra_ldap_password
    Getting local config mysql_root_password
    Getting local config mysql_logger_root_password
    Getting local config zimbra_mysql_password
    Getting local config zimbra_logger_mysql_password
    Getting local config mailboxd_java_heap_memory_percent
    Getting local config mysql_memory_percent
    Getting local config mailboxd_directory
    Getting local config mailboxd_keystore
    Getting local config mailboxd_keystore_password
    Getting local config mailboxd_truststore_password
    Getting local config zimbra_ldap_userdn
    Getting local config ldap_dit_base_dn_config
    checking isEnabled zimbra-snmp
    zimbra-snmp is enabled
    Getting local config snmp_notify
    Getting local config smtp_notify
    Getting local config snmp_trap_host
    Getting local config smtp_source
    Getting local config smtp_destination
    Getting local config av_notify_user
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Getting local config ldap_replication_password
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    Getting local config ldap_postfix_password
    Getting local config ldap_amavis_password
    done.
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-mta
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    antispam not in enabled cache
    antivirus not in enabled cache
    archiving not in enabled cache
    checking isEnabled zimbra-spell
    zimbra-spell is enabled
    Checking for port conflicts
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    checking isEnabled zimbra-logger
    zimbra-logger is enabled
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    Checking ldap status.
    *** Running as zimbra user: /opt/zimbra/bin/ldap status
    slapd running pid: 21509
    slapd already running.
    Setting defaults from ldap...
    Global config attribute retrieved from ldap: zimbraDefaultDomainName=
    Server config attribute retrieved for ****: zimbraImapBindPort=
    Server config attribute retrieved for ****: zimbraImapSSLBindPort=
    Server config attribute retrieved for ****: zimbraMailMode=
    Server config attribute retrieved for ****: zimbraMailPort=
    Server config attribute retrieved for **** zimbraMailSSLPort=
    Server config attribute retrieved for ****: zimbraImapProxyBindPort=
    Server config attribute retrieved for ****: zimbraImapSSLProxyBindPort=
    Server config attribute retrieved for ****: zimbraPop3ProxyBindPort=
    Server config attribute retrieved for ****: zimbraPop3SSLProxyBindPort=
    Global config attribute retrieved from ldap: zimbraSpamIsSpamAccount=
    Global config attribute retrieved from ldap: zimbraSpamIsNotSpamAccount=
    Global config attribute retrieved from ldap: zimbraNotebookAccount=
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    Server config attribute retrieved for ****: zimbraMtaMyNetworks=
    checking isEnabled zimbra-store
    zimbra-store is enabled
    Global config attribute retrieved from ldap: zimbraBackupReportEmailRecipients=
    Global config attribute retrieved from ldap: zimbraBackupReportEmailSender=
    COS attribute retrieved for COS default: zimbraPrefUseKeyboardShortcuts=
    COS attribute retrieved for COS default: zimbraPrefTimeZoneId=
    COS attribute retrieved for COS default: zimbraFeatureIMEnabled=
    COS attribute retrieved for COS default: zimbraFeatureTasksEnabled=
    COS attribute retrieved for COS default: zimbraFeatureBriefcasesEnabled=
    COS attribute retrieved for COS default: zimbraFeatureNotebookEnabled=
    COS attribute retrieved for COS default: zimbraFeatureNotebookEnabled=
    Server config attribute retrieved for ****: zimbraSmtpHostname=
    Server config attribute retrieved for ****: zimbraMtaAuthHost=
    done.
    Getting available components
    checking isEnabled zimbra-ldap
    zimbra-ldap is enabled
    checking isEnabled zimbra-store
    zimbra-store is enabled
    Checking ldap on <hostname removed>:389
    Unable to bind to ldap://<hostname removed>:389 with user uid=zimbra,cn=admins,cn=zimbra and password <password removed>
    Couldn't bind to <hostname removed> as uid=zimbra,cn=admins,cn=zimbra
    Checking ldap on <hostname removed>:389
    Unable to bind to ldap://<hostname removed>:389 with user uid=zimbra,cn=admins,cn=zimbra and password <password removed>:
    Couldn't bind to <hostname removed> as uid=zimbra,cn=admins,cn=zimbra
    Checking ldap on <hostname removed>:389
    Unable to bind to ldap://<hostname removed>:389 with user uid=zimbra,cn=admins,cn=zimbra and password <password removed>:
    Couldn't bind to <hostname removed> as uid=zimbra,cn=admins,cn=zimbra
    checking isEnabled zimbra-mta
    zimbra-mta is enabled
    checking isEnabled zimbra-archiving
    zimbra-archiving not in enabled cache
    enabled packages zimbra-logger zimbra-store zimbra-mta zimbra-core zimbra-apache zimbra-cluster zimbra-snmp zimbra-ldap zimbra-spell
    zimbra_server_hostname contained in ldap_url checking ldap status
    Checking ldap status.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    Would you please provide more information on your migration ie. same O/S ? same version of ZCS ?

  3. #3
    Join Date
    Nov 2008
    Location
    Pavia (Italia)
    Posts
    19
    Rep Power
    7

    Default

    Hi all, I'm having the same problem moving a Zimbra installation from a 32bit Ubuntu 8.04 server to a 64bit Ubuntu server with the same version. Please note also that the new server has a different IP, but of course I kept the same hostname.

    I followed the procedure suggested on the Zimbra blog at Moving ZCS to Another Server &#187; Zimbra :: Blog

    When I launch install.sh the last time, without "-s" attribute, it's unable to finish its steps and it prompt me to the Zimbra configuration to change some parameters, after some LDAP errors like the topic author posted.

    Some interesting log saved by Zimbra setup:
    Code:
    [...]
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-ldap
    Mon Mar  2 10:16:38 2009 zimbra-ldap is enabled
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-store
    Mon Mar  2 10:16:38 2009 zimbra-store is enabled
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-mta
    Mon Mar  2 10:16:38 2009 zimbra-mta is enabled
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-mta
    Mon Mar  2 10:16:38 2009 zimbra-mta is enabled
    Mon Mar  2 10:16:38 2009 antispam not in enabled cache
    Mon Mar  2 10:16:38 2009 antivirus not in enabled cache
    Mon Mar  2 10:16:38 2009 archiving not in enabled cache
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-spell
    Mon Mar  2 10:16:38 2009 zimbra-spell is enabled
    Mon Mar  2 10:16:38 2009 Checking for port conflicts
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-ldap
    Mon Mar  2 10:16:38 2009 zimbra-ldap is enabled
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-store
    Mon Mar  2 10:16:38 2009 zimbra-store is enabled
    Mon Mar  2 10:16:38 2009 Port conflict detected: 7306 (zimbra-store)
    Mon Mar  2 10:16:38 2009 checking isEnabled zimbra-mta
    Mon Mar  2 10:16:38 2009 zimbra-mta is enabled
    Mon Mar  2 10:16:38 2009 Port conflict detected: 25 (zimbra-mta)
    Mon Mar  2 10:16:51 2009 checking isEnabled zimbra-ldap
    Mon Mar  2 10:16:51 2009 zimbra-ldap is enabled
    Mon Mar  2 10:16:52 2009 checking isEnabled zimbra-store
    Mon Mar  2 10:16:52 2009 zimbra-store is enabled
    Mon Mar  2 10:16:53 2009 checking isEnabled zimbra-logger
    Mon Mar  2 10:16:53 2009 zimbra-logger is enabled
    Mon Mar  2 10:16:55 2009 checking isEnabled zimbra-mta
    Mon Mar  2 10:16:55 2009 zimbra-mta is enabled
    Mon Mar  2 10:16:55 2009 Checking ldap status.
    [...]
    Mon Mar  2 10:17:45 2009 Checking ldap on smtp.netjungle.it:389
    Mon Mar  2 10:17:45 2009 Unable to bind to ldap://*********:389 with user uid=zimbra,cn=admins,cn=zimbra and password *********:
    Mon Mar  2 10:17:45 2009 Couldn't bind to smtp.netjungle.it as uid=zimbra,cn=admins,cn=zimbra
    [...]
    Many thanks in advance,
    Giorgio
    Giorgio Salluzzo - Sviluppatore Python / Django

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Have you disabled your firewall on the server ?

  5. #5
    Join Date
    Nov 2008
    Location
    Pavia (Italia)
    Posts
    19
    Rep Power
    7

    Default

    Actually I don't have any firewall installed on the server.
    Giorgio Salluzzo - Sviluppatore Python / Django

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Can you shutdown ZCS and then start it backup again; and post any errors from /var/log/zimbra.log please.

  7. #7
    Join Date
    Nov 2008
    Location
    Pavia (Italia)
    Posts
    19
    Rep Power
    7

    Default

    Excuse me but I don't understand why you asking me to look for errors in /var/log/zimbra.log.
    The source server is up and running with no errros, and the new server's log is empty because I couldn't finish the installation script.
    Giorgio Salluzzo - Sviluppatore Python / Django

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Arghh! Okay, I would recommend you shut down your source server before trying to install the second one as it has the same hostname. I appreciate you have used a different IP but if any of the services check DNS then it will find your original server ! Quote from that wiki
    Setup the newer server with the old server’s networking attributes. Make sure your older server is offline.

  9. #9
    Join Date
    Nov 2008
    Location
    Pavia (Italia)
    Posts
    19
    Rep Power
    7

    Default

    My new server has an internal bind9 dns server that points to localhost for that domain. Is it ok?
    Last edited by drizzt; 03-02-2009 at 06:03 AM.
    Giorgio Salluzzo - Sviluppatore Python / Django

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    In theory yes; though the Wiki does say the original server should be down. What does the following show
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

Similar Threads

  1. [Network Edition Trial] OS X Installation
    By dmg in forum Installation
    Replies: 4
    Last Post: 02-07-2007, 05:25 PM
  2. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  3. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 10:19 AM
  4. Authenticating to the LDAP
    By jasonwillis in forum Installation
    Replies: 4
    Last Post: 03-15-2006, 10:48 AM
  5. ldap pasword problem
    By jasonwillis in forum Installation
    Replies: 15
    Last Post: 03-15-2006, 08:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •