I wanted to share the result of 3 days of arguing with imapsync, Lotus Domino, and nested folders, subfolders, or whatever you want to call them. Imapsync would not copy subfolders with a forward slash '/', for some reason it defaults to a backslash '\'. All fine and dandy unless you have a folder tree with child folders. The '\' would create a whole new folder and not a child folder:

----Special Projects

Imapsync would for some reason create:

-Documents\Work\Special Projects

All seperate folders listed just like that. The abundance of documentation about imapsync left alot to be desired. I tried imapsync --regextrans2 and it didn't work but --sep1 '/' changes the separator from a '\' to a forward slash!

And preserving the original dates uses --syncinternaldates. This is only notable because the imapsyncbatch script in the Wiki has it included but if your changing domain names then you cannot use the script as is.

I suppose I could have just asked the forum for help, but I try not too. So here is a post with all the words I used to tried to search to solve the problem.


ZCS 5.0.6 on Ubuntu 6.06LTS