Results 1 to 10 of 39

Thread: [SOLVED] Zimbra to Zimbra Migration Script

Threaded View

  1. #1
    Join Date
    Sep 2008
    Posts
    20
    Rep Power
    7

    Talking [SOLVED] Zimbra to Zimbra Migration Script

    Hi
    VERSION 2.03 IS OUT! SEE THE LAST REPLY!
    Since I have problem transferring the old Zimbra to my Zimbra installation, I have decided to write a script to automatically transfer all data to the new installation. The old and new installation are of different domain! <-- so migrate to another domain is possible!

    Best of all, interruption for the source server is minimum as you can first rsync the data and then later on move it to the new server

    Assumption
    1. since this script don't setup anything for you, it just move user's data to the correct position, please setup your Zimbra, create users USING SAME NAME----<username>@source_server.com and <username>@target_server.com will be consider the same person!

    2. I assume the source server and SSH without password to the target server, I also assume you are root user, setup any SSH authen permission etc.....

    3. I assume both target and source servers are of the same Zimbra version

    4. I assume that this script MAY corrupt your data, making your users upset, BACKUP BACKUP AND BACKUP (just tar jcvf zimbra.tar.bz2 /opt/zimbra! so simple!)
    5. I am not responsible for any damages caused by the script, provided as is.
    6. I assume you will give some response and submit some feature/bug to me, ok?

    Precedure
    1. start both server's Zimbra, edit the parameters in the script file
    2. in source server (where you want the data copy from), run Zimbra2Zimbra.sh
    3. run /opt/zimbra/libexec/zmfixperms

    Done!
    Attached Files Attached Files
    Last edited by hinyinlam; 10-24-2008 at 09:38 AM. Reason: New version!
    I can provide custom solution for Zimbra to Zimbra migration.

    Move your mailboxes individually or just item inside each mailbox

Similar Threads

  1. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 06:16 AM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •