Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: [SOLVED] 32bit to 64bit migration

Hybrid View

  1. #1
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default [SOLVED] 32bit to 64bit migration

    Has anyone actually done the migration from 32 to 64 bit systems? We plan to migrate from SuSE 32bit to Ubuntu 8.0.4 64bit.

    Please post your experiences and possible issues!

    Thanks

    Chris

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Which version of ZCS are you running FOSS or NE ? With any post it is helpful to include those details so you could always update your profile
    Code:
    su - zimbra
    zmcontrol -v
    Network Edition: Moving from 32-bit to 64-bit Server - Zimbra :: Wiki

  3. #3
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Sure, you're right. Release 5.0.9_GA_2533.SuSEES10_20080814121029_NETWORK edition

  4. #4
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    OK, for those interested: We did the migration (32-->64bit). We got it working with help from support, but had major ldap issues in between. ldap passwords were not correct, had to set them manually again. Hostname (/etc/hosts) was tricky, too. It seems to only work with localhost set this way:

    127.0.0.1 localhost.localdomain localhost

    We had 127.0.0.1 localhost before, which was not enough.

    Now it is running; hopefully it stays that way...
    Last edited by iway; 11-24-2008 at 02:18 AM.

  5. #5
    Join Date
    Aug 2006
    Posts
    122
    Rep Power
    9

    Default ldap -1 , dwill - 0

    I tried this weekend, unsuccessfully I reviewed just about every post on the subject and created my own checklist which follows parts of the wiki, and parts of JHolders ldif advice, along with notes of all the errors and resolutions posted here. Everything seemed to work grand until zmcontrol start. I too had logger & mailbox errors. log files pointed to mysql problems related to hostname, which didn't make sense. The machine resolves splendidly.

    It was frustrating that, as good as it is, the information in the wiki and individuals posts do not seem to cover all possible variations of a 32 bit to 64 bit migration. It appears there are a different set of caveats depending upon the underlying OS & ZCS version(s) involved. Good thing I don't give up! I'm sure our errors are similar. I knew something was bound to go wrong when certain 64 bit preparatory steps include entering settings & passwords from the 32 bit settings, which didn't exists in the 32 bit version in our particular case.

    If you could share your solution I'm sure I could use that as my "I learned something new today" task
    Work
    8.0.3 UBUNTU10_04 UBUNTU10_04 NETWORK

    Home
    8.0.3 UBUNTU10_04 UBUNTU10_04 FOSS

  6. #6
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    You certainly have to make sure ALL passwords mentioned are identical. Your old setup must contain mysql root passwords in localconfig.xml. Check there and make them identical on the new system.

  7. #7
    Join Date
    Aug 2006
    Posts
    122
    Rep Power
    9

    Default Pretty sure that's what got me

    I'm sure that's my downfall.
    Some key pairs were named identical, other did not quite match (or i goofed), and there were one or two that didn't exists in the 32 bit that the 64 bit had, or that the 64 bit setup notes required, but didn't exist in the 32bit localconfig.

    I did a
    zmlocalconfig -s ldap_amavis_password ldap_postfix_password ldap_replication_password ldap_root_password zimbra_ldap_password

    to get all the values from the old machine. I can't remember of the top of my head, but not all of these options existed on the new.
    Work
    8.0.3 UBUNTU10_04 UBUNTU10_04 NETWORK

    Home
    8.0.3 UBUNTU10_04 UBUNTU10_04 FOSS

  8. #8
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Yes, but you should just open the localconfig.xml on the old server and copy all the mentioned passwords (also the mysql root password) to the new server.

  9. #9
    Join Date
    Aug 2006
    Posts
    122
    Rep Power
    9

    Default Thanks for the advice

    I'll probably give it a go tonight again and let you know how it turns out.

    1 more question: on your 64 bit server - did you do a full install and then copy over the index, store,.. dirs or did you do the dummy install and copy everything?

    I did the full, but I've seen a few posts mentioning doing the dummy install and was wondering if thats capable going from 32 to 64 bit.

    FYI,
    I'm going from
    UBU 6.06 32bit --> UBU 8.04 64 bit
    ZCS 5.010 32bit --> ZCS 5.010 64bit
    Work
    8.0.3 UBUNTU10_04 UBUNTU10_04 NETWORK

    Home
    8.0.3 UBUNTU10_04 UBUNTU10_04 FOSS

  10. #10
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    No, I did the full install.

Similar Threads

  1. GroupWise migration experience
    By nrc in forum Migration
    Replies: 3
    Last Post: 08-24-2010, 12:41 AM
  2. Moving ZCS from 32bit to 64bit or vice versa ?
    By mark_orion in forum Administrators
    Replies: 1
    Last Post: 08-26-2008, 05:30 AM
  3. moving from 32bit to 64bit in multiserver
    By bdial in forum Administrators
    Replies: 5
    Last Post: 07-22-2008, 12:11 PM
  4. [SOLVED] ZCS 5.02 - 32bit to 64bit RHEL
    By gmsmith in forum Administrators
    Replies: 7
    Last Post: 05-25-2008, 07:49 PM
  5. Zimbra 5.06 - Move from Centos5 32bit to Ubuntu6 64bit
    By greenrenault in forum Installation
    Replies: 2
    Last Post: 05-25-2008, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •