Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: New server can send, cant recieve.

  1. #1
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Question New server can send, cant recieve.

    Hi and TIA

    I must be missing something here,

    I got a zimbra installed on new server, it will replace an aging ms exchange 2000, and the server is up and running, I can send messages but cant recieve, the network has two firewalls, first one is iptables, second one is an ISA 2000.

    There are 4 domains on this network (not including the intranet domain) so far only using one for testing before migrating other domains.

    The error i'm getting when sending an email to the zimbra hosted domain is:

    The original message was received at Thu, 18 Dec 2008 06:38:52 -0800 (PST)
    from bX20fXX.virtua.com.br [189.32.247.XXX] (may be forged)

    ----- The following addresses had permanent fatal errors -----
    <user@zimbradomain.com>
    (reason: 550 5.7.1 Unable to relay for user@zimbradomain.com)

    ----- Transcript of session follows -----
    ... while talking to mail.carlostavares.com.br.:
    >>> >>> DATA
    <<< 550 5.7.1 Unable to relay for user@zimbradomain.com
    550 5.1.1 <user@zimbradomain.com>... User unknown
    <<< 554 5.5.2 No valid recipients



    The old exchange 2000 server FQDN is mail01.domain.com the new zimbra server is mail02.domain.com. the MX records were only changed in the internal DNS server, as the external information remains the same, so when setting up the zimbra server, one of the first things i did was create a second MX record for the domain, priority 20. once that was done setup went through without a problem, but I could send it, but not recieve it. Once the server was installed, I tested by changing the mx records priority.

    I get this error no matter where I send it from, hotmail, gmail, yahoo, other domains. Port 25 was being routed from the first firewall to the second firewall and then to the old exchange 2000 server, I changed it so it would route to the new server, still no go.

    In the logs I see

    Dec 19 12:06:57 mail02 postfix/smtp[1663]: warning: numeric domain name in resource data of MX record for another_domain.com.br: 200.186.145.XXX
    Dec 19 12:07:20 mail02 postfix/smtp[1663]: 170CD2B004A: to=<user@another_domain.com.br:>, relay=200.186.145.XXX[200.186.145.XXX]:25, delay=2334, delays=2311/0/23/0, dsn=4.4.2, status=deferred (lost connection with 200.186.145.XXX[200.186.145.XXX] while receiving the initial server greeting)

    So, now I'm wondering what I'm overlooking...

    Any imput is apreciated.

  2. #2
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Default

    /bump

    anyone?

  3. #3
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Default

    bumping this up again, i do belive i have provided a good deal of information about the problem, if anyone has any thoughts on it please let me know.

    Thanks

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Please post the output from
    Code:
    su - zimbra
    zmcontrol -v
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  5. #5
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Default out of the office

    thanks,

    I'm out of the office for a day.. will have to post that tomorow

  6. #6
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Default

    Sorry for the delay, and thanks for the help
    Code:
    zmcontrol -v
     Release 5.0.11_GA_2695.UBUNTU8_64 UBUNTU8_64 FOSS edition
    Code:
    Code:
    cat /etc/hosts
    127.0.0.1       localhost
    192.168.1.16    mail02.marcosjardim.br  mail02
    192.168.1.16    mail.carlostavares.com.br mail
    # The following lines are desirable for IPv6 capable hosts ::1 ip6-localhost ip6-loopback fe00::0 ip6-localnet ff00::0 ip6-mcastprefix ff02::1 ip6-allnodes ff02::2 ip6-allrouters ff02::3 ip6-allhosts
    Code:
    cat /etc/resolv.conf
    search marcosjardim.br
    search carlostavares.com.br
    nameserver 192.168.1.18
    Code:
    dig yourdomain mx
    ; <<>> DiG 9.4.2 <<>> carlostavares.com.br mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22289
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;carlostavares.com.br.          IN      MX
    ;; ANSWER SECTION:
    carlostavares.com.br.   3600    IN      MX      10 mx.carlostavares.com.br.
    ;; ADDITIONAL SECTION:
    mx.carlostavares.com.br. 3600   IN      A       200.186.145.197
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.18#53(192.168.1.18)
    ;; WHEN: Fri Dec 26 14:53:08 2008
    ;; MSG SIZE  rcvd: 73
    Code:
    dig yourdomain any
    ; <<>> DiG 9.4.2 <<>> carlostavares.com.br any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56817
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 2
    ;; QUESTION SECTION:
    ;carlostavares.com.br.          IN      ANY
    ;; ANSWER SECTION:
    carlostavares.com.br.   3600    IN      NS      dns1.carlostavares.com.br.
    carlostavares.com.br.   3600    IN      SOA     mail01.marcosjardim.br. admin.marcosjardim.br. 24 900 600 86400 3600
    carlostavares.com.br.   3600    IN      MX      10 mx.carlostavares.com.br.
    ;; ADDITIONAL SECTION:
    dns1.carlostavares.com.br. 3600 IN      A       200.186.145.197
    mx.carlostavares.com.br. 3600   IN      A       200.186.145.197
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.18#53(192.168.1.18)
    ;; WHEN: Fri Dec 26 14:53:49 2008
    ;; MSG SIZE  rcvd: 17
    0

    Code:
    
    host `hostname`
    Host mail02 not found: 2(SERVFAIL)
    Last edited by phoenix; 12-26-2008 at 10:46 AM.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You need to set-up a Split DNS on your LAN. You should also have just one enrty for your Zimbra server (and the loopback IP) that is the FQDN of your server and the DNS records should point to the address of your server as per the article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by phoenix View Post
    You need to set-up a Split DNS on your LAN. You should also have just one enrty for your Zimbra server (and the loopback IP) that is the FQDN of your server and the DNS records should point to the address of your server as per the article.
    any info as to how to set this up on a windows server? zimbra is the only linux server on this network, and just to make sure, what will happen to this split domain after i take the old server out of the game?

    Thanks

  9. #9
    Join Date
    Oct 2008
    Posts
    49
    Rep Power
    7

    Default

    Quote Originally Posted by rslrdx View Post
    any info as to how to set this up on a windows server? zimbra is the only linux server on this network, and just to make sure, what will happen to this split domain after i take the old server out of the game?

    Thanks
    I just read the article, it says I need to setup the dns server on the mail host itself, I guess I jumped to conclusions a bit too soon. Will post results

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by rslrdx View Post
    I just read the article, it says I need to setup the dns server on the mail host itself, I guess I jumped to conclusions a bit too soon. Will post results
    You can set-up a split domain using any DNS server in your LAN, the article is just shows one method of doing it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. [SOLVED] Build Zimbra..a little problem...
    By Abdelmonam Kouka in forum Developers
    Replies: 33
    Last Post: 05-22-2008, 06:10 AM
  2. use internal mail server to send email in external net
    By abisello in forum Administrators
    Replies: 5
    Last Post: 03-18-2008, 09:29 AM
  3. [Network Edition Trial] OS X Installation
    By dmg in forum Installation
    Replies: 4
    Last Post: 02-07-2007, 05:25 PM
  4. Intallation on FC5
    By rsharpe in forum Installation
    Replies: 24
    Last Post: 06-13-2006, 06:15 AM
  5. send to local SMTP server?
    By BarrySDCA in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 05-17-2006, 10:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •