Results 1 to 2 of 2

Thread: [SOLVED] IMAPSYNC Issues with Initial SSL Connection

  1. #1
    Join Date
    Sep 2008
    Location
    Princeton, NJ
    Posts
    81
    Rep Power
    7

    Default [SOLVED] IMAPSYNC Issues with Initial SSL Connection

    I am having trouble setting up for a migration from a standard IMAP server to ZIMBRA.

    I have imapsync fully installed.

    I ran this command:
    imapsync --buffersize 8192000 --nosyncacls --subscribe --syncinternaldates --host1 <myIMAPserver> --user1 <account1> --password1 <password1> --ssl1 --host2 <myZIMBRAserver>--user2 <account2> --password2 <password2> --ssl2

    The results were:
    $RCSfile: imapsync,v $ $Revision: 1.255 $ $Date: 2008/06/24 16:38:49 $
    Here is a [linux] system (Linux <myZIMBRAserver> 2.6.18-92.1.13.el5 #1 SMP Thu Sep 4 03:51:21 EDT 2008 x86_64)
    with perl 5.8.8 and the module Mail::IMAPClient version used here is 2.2.9
    Command line used :
    imapsync --buffersize 8192000 --nosyncacls --subscribe --syncinternaldates --host1 <myIMAPserver> --user1 <account1> --password1 <password1> --ssl1 --host2 <myZIMBRAserver>--user2 <account2> --password2 <password2> --ssl2

    Turned ON syncinternaldates, will set the internal dates on host2 same as host1.
    TimeZone :[EST]
    Will try to use CRAM-MD5 authentication on host1
    Will try to use CRAM-MD5 authentication on host2
    From imap server <myIMAPserver> port [993] user [<account1>]
    To imap server [<myZIMBRAserver>] port [993] user [<account2>]
    Error connecting to <myIMAPserver>:993:

    I have tried
    openssl s_client -connect <myIMAPserver>:993
    and it works/connects fine.

    Any ideas?
    Thanks!

  2. #2
    Join Date
    Sep 2008
    Location
    Princeton, NJ
    Posts
    81
    Rep Power
    7

    Default

    Here is my *NEW* approach to this:
    - Despite several attempts I could not get imapsync to authenticate an SSL encrypted channel. Imapsync requires a specific OLDER version of the Perl Module IMAPClient and maybe my SSLv3 connection could not be understood by it..? (anyone agree?)
    - I was able to get a non-SSL login to work. By locking down the imap ports to just between the exisitng mail server and the zimbra server, I felt comfortable thta the machine was not overly exposed. The command that worked was:

    imapsync --buffersize 8192000 --nosyncacls --subscribe --syncinternaldates --host1 <oldmailserver> --user1 <olduseracct> --password1 <olduserpassword> --authmech1 LOGIN --host2 <zimbraserver> --user2 <newuseracct> --password2 <newuserpassword> --authmech2 LOGIN


    The transfer is SLOW but reliable!
    Last edited by the_griz; 01-02-2009 at 02:38 PM. Reason: Updated!

Similar Threads

  1. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 05:32 PM
  2. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  3. Lots of deferred errors all of a sudden
    By CdtDelta in forum Administrators
    Replies: 0
    Last Post: 12-01-2007, 08:27 AM
  4. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  5. SMTP SSL Problem
    By nexus in forum Installation
    Replies: 8
    Last Post: 03-15-2007, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •