Results 1 to 2 of 2

Thread: Imapsync problem executing on centos 5.2

  1. #1
    Join Date
    Jan 2009
    Location
    Kuala Lumpur
    Posts
    5
    Rep Power
    6

    Arrow Imapsync problem executing on centos 5.2

    Hi all.

    New to zimbra but quite not so old to linux.

    Problem is trying to run imapsync on centos 5.2. Resolved all perl dependancies but cannot resolve this one:

    Subroutine Authuser redefined at ./imapsync line 2681.
    imapsync needs perl lib Mail::IMAPClient release 2.2.9 exactly, future imapsync release may suppoort 3.0.x, but sorry not now. See file BUG_IMAPClient_3.xx


    Anyone have any ideas as how to resolve this issue?

    Thanks in advance.

    PS: I installed perl modules thru the cpan cli: such as :
    root@myserver:~perl -MCPAN -eshell
    cpan>install Mail::IMAPClient

  2. #2
    Join Date
    Oct 2006
    Location
    Alberta, Canada
    Posts
    22
    Rep Power
    9

    Default

    Hello,

    I was able to uninstall 3.11 via YUM and the download the perl-Mail-IMAPClient-2.2.9-1.2.el5.rf.noarch.rpm and get it installed. Reinstall imapsync and you should be ready to go.

    I have run four test accounts successfully (e-mail only, I will need to figure out contacts, docs and calendar another time) and now am running the bulk of the domain.

    Hope this is helpful.

    Kent

Similar Threads

  1. [SOLVED] CentOS 5 zcs-NETWORK-5.0.8_GA_2462.RHEL5_64
    By dazedandconfused in forum Administrators
    Replies: 7
    Last Post: 07-28-2008, 12:15 PM
  2. Replies: 0
    Last Post: 06-09-2008, 10:34 AM
  3. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  5. 5.0 Install tasks
    By JoshuaPrismon in forum Installation
    Replies: 2
    Last Post: 06-06-2007, 12:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •