I've just completed a very complex migration from ZCS 5.0.2 FOSS running on Opensuse 10.3 to ZCS 5.0.14 FOSS on Centos 5.2 (Release 5.0.14_GA_2850.RHEL5_20090303142201 CentOS5 FOSS edition). However I'm now getting an issue where if anyone tries to search using the web client, they're getting a SOAP error. I can't see any errors in the maillog or zimbra logs.

The migration went otherwise surprisingly smoothly considering how complex this move was, but you know how it is: people don't see the previous 15 months of 100% uptime, they just see the 6 hours of downtime

I had a problem where all incoming and outgoing mail was going into the mail queue as deferred and traced the issue down to the fact that the store was chowned to root rather than zimbra (a result of the server migration), and I think the search issue is going to be something similar.

I've tried zmfixperms but I tried that on the deferred issue and it never fixed that. I also tried reindexing a mailbox, got no errors during the reindexing as far as I could see, but the error remains in the web client.

Of course, in true IT support fashion, everyone is moaning cos they can't search their emails

The error itself: when typing something into the search box at the top of the web client and press return, a dialog box returns saying "A Network Error Has Occured". Further details show:

method: SearchRequest
msg: system failure: java.lang.NullPointerException
code: service.FAILURE
detail: soap:Receiver
trace: btpool0-20:1238665009982:de4c3b4c4d5afb98

How does zimbra index the emails? Is it /opt/zimbra/index? Anyone have any further ideas?