Results 1 to 9 of 9

Thread: [SOLVED] Backup / Restore with tgz formatter

  1. #1
    Join Date
    Aug 2009
    Posts
    16
    Rep Power
    6

    Question [SOLVED] Backup / Restore with tgz formatter

    Hello,

    I am using these 2 commands for migrating accounts from server 1 to server 2 (both in the same version) :

    Code:
    /opt/zimbra/bin/zmmailbox -z -m user@domain.com getRestURL “//?fmt=tgz” > /tmp/account.tgz
    and

    Code:
    /opt/zimbra/bin/zmmailbox -z -m user@domain.com postRestURL “//?fmt=tgz&resolve=reset” /tmp/account.tgz
    But now I want to use the same method for a 'update' operation on the same server for a test from version 5.0.18 to 6RC1

    But it seems that the tgz file resulting in the backup on version 5 in not compatible with tgz for version 6 ???

    As I can't use imapsync, what other tool I can use ?

    Thanks.

    PS : sorry, but this post should be in the 'Migration' forum.
    Last edited by iXô; 08-27-2009 at 03:40 PM. Reason: wrong forum notice

  2. #2
    Join Date
    Aug 2009
    Posts
    16
    Rep Power
    6

    Default

    Can I just copy the 'store' folder ?

    What will I loose if I use this trick ? I read that I may loose 'metadata', ok but what are metadata ?

    With this trick, if think that the index is not copied too, is the index can be recreated ? what is it used for ?

    And what about the database ? as between v5 et v6 schema as changed, I don't know how to reimport data from the database. Is it really important ?


    Thanks.

  3. #3
    Join Date
    Aug 2009
    Posts
    16
    Rep Power
    6

    Default

    Here is the ouput that the version 6 gave me for a restoration of a backup of the version 5.0.18 :

    Code:
    ERROR: service.FAILURE (system failure: POST failed, status=500 system failure: tgz formatter failure)
    com.zimbra.common.service.ServiceException: system failure: POST failed, status=500 system failure: tgz formatter failure
    ExceptionId:main:1251446767295:aaf27a255c491475
    Code:service.FAILURE
    	at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:251)
    	at com.zimbra.cs.zclient.ZMailbox.postRESTResource(ZMailbox.java:2624)
    	at com.zimbra.cs.zclient.ZMailboxUtil.doPostRestURL(ZMailboxUtil.java:2691)
    	at com.zimbra.cs.zclient.ZMailboxUtil.execute(ZMailboxUtil.java:1114)
    	at com.zimbra.cs.zclient.ZMailboxUtil.main(ZMailboxUtil.java:2574)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:585)
    	at com.zimbra.common.util.ConsoleRunner.main(ConsoleRunner.java:96)

  4. #4
    Join Date
    Aug 2009
    Posts
    16
    Rep Power
    6

    Default

    Nervermind, I managed to use imapsync finally.

  5. #5
    Join Date
    Jul 2007
    Location
    Austria
    Posts
    40
    Rep Power
    8

    Default

    Actually ist is NOT solved. This is a workaround.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by mtanzer View Post
    Actually ist is NOT solved.
    ..... and the point of adding this to a thread that's almost four years old I what?

    Quote Originally Posted by mtanzer View Post
    This is a workaround.
    A 'solution' in this case is what worked for the o/p, nobody said the original problem was solved.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Jun 2013
    Posts
    1
    Rep Power
    2

    Thumbs up I got the solution to this issue

    Quote Originally Posted by phoenix View Post
    ..... and the point of adding this to a thread that's almost four years old I what?

    A 'solution' in this case is what worked for the o/p, nobody said the original problem was solved.

    I understand that it is a closed message, but it had not solution until this time.

    I solved this issue replacing the & (ampersand symbol) with the equivalent to URLs: %26%.

    When I tested the "&" in Zimbra 6 there was not problem, but when migrate to Zimbra 8 the problem appeared.

    So in any message of this forum this solution doesnt appears and this is my contribution.

    Code:
    /opt/zimbra/bin/zmmailbox -z -m user@domain.com postRestURL “//?fmt=tgz%26%resolve=reset” /tmp/account.tgz

  8. #8
    Join Date
    Mar 2009
    Location
    Vitória - ES - Brazil
    Posts
    63
    Rep Power
    6

    Default

    Quote Originally Posted by frss03 View Post
    I understand that it is a closed message, but it had not solution until this time.

    I solved this issue replacing the & (ampersand symbol) with the equivalent to URLs: %26%.

    When I tested the "&" in Zimbra 6 there was not problem, but when migrate to Zimbra 8 the problem appeared.

    So in any message of this forum this solution doesnt appears and this is my contribution.

    Code:
    /opt/zimbra/bin/zmmailbox -z -m user@domain.com postRestURL “//?fmt=tgz%26%resolve=reset” /tmp/account.tgz
    Hi in my case after replacing the & for %26% error changed


    /opt/zimbra/bin/zmmailbox -z -m space@mydomain postRestURL "//?fmt=tgz%26%resolve=reset" /root/prg/space@mydomain
    ERROR: service.FAILURE (system failure: POST failed, status=400 error parsing message)

    Thanks for help..

  9. #9
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    8

    Default

    zmztozmig can also be used for zimbra to zimbra migration.

    zimbra@zcs147:~$ /opt/zimbra/libexec/zmztozmig -h
    usage:
    *********************
    zmztozmig -[options]
    Options details:
    -v --version Prints version
    -h --help Shows help
    -f --ConfigFile Config file path
    [default file -> /opt/zimbra/conf/zmztozmig.conf ]
    -d --debug prints versbose debug messages
    ~=Prashant=~

Similar Threads

  1. Replies: 658
    Last Post: 04-04-2014, 09:01 AM
  2. zimbra opesource Backup Script Problem!
    By tashi in forum Administrators
    Replies: 4
    Last Post: 03-30-2009, 11:49 PM
  3. Zimbra Open Source Backup Help
    By ayush1440 in forum Administrators
    Replies: 8
    Last Post: 11-13-2008, 03:56 AM
  4. Restore specific network edition backup
    By sdemeyer in forum Administrators
    Replies: 5
    Last Post: 09-07-2008, 09:04 PM
  5. [SOLVED] Backups failing, "unable to read metadata for account"
    By smcgrath1111 in forum Administrators
    Replies: 10
    Last Post: 04-10-2008, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •