Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Return-Path changed after upgrade

  1. #1
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default [SOLVED] Return-Path changed after upgrade

    Hi all,

    I have upgraded Zimbra 5.0.10 to 6.0.1. Everything works fine except one thing. As username we have a local name like (example) user@domain.lan.

    To send e-mail we use real email addresses. We have added these addresses through the option menu: email -> accounts we have a real email address like (example) user@domain.com.

    After the upgrade the Return-Path have changes. Before the upgrade the Return-Path was the real e-mail address used by the FROM field. After the upgrade the Return-Path have changed to the local email address a.k.a. the username. Because this is as a fake email address email is rejected by several mail servers.

    Is there a way to manipulate the Return-Path? I think it has something to do with the Postfix configuration. But I can't find a solution.

    Hope someone can help me with this.
    Kind regards,
    DaniŽl Westhoek

  2. #2
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default

    Sorry Found the solution. Use Domain Masquerading

    Domain Masquerading

    If you want mail from user@domain.com or user@zimbra.domain.com to appear to come from user@example.com, you can set the canonical address for the entire domain.

    zmprov md domain.com zimbraMailCatchAllAddress @domain.com zimbraMailCatchAllCanonicalAddress @example.com
    zmprov md zimbra.domain.com zimbraMailCatchAllAddress @zimbra.domain.com zimbraMailCatchAllCanonicalAddress @example.com
    Kind regards,
    DaniŽl Westhoek

  3. #3
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default

    Well.... is wasn't the solution after all. So I will ask again for a solution.

    Her is the problem after upgrading from 5.0.10 to 6.0.1:

    My company has 20 users only a few of them have a real e-mail address. Most of them doesn't have a real e-mail address. But internal it has to be possible to send e-mail to each other and make use of the groupware possibilities of Zimbra. So we decided to use fake, non existing e-mail address for internal usage. Everyone had an internal e-mail address like: abc@domain.lan. (the first three characters at the front are the first tree charachters of the persons name, so John gets an internal e-mail address like joh@domain.lan. With this solution we can e-mail to each other internally.

    For the real big world we use a couple of e-mail addresses like sales@domain.com, finance@domain.com, etc. Per user I have set up the e-mail address on which he/she can send e-mail out. (through OPTIONS -> Accounts -> Primary Accounts Settings -> Messages sent from this account have the following settings (choose the name that appears in the "From" field of email messages)

    For example, when John sends an e-mail to the "real world" his Name and E-mail address in the From appears like "John Doe" sales@domain.com.

    After upgrade from 5.0.10 to 6.0.1 we get a lot of bounce mail. Why? After a little search I figured out that the return-path in the e-mail header has changed. In the 5.0.10 situation the option return-path get the real e-mail adres, like sales@domain.com. But in 6.0.1 the option return-path get the internal e-mail address line joh@domain.lan. Because joh@domain.lan doesn't exists in the real world it is signed as SPAM and get bounced.

    I used domain masquerade (se above post) to appear domain.lan as domain.com. But that changes only the domain part of the e-mail address. so when John now sends e-mail the return-path is like joh@domain.com. And I want it to be sales@domain.com. Why? because we still get bounce mail when a mailserver is very strict in looking at SPAM. When it appears that joh@domain.com doesn't exists (and that's true) the e-mail will be bounced.

    So what I want is the old situation, where the option return-path likely was the information added through OPTIONS -> Accounts -> Primary Accounts Settings -> Messages sent from this account have the following settings (choose the name that appears in the "From" field of email messages.

    I really hope someone can help me further with this one.
    Last edited by danielw; 10-29-2009 at 02:32 AM.
    Kind regards,
    DaniŽl Westhoek

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

  5. #5
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default

    Thanks for you reply, but that's exact what I don't want.

    The problem I have is that I not want return-path to be the primary (logged in user) e-mail address, but the e-mail address I have added through OPTIONS -> Accounts -> Primary Accounts Settings -> Messages sent from this account have the following settings (choose the name that appears in the "From" field of email messages.

    So, I think you can say that I want return-path to be the send-on-behalf address. (not sure if I really can call it send-on-behalf) This was so in version 5.0.10.
    Kind regards,
    DaniŽl Westhoek

  6. #6
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default

    Found it. Use Canonical Address. See: http://www.zimbra.com/forums/adminis...l-address.html
    Kind regards,
    DaniŽl Westhoek

  7. #7
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I am not sure if that will fix it though ... Return Path gets written by Postfix just before delivery by the clean up agent. Let us know how you get on.

  8. #8
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default

    I'm testing it right now. And now it works just like I want.

    When I put sales@domain.com in the canonical address (user account properties in the admin interface) and John Doe sends out an e-mail return-path gives: sales@domain.com. When I remove the canonical address return-path gives joh@domain.com

    So it seems to work fine for mine situation now.

    The only problem you can face with this solution is that when you use different persona with different e-mail addresses, that will not work anymore.This is because it always uses the e-mail address used in the canonical address. So keep that in mind when you make use of the canonical address field!
    Kind regards,
    DaniŽl Westhoek

  9. #9
    Join Date
    Jun 2008
    Posts
    8
    Rep Power
    7

    Default

    I have a similar issue.
    When i send a mail, my local Domain is used in return path.
    I set canonical address but that is not the solution.
    When i have multiple identities, the Address is always overwritten by the canonical address, what isn't the way it should work.
    It worked fine in 5.0.6 but after an upgrade to 5.0.19 it stopped working as it should.

    Has anybody a solution for this problem?

  10. #10
    Join Date
    Oct 2008
    Location
    The Netherlands
    Posts
    24
    Rep Power
    6

    Default

    When you use multiple addresses then my solution isn't a solution.

    Well, it worked indeed in older versions. But there has been a change in postfix (I think) which cause this problem.

    To fix this issue, you have to look to the code which writes down the line to postfix. But I can't help you with that. That goes way to deep in the code for me!
    Kind regards,
    DaniŽl Westhoek

Similar Threads

  1. Errors installing Outlook Connector
    By Tim G in forum Zimbra Connector for Outlook
    Replies: 57
    Last Post: 05-05-2011, 02:27 PM
  2. Replies: 0
    Last Post: 06-09-2008, 10:34 AM
  3. Error Installing Outlook Connector
    By DanO in forum Zimbra Connector for Outlook
    Replies: 17
    Last Post: 08-28-2007, 09:35 AM
  4. 5.0 Install tasks
    By JoshuaPrismon in forum Installation
    Replies: 2
    Last Post: 06-06-2007, 12:18 PM
  5. httpd resident in memory but not accessible
    By AlexanderH in forum Installation
    Replies: 3
    Last Post: 05-11-2007, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •