Results 1 to 3 of 3

Thread: [SOLVED] slapadd import failed - upgrade fr. 5.0.20 to 6.0.2 oss

  1. #1
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Question [SOLVED] slapadd import failed - upgrade fr. 5.0.20 to 6.0.2 oss

    Hi ALL,

    During the upgrade from zcs oss 5.0.20 to 6.0.2 on the Ubuntu 8.04LTS platform, there is an error saying "Migrating ldap data... slapadd import failed. UPGRADE FAILED."

    Does anyone can advise the root cause and how to fix it? Many thanks!!
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    The installer needs to know about other versions, so when a FRANKLIN(5) is released after a particular GNR(6) build - you can't upgrade from that 'newer' v5 to an 'older' v6.

    I know it defies expected logic since it's a 'newer' v5 but schema wise it's not yet built into the 'older' v6's upgrade steps.

    For exiting earlier: Bug 42687 – ZCS install should identify and validate version from which upgraded & discussed in: Bug 42609 – Upgrade from 5.0.19 to 6.0.0 or 6.0.1 fails - slapadd import failed around zimbraFeatureVoiceChangePinEnabled.

    If you flip through the announcements section you'll get a sense of release dates.

    So the only 5 > 6 paths that are possible right now are:
    5.0.19 & prior > 6.0.2+
    5.0.18 & prior > 6.0.2 (& anything after 6.0.0RC1 but not worth your time)

    Thus you will have to wait till 5.0.21 & 6.0.4 since you can't upgrade major versions from a FRANKLIN(5) release that is 'newer' than an 'older' GNR(6) release. (Not gonna discuss possible hacks here.)

    5.0.20 is 'newer' than 6.0.2 and actually still 'newer' than the upcoming 6.0.3 because its essentially 6.0.2 with security fixes.

  3. #3
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

Similar Threads

  1. Problem upgrading to 6; slapadd import failed
    By gtr33m in forum Installation
    Replies: 9
    Last Post: 02-19-2010, 05:49 AM
  2. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  3. Upgrade 5.0.2 to 5.0.4 OSS Failed
    By Grejao in forum Installation
    Replies: 15
    Last Post: 04-04-2008, 02:13 PM
  4. [SOLVED] Upgrade 5.0.2 to 5.0.4 OSS Failed
    By Chewie71 in forum Installation
    Replies: 3
    Last Post: 03-25-2008, 12:01 AM
  5. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •