Results 1 to 4 of 4

Thread: mbox to imap

  1. #1
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default mbox to imap

    Hi everyone.

    I'm currently fighting with a mbox migration (I'm not the only one, considering the threads on the subject) on 5.0.20.

    I'm using the Python mbox2imap script but I'm having several issues with it.
    This is the one I'm using : http://people.cs.uchicago.edu/~brend...ipts/mbox2imap

    First of all, the imported messages are shown with the import date/time in the ZWC, not the message date.
    Fixing it is quite easy but needs to re-import each message: you just have to use the "Thunderbird hack", ie add "/tb" at the end of the username.

    Then, I have a first issue when dealing with recursive import. The script fails with a Python error (and I don't code Python at all). I fixed this by removing ".group(1)" at the end of line 285.

    But the worst issue, still in recursive import, is the way the folders are created on the ZCS server.
    mbox2imap creates the folders tree based on the mbox files folders (on the hardrive) and, as it's using IMAP, it uses dot in order to separate the levels.

    Example, on the hardrive, I have several folders and files (each file is a mbox file):
    /import
    /import/leads
    /import/leads/yahoo
    /import/leads/google
    /import/leads/microsoft

    mbox2imap creates, on the ZCS server, these folders using IMAP:
    import
    import.leads
    import.leads.yahoo
    import.leads.google
    import.leads.microsoft

    The dot is supposed to be the IMAP separator between folder and sub-folder but this doesn't work (at all): in the ZWC, instead of getting the same tree than on the harddisk, I'm getting all the folders at the same level with the dots in their name...

    Does anyone know why the dot is not working properly as separator in IMAP?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Change the IMAP separator in the script to be a slash instead ?

  3. #3
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    When the folders already exists, I can rename them to anything (even with slash in the name) with no problem. I'm afraid it'll be the same on creation.

    And I'm quite sure the dot is "IMAP standard" while slash is not.

    I'll try this tonight and let you know.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

Similar Threads

  1. 'Couldn't access Yahoo! Zimbra Desktop server"
    By chirag1 in forum Error Reports
    Replies: 37
    Last Post: 06-12-2011, 06:14 PM
  2. [SOLVED] Sudden problem synching with gmail
    By bouchardpie in forum Error Reports
    Replies: 8
    Last Post: 09-09-2010, 10:50 AM
  3. [SOLVED] Sync problem with Yahoo! mail
    By ivan_de_miguel in forum Error Reports
    Replies: 1
    Last Post: 09-10-2009, 02:04 AM
  4. Error using Zimbra Desktop with all folders
    By randhirv in forum Error Reports
    Replies: 3
    Last Post: 01-24-2009, 01:01 AM
  5. Error on IMAP - Tomcat crashes!
    By rodrigoccurvo in forum Administrators
    Replies: 5
    Last Post: 11-30-2005, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •