Results 1 to 6 of 6

Thread: [SOLVED] Moving zimbra 64bits to a more spacious server

  1. #1
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default [SOLVED] Moving zimbra 64bits to a more spacious server

    I have tried to move zimbra from one server to another doing the following:

    successfully move the directory to the remote location
    -scp -P [port] -r /opt/zimbra user@remoteservername:./zimbra destination

    -Install zimbra on the new server

    Remove the zimbra directory from the new server using the following command
    -rm -rf /opt/zimbra

    Sync the zimbra directory that was copied to the new server
    rsync -avr zimbra /opt

    reinstall zimbra as to upgrade it

    and had an error message...Below is the error message

    Error: assertion '-r /bin/mysqld_safe' failed

    Please tell me what is the best way to move my zimbra to a more spacious server.

    Thanks

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    it's possible some of your permissions got messed up syncing to the new server i'd try to run

    /opt/zimbra/libexec/zmfixperms

    see if that helps

  3. #3
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    11

    Default

    please read this and see what you missed.
    http://www.zimbrablog.com/blog/archi...er-server.html

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  4. #4
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    I tried the /opt/zimbra/libexec/zmfixperms and also added the -extended at the end, but still had the same problem...I will look at the blog that raj posted...
    Thanks gentlemen

  5. #5
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    Quote Originally Posted by raj View Post
    please read this and see what you missed.
    Moving ZCS to Another Server » Zimbra :: Blog

    Raj
    I have follow the blog that you sent me and after running the last install with -s option, I saw the following:
    Running bdb db_recover...done.
    Running zmldapapplyldif...failed
    Checking ldap status...not running
    Starting ldap...failed with exit code:256.
    This continues with a loop....
    Please help

  6. #6
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    Quote Originally Posted by borngunners View Post
    I have follow the blog that you sent me and after running the last install with -s option, I saw the following:


    This continues with a loop....
    Please help
    I have successfuly solve the problem using the following link for Open Source Edition:
    Moving ZCS to New Server - Zimbra :: Wiki

    Please after removing /opt/zimbra and replacing it with the backup, don't upgrade. There is no need for that.
    The only thing that you should do is run the following command as root:
    /opt/zimbra/libexec/zmfixperms
    then su zimbra, and start zimbra

Similar Threads

  1. Upgrade to ZCS 5.10
    By blozancic in forum Installation
    Replies: 0
    Last Post: 10-21-2008, 09:03 AM
  2. [SOLVED] Why my MTA Cross???
    By fsloke in forum Installation
    Replies: 6
    Last Post: 07-30-2008, 09:55 PM
  3. My Zimbra Server crashed this morning...
    By glitch23 in forum Administrators
    Replies: 3
    Last Post: 04-07-2008, 02:28 PM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •