Results 1 to 7 of 7

Thread: Debian4-Zimbra5 to Debian5-Zimbra6

  1. #1
    Join Date
    Nov 2008
    Location
    Maine
    Posts
    16
    Rep Power
    6

    Default Debian4-Zimbra5 to Debian5-Zimbra6

    I've been trying procedure after procedure to move from Debian4-Zimbra5 to Debian5-Zimbra6.

    I've tried these steps...
    Upgrade path from Zimbra 5 on Debian 4 to Zimbra 6 on Debian 5 | Nothing here. Move along.

    Once I upgrade from Debian4-Zimbra5 to Debian4-Zimbra6 the CPUs spike (side-by-side VM comparison at idle Debian4-Zimbra6=1434mhz Debian5-Zimbra6=22mhz), IMAP/CalDAV aren't accessible (side-by-side comparison Debian5-Zimbra6 is accessible with the same server and client conf), and in the admin interface some of the queue and stats don't load correctly.

    Code:
    zimbra@mailserver:~$ zmcontrol status
    Host mailserver.domain.tld
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            memcached               Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
    So from here I would then upgrade Debian4 to Debian5 which is step 4 and runs smoothly.

    Step 5 is when everything comes to a halt...
    Code:
    aptitude install libstdc++5 sysstat
    Code:
    ./install.sh
    
    Operations logged to /tmp/install.log.4173
    Checking for existing installation...
        zimbra-ldap...FOUND zimbra-ldap-6.0.4_GA_2038.DEBIAN4.0
        zimbra-logger...FOUND zimbra-logger-6.0.4_GA_2038.DEBIAN4.0
        zimbra-mta...FOUND zimbra-mta-6.0.4_GA_2038.DEBIAN4.0
        zimbra-snmp...FOUND zimbra-snmp-6.0.4_GA_2038.DEBIAN4.0
        zimbra-store...FOUND zimbra-store-6.0.4_GA_2038.DEBIAN4.0
        zimbra-apache...FOUND zimbra-apache-6.0.4_GA_2038.DEBIAN4.0
        zimbra-spell...FOUND zimbra-spell-6.0.4_GA_2038.DEBIAN4.0
        zimbra-convertd...NOT FOUND
        zimbra-memcached...FOUND zimbra-memcached-6.0.4_GA_2038.DEBIAN4.0
        zimbra-proxy...FOUND zimbra-proxy-6.0.4_GA_2038.DEBIAN4.0
        zimbra-archiving...NOT FOUND
        zimbra-cluster...NOT FOUND
        zimbra-core...FOUND zimbra-core-6.0.4_GA_2038.DEBIAN4.0
    ZCS upgrade from 6.0.4 to 6.0.4 will be performed.
    
    Saving existing configuration file to /opt/zimbra/.saveconfig
    
    
    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.
    
    License Terms for the Zimbra Collaboration Suite:
      http://www.zimbra.com/license/zimbra_public_eula_2.1.html
    
    
    Press Return to continue
    
    Checking for prerequisites...
         FOUND: NPTL
         FOUND: sudo-1.6.9p17-2
         FOUND: libidn11-1.8+20080606-1
         FOUND: libpcre3-7.6-2.1
         FOUND: libgmp3c2-2:4.2.2+dfsg-3
         FOUND: libexpat1-2.0.1-4+lenny3
         FOUND: libstdc++6-4.3.2-1.1
         FOUND: libstdc++5-1:3.3.6-18
    Checking for suggested prerequisites...
        FOUND: perl-5.10.0
        FOUND: sysstat
    Prerequisite check complete.
    Checking current number of databases...
    
    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases.  This may take a while.
    Starting mysqld...done.
    mysqld is alive
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Tstack_sp_ptr
    mysqld is alive
    Stopping mysqld... done.
    I added the Etch source list to apt
    Code:
    deb http://ftp.us.debian.org/debian/ lenny main
    deb-src http://ftp.us.debian.org/debian/ lenny main
    
    deb http://security.debian.org/ lenny/updates main
    deb-src http://security.debian.org/ lenny/updates main
    
    deb http://volatile.debian.org/debian-volatile lenny/volatile main
    deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
    
    deb http://ftp.us.debian.org/debian/ etch main
    deb-src http://ftp.us.debian.org/debian/ etch main
    
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    Code:
    aptitude update
    Code:
    aptitude install perl=5.8.8-7etch6 perl-base=5.8.8-7etch6 perl-modules=5.8.8-7etch6 perl-doc=5.8.8-7etch6
    Code:
    for p in perl perl-base perl-modules perl-doc liblocale-gettext-perl libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl; do echo "${p} hold" | sudo dpkg --set-selections; done
    This got me past verifying the DB...
    Code:
    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases.  This may take a while.
    Starting mysqld...done.
    mysqld is alive
    No errors found
    mysqld is alive
    Stopping mysqld... done.
    Installed packages...
    Code:
    Installing packages
    
        zimbra-core......zimbra-core_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-ldap......zimbra-ldap_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-logger......zimbra-logger_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-mta......zimbra-mta_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-snmp......zimbra-snmp_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-store......zimbra-store_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-apache......zimbra-apache_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-spell......zimbra-spell_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-memcached......zimbra-memcached_6.0.4_GA_2038.DEBIAN5_i386.deb...done
        zimbra-proxy......zimbra-proxy_6.0.4_GA_2038.DEBIAN5_i386.deb...done
    Started configuring...
    Code:
    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    ...
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Then crapped in my face again...
    Code:
    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Istack_sp_ptr
    I've tried...
    Zimbra - FedoraForum.org
    http://www.zimbra.com/forums/adminis..._sp_ptr-2.html
    and all they do is break perl...

    I've also researched and tried all of these...
    http://www.zimbra.com/forums/install...supported.html
    http://www.zimbra.com/forums/adminis...tu-8-10-a.html
    http://www.zimbra.com/forums/install...ian-lenny.html
    Moving ZCS to Another Server » Zimbra :: Blog
    Moving ZCS to New Server - Zimbra :: Wiki

    I'm at wits end...
    Now I've just build a fresh install of Debian5-Zimbra6 and will manually migrate everything over unless there is a way to nfs+rsync only the data and leave the broken Zimbra behind?
    Last edited by mlcdigital; 02-05-2010 at 07:28 AM.

  2. #2
    Join Date
    Dec 2007
    Location
    Ypsilanti, MI
    Posts
    145
    Rep Power
    7

    Default

    It looks like your link may be very similar, but here is how we generally recommend moving hardware:

    Ajcody-Notes-Server-Move - Zimbra :: Wiki

    You might consider moving to the new server on the existing version of zimbra, rather than upgrading to a new version and then upgrading. The way you're doing it, I'm not sure it's possible to tell whether it's the upgrade to ZCS6 or the move to the new hardware that is the cause of the issues you're seeing. At least if you move over on ZCS5 to the new OS/server, and wait a couple days to see if things are working properly, you'll know if the new OS is the cause or if ZCS6 is somehow broken.

    The perl symbol lookup error isn't a good one though, and makes me think you're using an OS zcs doesn't support. We test and build against the OS versions that we post for, and usually don't see issues like that. I'd be curious to know whether you're seeing that issue with ZCS 5 or ZCS 6, or both. Also what version and patch level OS you're using.

  3. #3
    Join Date
    Nov 2008
    Location
    Maine
    Posts
    16
    Rep Power
    6

    Default

    I thought about installing Debian 5 with ZCS5 to see if it runs correctly and then rsync the old data over.
    I'm using a clean build of Debian 4 without any custom installs.
    Code:
    Linux version 2.6.18-6-686 (Debian 2.6.18.dfsg.1-26etch1) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Thu Nov 5 16:28:13 UTC 2009
    The thing that jumps out at me is when I upgrade from ZCS5.21 to 6.04 on this Debian 4 build, the CPU spike and features/services don't work correctly (IMAP, stats).
    I'm going to try a clean install of Debian 5 with Zimbra 5. If it works verify zimbra_uid info from old to new server and migrate data then burn the system in to see if it works.

  4. #4
    Join Date
    Dec 2009
    Posts
    29
    Rep Power
    5

    Default

    Quote Originally Posted by mlcdigital View Post
    I thought about installing Debian 5 with ZCS5 to see if it runs correctly and then rsync the old data over.
    I'm using a clean build of Debian 4 without any custom installs.
    Code:
    Linux version 2.6.18-6-686 (Debian 2.6.18.dfsg.1-26etch1) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Thu Nov 5 16:28:13 UTC 2009
    The thing that jumps out at me is when I upgrade from ZCS5.21 to 6.04 on this Debian 4 build, the CPU spike and features/services don't work correctly (IMAP, stats).
    I'm going to try a clean install of Debian 5 with Zimbra 5. If it works verify zimbra_uid info from old to new server and migrate data then burn the system in to see if it works.
    Hi - I ran 6.0.2 (also upgraded to 6.0.3) OSS on Debian 5 64bit for 60 days and it was perfect. Everything worked. Then upgraded to 6.0.4 - everything seemed ok but then stats stopped working - data is stale and had to restart rsyslog. Upgraded to 6.0.5 and the server got worse - in 2 days the RAM usage was over 4GB and the stats problems persisted. I've searched around the forums but not found anything useful. So I'm coming to the conclusion that Debian 5 isn't the best platform for zimbra. I'm not trying to be a scaremonger or provoke a negative reaction - was was looking for a platform to replace a 10 year old slackware sendmail box that has never played up. I thought Debian was an excellent choice for stability.

    And this was with only 4 users in a test at a client's site. I'd be very interested in how you get on.

    sem

  5. #5
    Join Date
    Jul 2009
    Posts
    4
    Rep Power
    6

    Default

    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Istack_sp_ptr
    Do restart

  6. #6
    Join Date
    Nov 2008
    Location
    Maine
    Posts
    16
    Rep Power
    6

    Default

    Quote Originally Posted by sem View Post
    Hi - I ran 6.0.2 (also upgraded to 6.0.3) OSS on Debian 5 64bit for 60 days and it was perfect. Everything worked. Then upgraded to 6.0.4 - everything seemed ok but then stats stopped working - data is stale and had to restart rsyslog. Upgraded to 6.0.5 and the server got worse - in 2 days the RAM usage was over 4GB and the stats problems persisted. I've searched around the forums but not found anything useful. So I'm coming to the conclusion that Debian 5 isn't the best platform for zimbra. I'm not trying to be a scaremonger or provoke a negative reaction - was was looking for a platform to replace a 10 year old slackware sendmail box that has never played up. I thought Debian was an excellent choice for stability.

    And this was with only 4 users in a test at a client's site. I'd be very interested in how you get on.

    sem
    I installed Debain 5 x86 with Zimbra 6.0.4 and it ran smooth. I documented the steps here.
    Platform Specific - Zimbra :: Wiki

  7. #7
    Join Date
    Nov 2008
    Location
    Maine
    Posts
    16
    Rep Power
    6

    Default

    I've found a process that has worked...
    On the Debian4-Zimbra5 VM
    Code:
    apt-get install linux-image-2.6.24-etchnhalf.1-686
    After a week IO seemed to have locked up on the VM without any bugs in the logs but the VMware Server was still functioning. I did a little digging and found the solution to the VM freezing.
    http://kb.vmware.com/selfservice/mic...rnalId=1006427

    As I previously posted. I am able to install a clean Debian5-Zimbra6 that runs smooth.
    Platform Specific - Zimbra :: Wiki
    On the clean Debain5-Zimbra6 I created an account with the same username as the Debain4-Zimbra5 system.
    Then, on the Debian4-Zimbra5, I exported said account through the user interface.
    On the Debian5-Zimbra6 box I imported through the user interface and all the data moved over cleanly (with the exception of the chat folder I believe).
    Now I'm burning Debian5-Zimbra6 in to see if IO issues happen as well.
    Last edited by mlcdigital; 02-20-2010 at 01:28 PM.

Similar Threads

  1. Can't delete or rename account
    By nimag in forum Error Reports
    Replies: 17
    Last Post: 12-08-2008, 10:58 AM
  2. [SOLVED] Configure pidgin/gaim with Zimbra5?
    By speculatrix in forum Users
    Replies: 3
    Last Post: 05-05-2008, 02:35 AM
  3. Replies: 5
    Last Post: 03-03-2008, 03:58 PM
  4. zimbra5 - sending from another persona in Outlook - how?
    By ryanp in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 03-03-2008, 03:57 PM
  5. Replies: 2
    Last Post: 12-25-2007, 08:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •