Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: zimra on CenTOS domain name

Hybrid View

  1. #1
    Join Date
    Feb 2010
    Posts
    34
    Rep Power
    5

    Default zimra on CenTOS domain name

    hello,

    I have some problems about domain name zimbra on CenTOS.Like you.my old domain on exchange is username@localdomain.com,after migrating their domain name became username@localhost.localdomain.com.But ,I just want username@localdomain.com.Why it added localhost.localdomain.com.I looked at /etc/hosts files.In these files,I see that
    my ip address localhost.localdomain.com localhost does the zimbra take this instead of domain name?

    Thnak you

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    su - zimbra
    zmhostname
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quote

  3. #3
    Join Date
    Feb 2010
    Posts
    34
    Rep Power
    5

    Default hello

    zmhostname
    newyork.gata.com

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    192.168.2.9 newyork.gata.com newyork
    ::1 localhost6.localdomain6 localhost6

    cat /etc/resolv.conf
    nameserver 192.168.2.9
    nameserver 192.168.2.1

    dig newyork.gata.com mx
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> newyork.gata.com mx
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    dig newyork.gata.com any
    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> newyork.gata.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13602
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;newyork.gata.com. IN ANY

    ;; ANSWER SECTION:
    newyork.gata.com. 6477 IN A 216.197.121.178

    ;; Query time: 228 msec
    ;; SERVER: 192.168.2.1#53(192.168.2.1)
    ;; WHEN: Thu Mar 4 10:25:08 2010
    ;; MSG SIZE rcvd: 50

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Are you running a Split DNS - Zimbra :: Wiki as the MX lookup is resolving to your external IP and not the internal one.

  5. #5
    Join Date
    Feb 2010
    Posts
    34
    Rep Power
    5

    Default

    I will look at my bind configuration according to this article.But ,I configured my bind after installed zimbra.So,my adrres became username@newyork.gata.com immediately .Is it related with my bind?

    thanks

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Yes as it would have found that name as the MX record. Just add a domain alias for gata.com and rename your account.

  7. #7
    Join Date
    Feb 2010
    Posts
    34
    Rep Power
    5

    Default my bind files

    Hello ,

    my bind configuration is here,can you tell me where I am wrong?
    This is my /var/named/newyork.gata.com.zone
    $TTL 8600
    @ SOA ns1.newyork.gata.com. ns2.newyork.gata.com.(
    2004001 ; serial
    108000 ; refresh
    3600 ; retry
    315600 ; expire
    86400 ; caching TTL of 1 hour
    );

    @ IN NS ns1.newyork.gata.com.
    @ IN MX 10 gata.com.
    www IN A 192.168.2.9
    mail IN A 192.168.2.9
    ftp IN A 192.168.2.9

    This is my /etc/named.conf file
    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    query-source port 53;
    };
    include "/etc/rndc.key";
    // We are the master server for newyork.gata.com
    zone "newyork.gata.com" {
    type master;
    file "newyork.gata.com.zone";
    };

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    @ IN MX 10 gata.com.
    should be pointed at
    Code:
    @ IN MX 10 newyork.gata.com.
    and your server should have a A record
    Code:
    newyork IN A 192.168.2.9

  9. #9
    Join Date
    Feb 2010
    Posts
    34
    Rep Power
    5

    Default

    Hello uxbod,

    Firstly,Ihad made my mx newyork.gata.com,after that,I changed it to gata.com.Because,all emal address became username@newyork.gata.com,but I don't want this.I want username@gata.com.I want this,so I changed mx from newyork.gata.com to gata.com.

    Secondly,should ı add newyork IN A 192.168.2.9 to /var/named/newyork.gata.com.zone file?

    Thanks

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    If gata.com is your domain name then your zone should be
    Code:
    zone "gata.com" {
    type master;
    file "gata.com.zone";
    };
    and the contents of that zone file should look like
    Code:
    $TTL 8600
    @ SOA newyork.gata.com. admin.gata.com.(
    2004001 ; serial
    108000 ; refresh
    3600 ; retry
    315600 ; expire
    86400 ; caching TTL of 1 hour
    );
    
    @ IN NS newyork
    @ IN MX 10 newyork
    www IN A 192.168.2.9
    mail IN A 192.168.2.9
    ftp IN A 192.168.2.9
    newyork IN A 192.168.2.9

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 03:49 AM
  2. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  3. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 09:50 AM
  4. Zimbra startup hangs after install CentOS 4.2
    By eger in forum Installation
    Replies: 4
    Last Post: 02-10-2006, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •