Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Tomcat broken after upgrade to 4

  1. #11
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default

    Our email server is still down. I have not yet been able to fix this. Any advice would be great.

  2. #12
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    the passwords are not encrypted, they're just long character strings. what happens when you run these commands:

    su - zimbra
    which mysql
    mysql

    this wiki page explains how to get the passwords realigned between the config settings and the mysql user db:
    Resetting LDAP & MySQL Passwords

  3. #13
    Join Date
    Apr 2006
    Posts
    23
    Rep Power
    9

    Default

    This is what I got when running those commands:

    [root@mail ~]# su - zimbra
    [zimbra@mail ~]$ which mysql
    ~/bin/mysql
    [zimbra@mail ~]$ mysql
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 4437 to server version: 4.1.20-log

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>
    I reset the root and zimbra password and tomcat still doesnt run. Do I need to reset everything on that link you sent? Thanks.

    edit: I was going through the rest of that document to reset the passwords and when I get to the mysql command after setting the --skip-grant-tables \ option it errors out with this:

    [zimbra@mail ~]$ which mysql
    ~/bin/mysql
    [zimbra@mail ~]$ mysql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    [zimbra@mail ~]$

    I can't continue because I can't connect. Any ideas? Thanks!
    Last edited by dotslashroot; 09-06-2006 at 05:15 PM.

  4. #14
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    go back to running without the --skip-grant-tables option and post the output of this:

    su - zimbra
    mysql mysql
    select host, user, password from user;

Similar Threads

  1. Tomcat crashes after upgrade to 4.0.2
    By demanl in forum Administrators
    Replies: 13
    Last Post: 09-18-2007, 12:19 PM
  2. zmtrainsa broken after upgrade to v 4.0
    By sourcehound in forum Administrators
    Replies: 27
    Last Post: 10-18-2006, 06:27 AM
  3. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-28-2006, 11:36 PM
  4. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •