Results 1 to 3 of 3

Thread: system failure: ZimbraLdapContext when importing mail using zmmailbox

  1. #1
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    5

    Default system failure: ZimbraLdapContext when importing mail using zmmailbox

    All,



    I've copied the "home" directory of my old postfix mail server into my directory on the Zimbra server, and written a little script that parses it and then generates a list of zmmailbox commands like:

    Code:
    selectMailbox jendreka@oplin.org
    createFolder /old_mail
    createFolder "/old_mail/Policy"
    addMessage "/old_mail/Policy" "/home/jendreka/home/jendreka/Maildir/.Policy/cur"
    addMessage "/old_mail/Policy" "/home/jendreka/home/jendreka/Maildir/.Policy/new"
    createFolder "/old_mail/Sent"
    addMessage "/old_mail/Sent" "/home/jendreka/home/jendreka/Maildir/.Sent/cur"
    addMessage "/old_mail/Sent" "/home/jendreka/home/jendreka/Maildir/.Sent/new"
    And then I run the import with:
    /opt/zimbra/bin/zmmailbox -z -f /home/jendreka/mail_import_commands.txt

    Everything seems to work great up until it throws the error:

    Code:
    ERROR: service.FAILURE (system failure: ZimbraLdapContext)
    And then the whole thing falls over. The list of commands I'm feeding it is about 45,000 lines long, and it doesn't seem to die at the same place twice, so I don't think it's related to a specific user/email. I wrote another script that breaks the chunks of commands up by user, and waits 3 seconds between users, and it goes for longer, but ultimately it still dies. I get the feeling I'm overwhelming something. Any direction would be greatly appreciated.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Why don't you use IMAPSYNC?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    5

    Default

    I just figured that since I had a command line utility available, it would be easier and faster to just copy the file structure over and import it this way, and had things not died it would have been.

    Am I running into some sort of known issue?

    Also, I'll go ahead and take another look at imapsync.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. [SOLVED] Cannot receive incoming mail but can send.
    By windependence in forum Administrators
    Replies: 2
    Last Post: 03-23-2010, 03:43 AM
  3. No email in or out
    By ValueVPS in forum Installation
    Replies: 37
    Last Post: 01-13-2010, 12:56 PM
  4. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  5. Issues...
    By timothyalangorman in forum Administrators
    Replies: 3
    Last Post: 11-19-2007, 10:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •