Results 1 to 1 of 1

Thread: upgrade not terminated properly

Hybrid View

  1. #1
    Join Date
    Jan 2006
    Posts
    16
    Rep Power
    9

    Default upgrade not terminated properly

    ....the problem mentioned below is solved. I simply restarted the install.sh script again, this time the update worked flawlessly, most parts of zimbra work again. I only have to reapply a few patches necessary for vserver operation (mostly replacement of references to 127.0.0.1 here and there).

    Regards
    --Marcel

    Hi all

    I tried to upgrade my vserver-based zcs-3.1.4_GA_518.FC4 to zcs-4.0.1_GA_324.FC4. All modules could be installed properly, but at the end the procedure failed to upgrade my data store.

    Before upgrading, the system forced me to modify the /etc/hosts file to something that does not work within my vserver. Because I have a linux-vserver, I cannot put a "127.0.0.1 localhosts" entry in my hosts file. zcs-3.1.4 worked fine with my alternate hosts file with one single line:

    192.168.193.36 localhost.localdomain localhost v-zimbra.milnet.lan v-zimbra

    ...but the install script did not like that. So I had to modify this file temporarily to make the install script happy, but then reverted back to the version shown here.

    Now when I try to launch the admin panel, I get
    javax.servlet.UnavailableException: Data version mismatch. Reinitialize or upgrade the backend data store.
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 118)

    I would not mind to lose all data in the data store as long as I can keep my user accounts; this is a test installation anyway. How can I try to perform this "data store upgrade" by hand or reinitialize the data store for use with zcs-4 without losing my configuration/my accounts?

    Thanks for any help and best regards
    --Marcel
    Last edited by milprog; 09-20-2006 at 01:07 AM. Reason: problem solved

Similar Threads

  1. Replies: 6
    Last Post: 07-04-2007, 08:36 AM
  2. Upgrade 4.5.4 to 4.5.5 questions
    By dlochart in forum Zimbra Connector for Outlook
    Replies: 11
    Last Post: 05-14-2007, 02:44 AM
  3. Backup directory deleted during upgrade!
    By dlochart in forum Installation
    Replies: 2
    Last Post: 02-25-2007, 06:38 AM
  4. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-28-2006, 11:36 PM
  5. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •