Results 1 to 9 of 9

Thread: pst import sent items have from address in to field

  1. #1
    Join Date
    Oct 2010
    Location
    Netherlands, Groenlo
    Posts
    9
    Rep Power
    4

    Default pst import sent items have from address in to field

    hi,

    I run Release 6.0.9_GA_2686.RHEL5_64_20101115233514 CentOS5_64 FOSS edition. just updated five minutes ago...
    however, the migration below was done while running 6.0.8... did not find any notes about the zcs migration wiz in the 6.0.9 release notes so I think my question is still valid...

    a while ago I imported some mailboxes from a exch 2003 server. nearly everything went ok. not the sent items however. When we look in the list of sent items we see the from address of the owner of the mailbox in the "to" column.... when one opens the mail it tells the proper to address...

    while searching the forums for similar questions I read about a pst repair wizzard.
    I did NOT run that repair wizzard before the import. could it be that that qould have solved the problem?

    no errors regarding sent items where logged during the import.

    If not, is there any trick, sql script or smart idea that can change those addresses afterwards?
    I still have the pst's and I can rerun a import on a testmailbox if it makes any sense...

    thanks for taking the effort of reading my question and if you answer it: thanks in advance!

    if you need any more information please don't hesitate to ask!

    Kind regards,
    Alex

  2. #2
    Join Date
    Sep 2005
    Location
    Sydney, Australia
    Posts
    291
    Rep Power
    10

    Default

    Hi,
    I have found one of our users with the same problem, same stack as you.
    Did you find any fix for it? Anyone got any suggestion to try and troubleshoot it? The zimbra web client shows the sender in the To: field, just like Alex here.
    http://www.solutionsfirst.com.au/hosting/zimbra/
    Australia's premier Zimbra Hosting Partner
    Resellers wanted!

  3. #3
    Join Date
    Oct 2010
    Location
    Netherlands, Groenlo
    Posts
    9
    Rep Power
    4

    Default

    Hi Dave, I have not received any reply on this one...

    it would still be a nice thing to solve...

  4. #4
    Join Date
    Apr 2012
    Posts
    22
    Rep Power
    3

    Default Import from Mozilla has the same problem

    Import from Mozilla has the same problem,

    inbox are converted fine, but all sent emails have the same problem.

    When you select the message in the Web client or ZD, it shows correct address in the message details, but in the message list "To" field is taken from "From".


    And I think Zimbra developers are not going to fix this error as the first post is very old.

    We shall find another solution.

  5. #5
    Join Date
    Oct 2010
    Location
    Netherlands, Groenlo
    Posts
    9
    Rep Power
    4

    Default

    Hi Shal,

    I should file a bug report then on Bugzilla Main Page - Zimbra and post the bug# here. Is is my experience that good bugreports are picked up better by zimbra than forum posts. a forum is more for questions i think.

    good luck!

    Alex

  6. #6
    Join Date
    Apr 2012
    Posts
    22
    Rep Power
    3

    Default

    Alex, I noticed one more thing

    If I import a folder, I get the very first message with correct "To" address, but only FIRST one. Everything else is imported with error. I think you should add this to your report.

    Of course I think the best way is to file a bug report, but I noticed that the forum has A LOT of unanswered bugs. So much that I would not belive that people from Zimbra are selling this product. Seems they are absent from forum and they do not care at all.

    So I see two ways to correct this bug.

    The first way.
    1 export imported messages,
    2 fix errors in *.meta files in tgz archive,
    3 import fixed files back.

    The second way
    Make a PHP script that do this
    1. Connect to MySQL database in Zimbra server,
    2. Find MSG files in file system
    3. Take "To" field from MSG file
    4. Update database record in MySQL

    what you think about this?

  7. #7
    Join Date
    Oct 2010
    Location
    Netherlands, Groenlo
    Posts
    9
    Rep Power
    4

    Default

    Hi Shal,

    I'm not very often on this forum so I can't tell you whether Zimbra personnel is looking after bugs mentioned here.

    I wasn't very clear in my post I see, I meant "if I were you I should file a bug report". I haven't got very recent test data so it doesn't make sense for me to file one. Please enter as much info you can gather, but at least:
    1. how did you get/make the pst export? was is an export of Mozilla (what version?!)? how exactly did you create it? can you replay this with a nearly empty demo mailbox and attach the pst file?
    2. what version of zcs (zmcontrol -v, as in your profile here)
    3. describe exact import procedure.

    the details you mentioned here are usefull info as well.

    good luck and kind regards,
    Alex

  8. #8
    Join Date
    Apr 2012
    Posts
    22
    Rep Power
    3

    Default

    Quote Originally Posted by aswen View Post
    Hi Shal,
    1. how did you get/make the pst export? was is an export of Mozilla (what version?!)? how exactly did you create it? can you replay this with a nearly empty demo mailbox and attach the pst file?
    The problem in any import no matter what kind of source.
    I took Mozilla thunderbird Sent file, convert it to mbox format, and pack to tar and tgz


    Quote Originally Posted by aswen View Post
    2. what version of zcs (zmcontrol -v, as in your profile here)
    ANY version, I used the latest one and 7.1.4.

    Bug exists at least since 01-15-2010 and as far as I know there is no solution and developers do not care.

    http://www.zimbra.com/forums/adminis...d-sent-me.html

    Quote Originally Posted by aswen View Post
    3. describe exact import procedure.

    the details you mentioned here are usefull info as well.

    good luck and kind regards,
    Alex
    I will send detailed report lately

  9. #9
    Join Date
    Apr 2012
    Posts
    22
    Rep Power
    3

    Cool puzzle solved

    The solution is

    1. Copy EML files to the server
    2. Make them accesible by "zimbra" user (change owner/group)
    3. login as user "zimbra"
    4. type "zmmailbox" command, >mbox prompt will appear
    5. adminAuthenticate %user% %password%
    6. selectMailbox %mailbox%
    7. addMessage -Fs Sent %path_of_eml%

    '-Fs' means to add 's' tag (Sent by me)

    this import the messages in EML files from %path_of_eml% to "Sent" folder of %mailbox%

Similar Threads

  1. PST Import Wizard question
    By webman in forum Migration
    Replies: 2
    Last Post: 04-06-2008, 02:27 PM
  2. [SOLVED] PST import tool, error limit reached
    By Mike Scholes in forum Administrators
    Replies: 6
    Last Post: 12-14-2007, 09:16 AM
  3. PST Import - 96 hours?!?
    By plochner in forum Migration
    Replies: 7
    Last Post: 12-03-2007, 10:34 AM
  4. Replies: 1
    Last Post: 06-18-2007, 10:32 PM
  5. PST Import Questions
    By soxfan in forum Migration
    Replies: 2
    Last Post: 03-02-2007, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •