Results 1 to 4 of 4

Thread: Ldap Migration Error

  1. #1
    Join Date
    Mar 2010
    Location
    Egypt
    Posts
    41
    Rep Power
    5

    Default Ldap Migration Error

    Hi,
    i Have this error when i am trying to migrate ldap db

    [root@mail zimbra]# ./openldap/sbin/slapadd -F /opt/zimbra/data/ldap/config/ -l /tmp/ldap.ldif
    The first database does not allow slapadd; using the first available one (2)
    => hdb_tool_entry_put: id2entry_add failed: DB_KEYEXIST: Key/data pair already exists (-30995)
    => hdb_tool_entry_put: txn_aborted! DB_KEYEXIST: Key/data pair already exists (-30995)
    slapadd: could not add entry dn="cn=zimbra" (line=1): txn_aborted! DB_KEYEXIST: Key/data pair already exists (-30995)
    _ 0.44% eta none elapsed none spd 266.8 k/s
    Closing DB...

    Any Ideas?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Mido3mad View Post
    Hi,
    i Have this error when i am trying to migrate ldap db

    [root@mail zimbra]# ./openldap/sbin/slapadd -F /opt/zimbra/data/ldap/config/ -l /tmp/ldap.ldif
    The first database does not allow slapadd; using the first available one (2)
    => hdb_tool_entry_put: id2entry_add failed: DB_KEYEXIST: Key/data pair already exists (-30995)
    => hdb_tool_entry_put: txn_aborted! DB_KEYEXIST: Key/data pair already exists (-30995)
    slapadd: could not add entry dn="cn=zimbra" (line=1): txn_aborted! DB_KEYEXIST: Key/data pair already exists (-30995)
    _ 0.44% eta none elapsed none spd 266.8 k/s
    Closing DB...

    Any Ideas?
    Is this part of the moving your server to another server thread? This isn't a 'migration' question, it should have been added to the other thread. You're not actually giving any useful information about the circumstances under which this problem is happening, please expand your post about this problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2010
    Location
    Egypt
    Posts
    41
    Rep Power
    5

    Default

    i am using
    Release 5.0.20 on RHEL4 FOSS edition
    and i am trying to transfer ldap account and password to anther mail server with new domain
    so i export ldap.ldif file and edit the file by changing the domain name for each user manually so when i am trying to import the file in new mail that error occured

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Your version information should go in your forum profile, put the output of the following command in theer (do not post the output in this thread):

    Code:
    zmcontrol -v
    Quote Originally Posted by Mido3mad View Post
    and i am trying to transfer ldap account and password to anther mail server with new domain
    Why? Is it part of your other thread (as I asked you earlier)? Are both machines the same architecture?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Debian Etch 32 / 64: MTA not working
    By xflip in forum Installation
    Replies: 2
    Last Post: 01-18-2008, 03:58 AM
  3. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •