Results 1 to 10 of 10

Thread: Upgrade from FC4 to FC5

Threaded View

  1. #1
    Join Date
    Apr 2006
    Location
    San Jose, CA
    Posts
    23
    Rep Power
    9

    Default Upgrade from FC4 to FC5

    Hello folks,
    I just tried to upgrade FC4+3.1.3 OpenSource to FC5+4.0.2 with the following steps. If you guys know the better ways or ideas, kindly let me know.

    1. Backup /opt/zimbra dir and keep this safe place.
    ex. # tar cvfz zimbra_313.tgz /opt/zimbra (I correct the command because of typo in previous post...)

    2. Install FC5 from scratch.
    2-1. Disable SELinux
    2-2. Diable firewall
    2-4. yum -y update
    2-5. Install requirement software (Sudo, libidn, cURL, GMP, etc...)
    2-3. Install Openssl097a (just in case)

    yum install openssl097a
    cd /lib
    ln -s libssl.so.0.9.7a libssl.so.5
    ln -s libcrypto.so.0.9.7a libcrypto.so.5

    3. Install 4.0.2 with FC5 binary.

    4. Stop ZCS and remove /opt/zimbra

    5. Restore 3.1.3 dir to /opt/zimbra

    6. Start the Upgrade to 4.0.2 with FC5 binary

    7. Just before running server during installation (when the message "Notify Zimbra of your installation?" appears), do the followings to avoid further "zmprov" errors.
    7-1. remove rm /opt/zimbra/lib/jars/commons-httpclient-2.0.1.jar
    7-2. Renew SSL certificate
    7-3. Remove Logo.gif in Template directory (not necessary in some cases)

    (by root user)
    rm -rf /opt/zimbra/ssl
    mkdir /opt/zimbra/ssl
    chown zimbra:zimbra /opt/zimbra/ssl
    chown zimbra:zimbra /opt/zimbra/java/jre/lib/security/cacerts
    chmod 644 /opt/zimbra/java/jre/lib/security/cacerts
    rm -rf /opt/zimbra/lib/jars/commons-httpclient-2.0.1.jar
    rm -rf /opt/zimbra/wiki/Template/Logo.gif(not necessary in some cases)

    (by zimbra user)
    keytool -delete -alias my_ca -keystore /opt/zimbra/java/jre/lib/security/cacerts -storepass changeit
    keytool -delete -alias tomcat -keystore /opt/zimbra/tomcat/conf/keystore -storepass zimbra
    zmcreateca
    zmcreatecert
    zmcertinstall mailbox /opt/zimbra/ssl/ssl/server/tomcat.crt
    zmcertinstall mta /opt/zimbra/ssl/ssl/server/server.crt /opt/zimbra/ssl/ssl/server/server.key

    Thanks,
    Last edited by samotrak; 10-17-2006 at 05:16 PM. Reason: Some update

Similar Threads

  1. Upgrade from 3.1.3_GA_474 on FC4 to 4.5.1_GA_660
    By cjhall in forum Installation
    Replies: 3
    Last Post: 02-12-2007, 07:17 AM
  2. Replies: 7
    Last Post: 01-24-2007, 11:03 PM
  3. Zimbra 4.04 GA FC4 - Upgrade Failure
    By RJerrom in forum Installation
    Replies: 3
    Last Post: 12-08-2006, 12:10 PM
  4. fc4 zcs-3.0.1 -> 3.1 upgrade worked great.. almost
    By keyhman in forum Installation
    Replies: 29
    Last Post: 09-29-2006, 12:06 PM
  5. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •