Results 1 to 3 of 3

Thread: 4.01 to 4.02 upgrade problem (with solution)

  1. #1
    Join Date
    Sep 2006
    Greenville, SC
    Rep Power

    Default 4.01 to 4.02 upgrade problem (with solution)


    About a week ago I installed Zimbra on my Centos 4.4 powered server. The installation went without a hitch, except for two issues: The first was that the install died due to a missing key. A quick search of the forums found a solution to that. (zmsshkeygen && zmupdateauthkeys && tomcat restart)

    Once that was fixed, I tried to set up a documents area and got an error.. again, a quick search of the forums got me an answer (zmprov initNotebook 123456)

    After that, my Zimbra was running and life was good.

    Why do I bore you with this, do you ask?
    Because it points to the root cause of the subject of my post.

    Today, I decided to upgrade to 4.02. I shut down zimbra, grabbed the tarball, untarred it, ran, and everything was going dandy until this:

    Setting defaults...Setting defaults from existing config...Done
    Upgrading from  to 4.0.2_GA_362
    Thu Sep 28 17:33:27 2006: Stopping zimbra services
    Thu Sep 28 17:33:35 2006: Starting mysql
    Thu Sep 28 17:33:38 2006: SELECT value FROM config WHERE name = 'db.version'
    Thu Sep 28 17:33:38 2006: Checking logger mysql status
    Thu Sep 28 17:33:39 2006: Starting logger mysql
    Thu Sep 28 17:33:40 2006: SELECT value FROM config WHERE name = 'db.version'
    I can't upgrade version
    Geez. Everybody hates a quitter. Especially when my wife can't get her email! But I digress.

    So, I dug around in the code until I figured out that parses out versions by reading /opt/zimbra/.install_history. Further, in this particular scenario, it expects to see "CONFIGURED END" in that file, and if it doesn't, a variable is left in it's initialized state (empty), resulting in the behavior above. (Note the "Upgrading from to" line)

    Looking at .install_history, I saw that the CONFIGURED entries for the day I installed got up to "CONFIGURED setupSyslog" and then just stopped. What the?! Where's the "CONFIGURED END"?

    While figuring out how worked, I noticed that I could run against a saved config. Hey, these guys really know what they are doing! So I blew away the /opt/zimbra directory, restored from the backup I took before I started, and ran -c config.18869 (the config that got saved when I originally installed 4.01)
    Sure enough, zmsetup configured configInitNotebooks after setupSyslog this time, followed by CONFIGURED END. Woohoo! Back in business! I ran again, and the upgrade to 4.02 succeeded.

    Now usually at this time I'd be dancing around shaking my booty at the server, but since the server is in Texas and I'm in South Carolina, the dogs had to suffice.

    To summarize:
    The 4.01 install failed during configInitNotebooks (I would imagine), but not a hard enough failure to keep anything except documents from working.
    No "CONFIGURED END" == failed upgrade.

    I would recommend that anyone who plans to upgrade from 4.01 (which looks like it has an installation problem when it comes to documents) to 4.02 to check to make sure that /opt/zimbra/.install_history has a "CONFIGURED END" for every "CONFIGURED BEGIN". If it doesn't, you need to figure out what config process failed and fix it. If your scenario matches mine (4.01 setup failed during configInitNotebooks), I think the fix is to run "zmprov initNotebook 123456" and then run " -c <last saved config>" before you attempt to upgrade. Otherwise, you are doomed to failure.

    Zimbrans - Awesome product. From an admin point of view, this is the most fully featured, easy to work with, nicely integrated mail system I've ever seen. And I've seen a few. I almost forgive you for making me look at perl (the horror!)

    Charles (python guy)
    Last edited by criley; 09-28-2006 at 10:07 PM. Reason: speling

  2. #2
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Very nice. I have to say that I am verry impressed by your very first post.
    Welcome to the forums.

    Good job.
    Last edited by jholder; 09-28-2006 at 10:38 PM.

  3. #3
    Join Date
    Sep 2006
    Greenville, SC
    Rep Power


    Quote Originally Posted by wannabetenor
    Very nice. I have to say that I am verry impressed by your very first post.
    Welcome to the forums.

    Good job.
    Thanks! You'll probably be seeing more of me around the developer forums. I have a zimlet <->SugarCRM project in mind.


    ** No dogs were harmed during the previously described upgrade.

Similar Threads

  1. 4.5.6 -> 5.0 Upgrade Problem :(
    By uxbod in forum Installation
    Replies: 3
    Last Post: 07-21-2007, 08:02 PM
  2. 3.1.3OS Upgrade Problem
    By mcevoys in forum Installation
    Replies: 7
    Last Post: 06-16-2006, 09:47 AM
  3. 3.0.1 GA upgrade problem
    By kollross in forum Administrators
    Replies: 5
    Last Post: 04-04-2006, 10:42 AM
  4. Another odd GA upgrade problem (FYI)
    By meikka in forum Installation
    Replies: 0
    Last Post: 02-08-2006, 12:38 PM
  5. Odd GA upgrade problem
    By drewage in forum Installation
    Replies: 2
    Last Post: 02-08-2006, 09:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts