I'm attempting to use imapsync to convert a bunch of old Dovecot accounts over to the new Zimbra setup I installed a couple of days ago (it's the Open Source version, by the way). However, I keep getting errors from the program:

Code:
get options: [1]
$RCSfile: imapsync,v $ $Revision: 1.476 $ $Date: 2011/12/10 01:33:50 $ 
Here is a [linux] system (Linux localhost.localdomain 2.6.32-220.2.1.el6.centos.plus.x86_64 #1 SMP Thu Dec 22 23:32:31 GMT 2011 x86_64)
With perl 5.10.1 Mail::IMAPClient  2.2.9
Command line used:
/usr/bin/imapsync --maxsize 52428800 --buffersize 52428800 --fastio1 --fastio2 --nofoldersizes --nosyncacls --subscribe --syncinternaldates --noauthmd5 --authmech2 PLAIN --exclude (?i)\b(Junk|Spam|Trash)\b --skipheader X-* --regexflag s/\\\\(?!Answered|Flagged|Deleted|Seen|Recent|Draft)[^\s]*\s*//ig --regextrans2 s,:,-,g --regextrans2 s,\",',g --regextrans2 s,\s+(?=/|$),,g --regextrans2 s,^(Briefcase|Calendar|Contacts|Emailed Contacts|Notebook|Tasks)(?=/|$), $1 Folder,ig --host1 whistler.everydaystyle.com --host2 sunfire.everydaystyle.com --user1 orderprocessing --user2 orderprocessing@everydaystyle.com --password1 MASKED --authuser2 orderprocessing --password2 MASKED --regextrans2 s,\",-,g --regextrans2 s,&AAo-|&AA0ACg-|&AA0ACgANAAo-(?=/|$),,g --authmech1 PLAIN --dry --debug --debugimap
Temp directory is /tmp
PID file is /tmp/imapsync.pid
Modules version list:
Mail::IMAPClient     2.2.9
IO::Socket           1.31
IO::Socket::INET     1.31
IO::Socket::SSL      0.81
Digest::MD5          2.39
Digest::HMAC_MD5     1.01
Term::ReadKey        2.30
Authen::NTLM         1.09

IMAPClient 2.2.9
Info: turned ON syncinternaldates, will set the internal dates (arrival dates) on host2 same as host1.
Info: will try to use PLAIN authentication on host1
Info: will try to use PLAIN authentication on host2
Host1: imap server [whistler.everydaystyle.com] port [143] user [orderprocessing]
Host2: imap server [sunfire.everydaystyle.com] port [143] user [orderprocessing@everydaystyle.com]
Host1 connection
Entering myconnect
Calling configure
Read: * OK Dovecot ready.
Banner: * OK Dovecot ready.
Sending: 1 CAPABILITY

Sent 14 bytes
Info: host whistler.everydaystyle.com says it has CAPABILITY for AUTHENTICATE PLAIN
Sending: 2 AUTHENTICATE PLAIN

Sent 22 bytes
Sending: b3JkZXJwcm9jZXNzaW5nAG9yZGVycHJvY2Vzc2luZwAwcmQzcnByMGMzc3Mxbmc=

Sent 66 bytes
Info: success login on [whistler.everydaystyle.com] with user [orderprocessing] auth [PLAIN]
Host2 connection
Entering myconnect
Calling configure
Read: * OK localhost.localdomain Zimbra IMAP4rev1 server ready
Banner: * OK localhost.localdomain Zimbra IMAP4rev1 server ready
Sending: 1 CAPABILITY

Sent 14 bytes
Info: host sunfire.everydaystyle.com says it has CAPABILITY for AUTHENTICATE PLAIN
Sending: 2 AUTHENTICATE PLAIN

Sent 22 bytes
Sending: b3JkZXJwcm9jZXNzaW5nQGV2ZXJ5ZGF5c3R5bGUuY29tAG9yZGVycHJvY2Vzc2luZwBuMHdoM3Ij

Sent 78 bytes
Failure: error login [sunfire.everydaystyle.com] with user [orderprocessing@everydaystyle.com] auth [PLAIN]: 2 NO AUTHENTICATE failed
Failure: error login [sunfire.everydaystyle.com] with user [orderprocessing@everydaystyle.com] auth [PLAIN]: 2 NO AUTHENTICATE failed
Both accounts exist, I have logged into both of them via IMAP before, and I made sure that plaintext authentication is on, so that's definitely not the problem. Am I missing something here?