Results 1 to 4 of 4

Thread: Migrating From Scalix To Zimbra: Hostname?

Hybrid View

  1. #1
    smpoole7 Guest

    Default Migrating From Scalix To Zimbra: Hostname?

    I want to start by thanking every one of you folks who have anything to do with Zimbra. Nice product!

    We are currently running the Scalix mailserver and are ready to migrate. We couldn't get the [crypt}'d passwords to transfer into Zimbra, so, we set up a VirtualBox on another server machine, installed Zimbra in it and had all of our users (approx 400) log in and change their passwords.

    Our main mail server is at This temporary was at (and different IP address), but I set up the VirtualBox so that it thought that it was at DNSMasq returned the virtual Zimbra's own IP address on Everything worked fine. I now have a Zimbra store with no mail (except for a few test messages), but about 400 usernames and passwords.

    But I think I boo-boo'ed. Without thinking, I set the hostname on the Virtual Zimbra to the full, "" instead of just "mail." When I copy the /opt/zimbra folder from the virtualbox over to the main mail server, install Zimbra (following the Wiki instructions for "Move to a new Server"), I can't get the zmmailctld component to run, regardless of hostname.

    DNSMasq is set up and is running correctly:
    [root@mail ~]# host $(hostname)
    mail has address
    [root@mail ~]# hostname
    [root@mail ~]# host has address
    [root@pop ~]# host has address
    That last one is required because that's what our MX records actually point to. Could that be the problem?

    Final question: we're moving this weekend. If need be, is there anyway to just transfer these good passwords and usernames from the "virtual" Zimbra store over to a new, fresh install of Zimbra?

    Thanks for the help.

    Running zcs-6.0.15_GA on a Dell Poweredge with Centos 5.8.

  2. #2
    smpoole7 Guest


    OK, re-read the installation guide and it says that I do the fully qualified hostname: I thought so, but wanted to be sure.

    Digging through the logs, however, I found this interesting snippet in zmmailboxd.out:

    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.
    Now, that's intriguing. The server has 8 gig of RAM (7 gig free at the time I tried), and yet, this same Zimbra installation ran like a champ in a 2 gig VirtualBox.

    The adventure continues ...

  3. #3
    smpoole7 Guest

    Smile Figured It Out.

    I wish I could change the title of this thread because it might help someone else out. I originally assumed that it was a hostname issue, but it wasn't. My DNSMasq and hostname settings were fine.

    Here's what happened:

    If you build Zimbra in a small memory environment, it's going to set up the memory allocations accordingly. Believe it or not, in that limited environment, it may actually allocate MORE memory (as a percentage) to some functions.

    In my 2 Gig VirtualBox, it set the mailboxd memory percentage to 40%. When I moved that /opt/zimbra data over to my new server, it tried to allocate that much memory and couldn't.


    zmlocalconfig -e mailboxd_java_heap_memory_percent=18
     zmlocalconfig -e mysql_memory_percent=19
    ... solved my problem. The logs were right, there was insufficient free memory when I'd try to start it on the new server, even though it had 4 times as much memory (8 gig).

    If anyone hits this thread in a search, I'd suggest that you run zmlocalconfig (without arguments) on your old server, and then on the new, and carefully compare what you get. You can also compare the "" files created by the installer, but to me, it's easier to use zmlocalconfig, because the output from that command is already formatted as you'll want them (ex., "mailboxd_java_heap_memory_percent," as shown above, instead of MAILBOXMEMORYPERCENT, as in the output).

    We're off to the races!

  4. #4
    Join Date
    Jun 2011
    Caracas Venezuela
    Rep Power


    smpoole7, as you know.. a very good analysis and troubleshooting!

    Thanks for share!


Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  2. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts