Page 20 of 22 FirstFirst ... 101819202122 LastLast
Results 191 to 200 of 211

Thread: Full Server Backup and Restore of “open source version”

  1. #191
    Join Date
    Jun 2009
    Posts
    10
    Rep Power
    6

    Default Erro restore with restore.sh

    I installed two servers
    virtual.dominio.local 192.168.100.231
    I ran backup.sh and copy all


    When I try to run restore.sh in
    virtual.dominio.local 192.168.100.231

    [zimbra@virtual tmp]$ ./restore.sh marcos reset
    Start to restore => *** Mai 29 11:55:50 BRT 2009
    Check account [marcos] ==> NO, [marcos] not exist
    [zimbra@virtual tmp]$

    What is the problem ???

  2. #192
    Join Date
    May 2008
    Location
    Taiwan
    Posts
    296
    Rep Power
    7

    Default

    actually, I'm not sure if i understand your question.

    but i guess you don't have "macros" account in second machine. these backup scripts don't handle the account creation if it's not existing.

    therefour, you can create the account manually , or add "zmprov ca xxxx@domain pass1111" in my restore.sh script when account is not there.

  3. #193
    Join Date
    Jun 2009
    Posts
    10
    Rep Power
    6

    Default Problems with restore.sh

    Yes, I created, but don't work.
    Would be the unique account id ?
    For example:
    marcos in server 1 don`t is the same marcos in server 2. Because it have different id`s ( like active directory for example).

  4. #194
    Join Date
    May 2008
    Location
    Taiwan
    Posts
    296
    Rep Power
    7

    Default

    did these two server with same domain name?

    if you read my script and you will find actually i'm just checking whether system has this account or not by : zmprov ga <account@domain> . so if you are backup in A.domain and restore to B.domain, that will not work.

  5. #195
    Join Date
    Jun 2009
    Posts
    10
    Rep Power
    6

    Question Problems with restore.sh

    Yes, Of course.
    The same domain, same user name and I saw your script.

    I will try again.

    I can to restore in same server, but I can`t in second server.

    Thanks a lot.

  6. #196
    Join Date
    May 2009
    Posts
    19
    Rep Power
    6

    Default

    I've not read through each of the posts, but I found the easiest way to backup the opensource version of Zimbra is:
    1) Shutting it down for a minute.
    2) Doing a snapshot of the LVM partition.
    3) Starting Zimbra again.
    4) rsynching that snapshot I made to the backup server.
    5) deleting LVM snapshot once completed.

    This pretty much means if I need restore from backup, all I need to do is rsync it back, no reimporting of data to MySQL/ldap etc.

    A minute of downtime at 3AM isn't really going to effect anyone here. If you're running a mission critical setup that needs to be up 24/7, non-stop. One wonders why you aren't running a grid setup (or using the commerical versions) that would easilly allow you to turn one server off for a 'clean' back up without interupting the service since the other servers are still online.

  7. #197
    Join Date
    Jun 2009
    Posts
    10
    Rep Power
    6

    Default Question

    What mean ?

    Doing a snapshot of the LVM partition.


    ????????????????????????????????

  8. #198
    Join Date
    May 2009
    Posts
    19
    Rep Power
    6

    Default

    Quote Originally Posted by marcos.gw View Post
    What mean ?

    Doing a snapshot of the LVM partition.


    ????????????????????????????????
    Means something like

    lvcreate -L592M -s -n dbbackup /dev/ops/databases
    mkdir /mnt/ops/dbbackup
    mount /dev/ops/dbbackup /mnt/ops/dbbackup
    rsync username@host /mnt/ops/dbbackup --delete -a

  9. #199
    Join Date
    Jun 2008
    Posts
    3
    Rep Power
    7

    Default

    Hi all,

    I don't manage to use the backup.sh script to backup one account (the script to backup ALL accounts is working perfectly).

    I have entered my domain name in the backup.sh script (ie i have replaced the domain="@my.domain" with my real domain name) but when i launch "backup.sh admin@domain.com" i receive the "cat: admin@domain.com: No such file or directory" message.
    Any clue ?
    Thanks a lot
    Guillaume

  10. #200
    Join Date
    May 2008
    Location
    Taiwan
    Posts
    296
    Rep Power
    7

    Default

    guillaume142,
    backup.sh is going to read accounts from one file, thus backup.sh needs filename as parameter (not the account name).

    fyi.

Similar Threads

  1. mailbox backup & restore on open source version
    By Artturi in forum Administrators
    Replies: 3
    Last Post: 07-30-2010, 05:26 PM
  2. Restore single account failed from full backup
    By fmodola in forum Administrators
    Replies: 4
    Last Post: 06-20-2007, 06:27 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  4. copying only last full backup to store offsite
    By riccadus in forum Administrators
    Replies: 0
    Last Post: 01-11-2007, 01:29 AM
  5. Zimbra Full Backup and Restore???
    By jgao in forum Administrators
    Replies: 3
    Last Post: 01-19-2006, 01:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •