Results 1 to 2 of 2

Thread: Getting an error with IMAP Sync

Hybrid View

  1. #1
    Join Date
    Mar 2013
    Posts
    30
    Rep Power
    2

    Default Getting an error with IMAP Sync

    I am in the process of migrating from one server to another and I am getting an error when I run imapsync. I made sure the plain text was check marked on both servers and when input this command I get an error
    Code:
    imapsync --buffersize 8192000 --nosyncacls --subscribe --syncinternaldates --host1 10.10.0.234 --user1 user1 --password1 password1 --host2 10.10.0.7 --user2 user2 --password2 password2
    Transfer started at Thu Jun 6 11:36:03 2013
    $RCSfile: imapsync,v $ $Revision: 1.542 $ $Date: 2013/05/06 08:30:35 $
    Here is a [linux] system (Linux mail 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64)
    With perl 5.14.2 Mail::IMAPClient 3.30
    Command line used:
    /usr/bin/imapsync --buffersize 8192000 --nosyncacls --subscribe --syncinternaldates --host1 10.10.0.234 --user1 kgeotz@1streverse.com --password1 MASKED --host2 10.10.0.7 --user2 kgeotz@rmhq.com --password2 MASKED
    Temp directory is /tmp
    PID file is /tmp/imapsync.pid
    Modules version list:
    Mail::IMAPClient 3.30
    IO::Socket 1.32
    IO::Socket::INET 1.31
    IO::Socket::SSL 1.53
    Digest::MD5 2.51
    Digest::HMAC_MD5 1.01
    Digest::HMAC_SHA1 1.03
    Term::ReadKey ?
    Authen::NTLM ?
    File::Spec 3.33
    Time::HiRes 1.972101
    URI::Escape ?
    Data::Uniqid ?

    Info: turned ON syncinternaldates, will set the internal dates (arrival dates) on host2 same as host1.
    Info: will try to use LOGIN authentication on host1
    Info: will try to use LOGIN authentication on host2
    Host1: imap server [10.10.0.234] port [143] user [kgeotz@1streverse.com]
    Host2: imap server [10.10.0.7] port [143] user [kgeotz@rmhq.com]
    Banner: * OK IMAP4 ready
    Info: host 10.10.0.234 says it has NO CAPABILITY for AUTHENTICATE LOGIN
    Failure: error login on [10.10.0.234] with user [kgeotz@1streverse.com] auth [LOGIN]: 2 BAD invalid command
    I also did a telnet test and this is what I got

    telnet 10.10.0.234 143
    Trying 10.10.0.234...
    Connected to 10.10.0.234.
    Escape character is '^]'.
    * OK IMAP4 ready
    a02 LOGIN username password
    NO cleartext logins disabled
    a02 BAD invalid command
    a86 LOGOUT
    * BYE Zimbra IMAP server terminating connection
    a86 OK completed

  2. #2
    Join Date
    Mar 2013
    Posts
    30
    Rep Power
    2

    Default

    Got it working I had to do imapsync over SSL!

    This post was very helpful!
    Last edited by motang; 06-06-2013 at 11:01 AM. Reason: added link to the post I used to get it working

Similar Threads

  1. IMAP Sync Issues
    By borngunners in forum Migration
    Replies: 9
    Last Post: 09-15-2009, 01:05 PM
  2. Imap sync
    By guicar in forum Error Reports
    Replies: 2
    Last Post: 07-16-2009, 07:42 AM
  3. Mail Sync & IMAP
    By shampoo in forum Zimbra Connector for BlackBerry
    Replies: 0
    Last Post: 04-07-2009, 05:10 PM
  4. imap sync problems
    By richard.bessey in forum Migration
    Replies: 1
    Last Post: 07-08-2008, 12:23 PM
  5. IMAP error: unable to store IMAP message data
    By ebatte in forum Administrators
    Replies: 8
    Last Post: 04-27-2008, 09:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •