I'm getting ready to move about 50 users to Zimbra off of a Postfix/Dovecot server. I'm using imapsync to move the messages.

My first problem was with the Received Date being incorrect in Zimbra webmail, even with --syncinternaldates. Using the <username>/tg hack fixed that problem.

I still have a problem with message flags though. Every message shows up as unread in Zimbra. Has anyone else run into that?

For the record here's my setup:

source server: Dovecot-1.0beta8
ZCS: 4.0.3
imapsync command: imapsync --nosyncacls --syncinternaldates \
--host1 <sourceserver> --user1 <user> --password1 <pass> \
--host2 <zimbraserver> --user2 <user>/tb --password2 <pass> \
--split1 1000 --split2 1000 --ssl1 --ssl2 \
--delete2 --folder INBOX \
--authmech1 PLAIN --authmech2 LOGIN

And here's some output from imapsync:

From Folder [INBOX]
To Folder [INBOX]
++++ From [INBOX] Parse 1 ++++
++++ To [INBOX] Parse 1 ++++
++++ Verifying [INBOX] -> [INBOX] ++++
+ NO msg #2 [Ef5w/AcpDxZcbmTyW1NLrQ:2417] in INBOX
+ Copying msg #2:2417 to folder INBOX
flags from : [\Seen]["07-Jun-2006 10:34:15 -0700"]
Copied msg id [2] to folder INBOX msg id [39529]
+ NO msg #8 [71RdFMyq3B263VtEKadQeg:1110] in INBOX
+ Copying msg #8:1110 to folder INBOX
flags from : [\Seen]["07-Jun-2006 11:54:15 -0700"]
Copied msg id [8] to folder INBOX msg id [39530]
+ NO msg #9 [1cOWKjNCRR2baErrWMOMgA:1508] in INBOX
+ Copying msg #9:1508 to folder INBOX
flags from : [\Seen]["07-Jun-2006 12:19:47 -0700"]
Copied msg id [9] to folder INBOX msg id [39531]
+ NO msg #10 [IZARZZP4PFrHoTj3CjR7TQ:20281] in INBOX
+ Copying msg #10:20281 to folder INBOX
flags from : [\Seen]["07-Jun-2006 12:34:29 -0700"]
Copied msg id [10] to folder INBOX msg id [39532]
+ NO msg #11 [z1UKIpPKaZPKYxKoAPd0pg:43760] in INBOX
+ Copying msg #11:43760 to folder INBOX
flags from : [\Seen]["07-Jun-2006 12:47:08 -0700"]
Copied msg id [11] to folder INBOX msg id [39533]