Hi!
We use here the combination Postfix+Courier in our institute, having an external LDAP with almost 3,000 users registered. We are willing to migrate from it to Zimbra 8.0.5. I've already solved the issues involving the LDAP connection, using both LAZY or EAGER modes, but now I can't manage how to correctly migrate/sync the mailboxes using the imapsync, since I don't have users passwords. With the password, everything works perfectly, but without it it doesn't. I've seen numbers of threads, but none solved my problems. I got that I should login using an admin account, and then syncing everything. All the passwords are cryptographed using SSHA. The best way for us would be using the EAGER mode, to make all the migration before changing the mail server. We are also thinking in a way to get users' passwords and migrate mailboxes in LAZY mode, right after they try the first login in new server, but it would be a lot easier using EAGER mode. I have the following error:


Transfer started at Tue Sep 24 21:48:37 2013
$RCSfile: imapsync,v $ $Revision: 1.558 $ $Date: 2013/08/03 01:13:37 $
Here is a [linux] system (Linux zimbra 3.8.0-30-generic #44~precise1-Ubuntu SMP Fri Aug 23 18:32:41 UTC 2013 x86_64)
With perl 5.14.2 Mail::IMAPClient 3.30
Command line used:
/usr/bin/imapsync --syncinternaldates --host1 webmail.ifsp.edu.br --user1 rt133206 --authuser1 bruno --password1 MASKED --ssl1 --port1 993 --host2 zimbra.ifsp.edu.br --user2 bruno --authuser2 dir --password2 MASKED --ssl2 --port2 993
Temp directory is /tmp
PID file is /tmp/imapsync.pid
/tmp/imapsync.pid already exists, overwriting it
Modules version list:
Mail::IMAPClient 3.30
IO::Socket 1.32
IO::Socket::IP ?
IO::Socket::INET 1.31
IO::Socket::SSL 1.53
Net::SSLeay 1.42
Digest::MD5 2.51
Digest::HMAC_MD5 1.01
Digest::HMAC_SHA1 1.03
Term::ReadKey ?
Authen::NTLM ?
File::Spec 3.33
Time::HiRes 1.972101
URI::Escape ?
Data::Uniqid ?

Info: turned ON syncinternaldates, will set the internal dates (arrival dates) on host2 same as host1.
Info: will try to use PLAIN authentication on host1
Info: will try to use PLAIN authentication on host2
Host1: IMAP server [webmail.ifsp.edu.br] port [993] user [rt133206]
Host2: IMAP server [zimbra.ifsp.edu.br] port [993] user [bruno]
Host1: * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc. See COPYING for distribution information.
Host1: webmail.ifsp.edu.br says it has CAPABILITY for AUTHENTICATE PLAIN
Failure: error login on [webmail.ifsp.edu.br] with user [rt133206] auth [PLAIN]: 2 NO Login failed.
at /usr/bin/imapsync line 2293
main::die_clean('Failure: error login on [webmail.ifsp.edu.br] with user [rt13...') called at /usr/bin/imapsync line 2056
main::authenticate_imap('Mail::IMAPClient=HASH(0x2 dae0d0)', 'webmail.ifsp.edu.br', 993, 'rt133206', undef, 'MASKED', undef, undef, 0, ...) called at /usr/bin/imapsync line 2018
main::login_imap('webmail.ifsp.edu.br', 993, 'rt133206', undef, 'MASKED', undef, undef, 0, 1, ...) called at /usr/bin/imapsync line 973


It looks like it is trying to login using the user1, not authuser1. Is it really the problem? Can anybody help me?

Thanks a lot!