Results 1 to 5 of 5

Thread: Split Domain w/Sendmail

  1. #1
    Join Date
    Jan 2007
    Posts
    5
    Rep Power
    8

    Unhappy Split Domain w/Sendmail

    Hello,

    This split domain stuff has got me vexed. I've read through the Split Domain Wiki and have searched the forum for answers, but I'm still a bit confused.

    What I can't seem to figure, is how this split domain works with my company's server configuration. We are currently working off of a Sendmail server, mail.genart.org. I need to migrate all of the accounts off of that Sendmail server to a Zimbra server which has just been setup. I can't move all of the accounts at once due to limited resources, so I plan to use the PST migration wizards once this split domain is accomplished. I would like to have a setup where e-mails come into either the Zimbra or Sendmail server and if the account and is not found are forwarded on to the other server.

    To me, it looks like my only option is to have Zimbra configured as the primary e-mail server and to prescreen inbound e-mail on the Zimbra machine, forwarding them over if the accounts are not present. Is that assumption correct? If that is the case, what do I need to do to my MX records, Zimbra and Sendmail machines to make this work? Can I leave Sendmail as the primary server and tell it to forward e-mail traffic to the Zimbra box for those accounts which do not exist on the Sendmail server?

    Thanks in advance for your help,

    Paul.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi Paul,
    I've forwarded this ont the developers to get you some help.

    You should get a response soon.

    thx
    john

  3. #3
    Join Date
    Jan 2007
    Posts
    5
    Rep Power
    8

    Default

    I tried to configure Zimbra as a Secondary server to my Sendmail server.

    I have the .forward file in place, e-mails seem to reach the Zimbra server, but arenít being routed correctly.

    Hereís what Iíve done:

    Iíve created an account zmtest@example.org on my Sendmail server and on as well as my Zimbra server. I placed a .forward file in zmtestís home directory on the Sendmail server pointing to the Zimbra server. I ran the zmprov commands that are in the split-domain document on the Zimbra server. I send mail to zmtest@example.org and I get this reply:

    Reporting-MTA: dns; mail.example.org

    Received-From-MTA: DNS; 41.mufm.nycm.n54ny06r18.dsl.att.net

    Arrival-Date: Thu, 8 Feb 2007 17:22:52 -0500

    Final-Recipient: RFC822; zmtest@example.org

    X-Actual-Recipient: RFC822; zimbratest.example.org@mail.example.org

    Action: failed

    Status: 5.1.1

    Diagnostic-Code: X-Unix; 550 5.1.1 User unknown

    Last-Attempt-Date: Thu, 8 Feb 2007 17:23:05 -0500

    Any ideas as to what I'm doing wrong?

    Thanks!

    Paul.

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    What domain did you create on Zimbra? Can you send mail to/from that test account in Zimbra alone. Best to test that before you test the forward.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    I have no idea which server that bounce came from; could you post some details on your setup, letting us know which server is which?

    Also, post one of your .forward files.

    This sounds like a sendmail problem, which we may not be much help with, but more details will tell us.

    When you say "emails seem to reach the zimbra server" what makes you think that?

    For the account that generated the bounce, what do you get from
    zmprov ga accountname
    on the zimbra box?
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Split Domain with OS X Postfix
    By wickhamandrew in forum Installation
    Replies: 1
    Last Post: 01-16-2007, 07:29 PM
  2. Migration issue with split domain & multi-servers
    By adminsmc in forum Migration
    Replies: 3
    Last Post: 12-17-2006, 08:14 AM
  3. Question about Split Domain setup
    By ericding in forum Administrators
    Replies: 3
    Last Post: 05-05-2006, 05:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •