I have been "playing" with the idea of backing up my zimbra Server. Now I find I need to utilize the thought of "backing up" at a different level: restoration -- to different Equipment.

The question here is: how do I successfully "Backup" the Zimbra running on one piece of hardware, and move it to another.

Since I bring with me lots of attempts at doing this I am moving this whole concept to this new thread. Following is what I have tried so far, for ppls to ponder over.

Given:
PC1: RHEL4 update 3, Zimbra 3.0.1 GA
PC2: RHEL5 (rtm)

Source threads for this discussion:
OSS Backup Discussion

Migration Issues 3.1.4 to 4.5.3
Migration Issues 3.x to 4.5.3

Critical bug workaround for 4.5.5


There are 2 parts to this:
1. Get/Show RHEL 4 Zimbra relases will install on RHEL 5
2. Get the Zimbra install info from the old server on to this new one. (I need to transition Zimbra to newer hardware -- read: different PC)

Part 1
What I've sucessfully done so far:

Installing RHEL 5 with the intension of installing Zimbra RHEL 4 release on it.

sendmail can be deselected when installing by insuring it is not checked under Base System | Base, as well as Servers | Mail Server, it wont matter though because fetchmail is dependant on it, so it will install anyway.
openssl097a compat-libstdc++-296 compat-libstdc++-33 are available when installing under Base System | Legacy software support.
fetchmail - under Applications | Text-based Internet
gmp : gmp-devel under Development

Before Installing Zimbra:
visudo and comment "Defaults requiretty"
NOTE: in RHEL 5 the man page for visudo is there, but the command doesnt seem to work. I have read that as long as you are the only user modifying the file you can:

su
vi /etc/Sudoers
(comment "Defaults requiretty")
:x! (to force vi to save over the readonly file)

vi /etc/hosts
verify:
127.0.0.1 localhost.localdomain localhost
xxx.xxx.x.x mail.host.com mail

I cheat and use the GUI for the next few steps:
RHEL5 automatically turns on SELinux and firewall ... it doesnt even ask during install anymore... so
System | Administration | Security Level and Firewall
Set Firewall to disabled, Set SELinux to Disabled

Install Zimbra 3.0.1 GA OSS

This is installed and working fine on RHEL 5. I now need to figure out how to get my old info on this machine from a different server.

Part 2
What I've done to try to bring info from another machine:


zmcontrol stop
targzip /opt
stop zimbra with "zmcontrol stop"
rename opt volume with "mv /opt /opt.clean"
restore old opt volume with "tar -xvf zimbrabak.tar.gz"
reboot

Where I get stuck:
Zimbra doesnt seem to restart after reboot.
If I "stop" it manually with zmcontrol stop, then try to restart with zmcontrol start, it gets to the first thing:
Starting ldap...Password:
and wants some sort of password. I have tried the root password and even the LDAP password from the old zimbra machine (found with zmlocalconfig -s).
I have even tried reformatting the machine, reinstalling linux, and specifying the old LDAP password from the previous server when installing clean zimbra, before renaming /opt to /opt.clean.
No DICE.

The only other thing I could find on the forums to try doing was Installing over this zimbra, and choosing upgrade.
The upgrade goes fine, except I get errors right after the ldap convert, then ldap FAILED (512)