Page 40 of 106 FirstFirst ... 3038394041425090 ... LastLast
Results 391 to 400 of 1054

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #391
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Please look for a PM from me (under your account name at the rop right of the page if you are unfamiliar with this site)

    Turn on WBXML_DEBUG in wbxml.php and ZIMBRA_DEBUG in config.php - try to do a sync, and send me a copy of the log file.

    I will take a look at it.

    You might have a corrupted appointment ?

    Or, is it possible that calendar sync is not turned on by default ?

  2. #392
    Join Date
    May 2010
    Location
    France
    Posts
    6
    Rep Power
    5

    Default

    Liverpoolfcfan identified an appointment with a bad UID. Removing it solves the issue. Thanks!

  3. #393
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default Corrupted Appointment UID - what to look for

    Quote Originally Posted by mangue View Post
    Liverpoolfcfan identified an appointment with a bad UID. Removing it solves the issue. Thanks!
    As it might help others in finding such corrupted appointments, I will show you the lines from his log file as an example.

    With WBXML_DEBUG set to true, you will get the z-push core debug messages that show the communications between the phone and server.

    The UID field in the communications between the server and phone contains a Unique ID for the appointment.

    For a good appointment, created on zimbra, it will look something like this

    Code:
    12/15/10 11:40:35 [29104] O        <POOMCAL:UID>
    12/15/10 11:40:35 [29104] O        ad9d2c16-2abb-4303-a265-f9f50c0227f4
    12/15/10 11:40:35 [29104] O        </POOMCAL:UID>
    Appointments generated on a phones may use a different format, but the UID should contain all ASCII characters.

    Here are the log lines for the corrupted appointment that was breaking the sync

    Code:
    12/15/10 11:40:35 [29104] O        <POOMCAL:UID>
    12/15/10 11:40:35 [29104] O        )řu˕H
    ´𲪧U
    12/15/10 11:40:35 [29104] O        </POOMCAL:UID>
    Hopefully that garbage comes through on the forum - but if not it contains a bunch of non-ASCII characters.

    Removing that corrupted appointment from the zimbra server calendar allowed the sync to complete successfully.

  4. #394
    Join Date
    Dec 2010
    Location
    Brazil
    Posts
    14
    Rep Power
    4

    Default

    I'm having problems synchronizing Nokia E71 with MfE 3.00.050 on z-push 1.4.3.486 using BackendZimbra R47.

    Log debug.txt

    12/16/10 10:34:04 [13067] Start
    12/16/10 10:34:04 [13067] Z-Push version: 1.4.3 486
    12/16/10 10:34:04 [13067] Client IP: XXX.XXX.XXX.XXX
    12/16/10 10:34:04 [13067] PHP Version: 5.1.6 - Zimbra Z-Push Backend Version: 47
    12/16/10 10:34:04 [13067] START Logon { username = teste@domain.com.br; domain = domain.com.br; password = <hidden> }
    12/16/10 10:34:04 [13067] SOAP message: <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
    <soap:Header><context xmlns="urn:zimbra">
    <session id="" />
    <notify seq="0" />
    </context></soap:Header>
    <soap:Body><AuthRequest xmlns="urn:zimbraAccount">
    <account by="name">teste@domain.com.br</account>
    <password>**********</password>
    <attrs><attr name="uid"/></attrs>
    <prefs><pref name="zimbraPrefTimeZoneId"/></prefs>
    </AuthRequest></soap:Body>
    </soap:Envelope>
    12/16/10 10:37:13 [13067] SOAP Error:
    12/16/10 10:37:13 [13067] ERROR: curl_exec - (7) couldn't connect to host
    12/16/10 10:37:13 [13067] END Logon { connected = false }
    12/16/10 10:37:13 [13067] Access denied: backend logon failed.
    12/16/10 10:37:13 [13067] end
    12/16/10 10:37:13 [13067] --------

    Any suggestions?

  5. #395
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    12/16/10 10:37:13 [13067] SOAP Error:
    12/16/10 10:37:13 [13067] ERROR: curl_exec - (7) couldn't connect to host
    Most likely you have made a mistake in defining your zimbra server - in config.php

    Code:
    define('ZIMBRA_URL', 'http://yourzimbraserver.yourdomain');

  6. #396
    Join Date
    Dec 2010
    Location
    Brazil
    Posts
    14
    Rep Power
    4

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    Most likely you have made a mistake in defining your zimbra server - in config.php

    Code:
    define('ZIMBRA_URL', 'http://yourzimbraserver.yourdomain');
    liverpoolfcfan,

    My config.php is correct

    define('ZIMBRA_URL', 'http://mail.domain.com.br');


    Any idea of some other solution?
    Last edited by Felipe Nolasco; 12-16-2010 at 05:00 AM.

  7. #397
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    For starters, please describe how you set this up.

    Is z-push on the same server as zimbra ?

    What http port is zimbra listening on ?

    Can you "wget http://mail.domain.com.br" from the z-push folder ?

  8. #398
    Join Date
    Dec 2010
    Location
    Brazil
    Posts
    14
    Rep Power
    4

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    For starters, please describe how you set this up.

    Is z-push on the same server as zimbra ?

    What http port is zimbra listening on ?

    Can you "wget http://mail.domain.com.br" from the z-push folder ?
    Thanks, I found the problem.
    Was in the iptables rule (table mangle).
    Now I need to figure out why is not updating the mailbox.

  9. #399
    Join Date
    Dec 2010
    Location
    Brazil
    Posts
    14
    Rep Power
    4

    Default

    New entries are syncing, but not old items.
    Any idea?

  10. #400
    Join Date
    Dec 2010
    Location
    Brazil
    Posts
    14
    Rep Power
    4

    Default

    I can receive only 50 emails in my inbox.
    Calendar, send and receive operate normally.
    Any idea about this limitation?

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 10:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 01:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 03:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •