Page 83 of 106 FirstFirst ... 3373818283848593 ... LastLast
Results 821 to 830 of 1054

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #821
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    I tested it today. I have an account that never used z-push and all worked fine. Hooked them up and problems started. Switch off the z-push server and all is ok

  2. #822
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    I have been looking at this for a while to try to understand if it is something that can be influenced. So far, I think it might be a factor of how many SOAP requests a client makes. I see the problem occur more often if I am syncing multiple devices to my zimbra account than I do if only syncing a single device.

    But I am not entirely convinced it is not a web client issue. Generally when I see the problem in my browser (chrome) if I click on the next email it is rendered in plain text - not HTML which is my default. Pressing the refresh on the browser returns the browser to HTML display mode again.

    That being said - I have discovered a way to significantly reduce the number of soap requests for the setup of each sync session - particularly if you use a lot of shared folders.

    If you would like to test it, please PM me.

  3. #823
    Join Date
    Feb 2011
    Location
    Belgium
    Posts
    12
    Rep Power
    4

    Default

    Hi all!

    As an exercise, and to test if i could get email sync with my new GS3, i tried to install Z-Push 2.0 RC with the appropriate SVN version of the zimbra backend (zpush-2-beta branch).

    I had the following error:

    Class BackendSearchZimbra contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (ISearchProvider::TerminateSearch)

    So I modified the zimbra.php file at line 9615 to add the following:

    public function TerminateSearch($pid) {
    return true;
    }

    It solved the problem (well, it's an empty function ...) and email, contacts and calendar now works on my GS3 (including HTML messages) with Z-Push 2.0 RC.

  4. #824
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Quote Originally Posted by rfr View Post
    It solved the problem (well, it's an empty function ...) and email, contacts and calendar now works on my GS3 (including HTML messages) with Z-Push 2.0 RC.
    Thanks for the post. I have already seen and fixed this issue in the same way too - though not checked it into SVN yet. It was caused by a change in the Search Interface in the most recent z-push 2.0 changes.

  5. #825
    Join Date
    Mar 2011
    Posts
    57
    Rep Power
    4

    Default

    I have a question about contact groups created in Zimbra: are they synced with devices? I tried with iPhone, iPad and an Android 4.0 phone, but I did not find the groups in the address book.

  6. #826
    Join Date
    Nov 2010
    Posts
    54
    Rep Power
    5

    Question Apache optimisations?

    I was wondering if there were any Apache settings recommendations for z-push backend for Zimbra.

    You know some settings like (which I randomly copy-and-paste from the internet):

    Code:
    StartServers         40
    MinSpareServers      30
    MaxSpareServers     50
    MaxClients          240
    MaxRequestsPerChild  10000
    Timeout 30
    KeepAliveTimeout 3
    and with some explanations why you advice these values. Our main concern is not to run out of memory.

    Thank you very much.
    Adrian Gibanel, IT Manager

    "be free, be innovative, bTactic"

    Av. Balmes, 34 4rt 1a B | Lleida, Spain 25006

    www.btactic.com

  7. #827
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Quote Originally Posted by jobe View Post
    I have a question about contact groups created in Zimbra: are they synced with devices? I tried with iPhone, iPad and an Android 4.0 phone, but I did not find the groups in the address book.
    Only Apple devices will show contact groups - assuming you do not disable them in the config - or filter them out using SmartFolders or XML files.

    When you open your Contacts app on the iPxxx device - it most likely defaults to "All Contacts" at the top of the screen - with a <Groups] button to the left. If you click the <Groups] button, it should show you the list of contact folders, and allow you to select individual groups.

    As of yet - no other phones support this functionality. In the backend code - it is enabled by identifying the useragent as containing "Apple".

  8. #828
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Quote Originally Posted by adrian.gibanel.btactic View Post
    I was wondering if there were any Apache settings recommendations for z-push backend for Zimbra.
    I am not aware of anything that should be different for zimbra over and above what would work for any other backend.

    I would suggest you pose the question on the z-push forum for guidance from the z-push developers - and feel free to post back their answer here as it might help other users.

  9. #829
    Join Date
    Feb 2011
    Location
    Belgium
    Posts
    12
    Rep Power
    4

    Default

    The final version of Z-Push 2.0 is out. It seems to work smoothly with the last revision of the zimbra backend 2.0-alpha2 branch (rev 136).

  10. #830
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Quote Originally Posted by rfr View Post
    The final version of Z-Push 2.0 is out. It seems to work smoothly with the last revision of the zimbra backend 2.0-alpha2 branch (rev 136).
    Thanks for the feedback. I am sure you already are - but just to be sure you should be using the beta branch SourceForge.net Repository - [zimbrabackend] Index of /zimbra-backend/branches/z-push-2-beta

    It still needs some tidy up and a bunch of debugs removed but it is getting there.

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 11:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 02:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 04:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 08:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •