Page 95 of 106 FirstFirst ... 45859394959697105 ... LastLast
Results 941 to 950 of 1054

Thread: Z-Push Zimbra Backend (Push Email, Contacts, Appointments & Tasks)

  1. #941
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Quote Originally Posted by lytledd View Post
    I ran into this yesterday on a new install under CentOs, the fix was:

    yum install php-process

    Doug
    Perfect!! For some reason my repositories don´t have that package available...i downloaded it from elsewhere (a centos 6.3 mirror in fact)

    Now, i´m only left with this:

    [WARN] [username] /usr/share/z-push/lib/core/zpush.php:445 Use of undefined constant ZIMBRA_USER_DIR - assumed 'ZIMBRA_USER_DIR' (8)

    Again, sync is working just fine. But i would love to get rid of the errors and warns

    THANKS!!!!!

  2. #942
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    For now just set it to 'zimbra' as it says in the INSTALL notes. If you were using XML files you would also need to create a folder zimbra in the root of the z-push folder.

    In a future release I will move all the code that references the ZIMBRA_USER_DIR into the XML files handling function, as it is not relevant outside of that.

  3. #943
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    **** WARNING for Z-Push-2 trunk users ****

    If you are running a trunk checkout of z-push-2, do not update past r1557 with z-push-2 zimbra backend versions 54.1 and earlier.

    There is an interface change introduced in z-push-2 r1558 that will break the loading of the zimbra backend

    I will incorporate the required changes into the next zimbra backend release - which will need to be used with Z-Push 2.0.6 RC and later.

  4. #944
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Thanks for your help with the previous issues!

    I think i´ve run into something new now. I did search around here, but couldn´t find any results...but that could be me and i apologize if it had been posted before.

    When i create a contact in Zimbra with multiple mobile numbers (and they´re labelled as such), Android and Iphone will display only the first entry.

    Example:

    3883-9876 Work
    8888-8888 Mobile
    1234-5678 Mobile
    4444-5555 Mobile

    The contact on the phone displays only the number set as "Work" and the first "Mobile" entry, ignoring the next two. If i set anything other than "Mobile" to the other numbers making them all fall into different classes (say, Work, Mobile, Home, Fax) they all display correctly. So it appears that multiple numbers with the same label are not displayed correctly.

    Zimbra 6.0.6, z-push 2, backend version 54

    Thanks!!

  5. #945
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Quote Originally Posted by fviero View Post
    The contact on the phone displays only the number set as "Work" and the first "Mobile" entry, ignoring the next two. If i set anything other than "Mobile" to the other numbers making them all fall into different classes (say, Work, Mobile, Home, Fax) they all display correctly. So it appears that multiple numbers with the same label are not displayed correctly.
    That is an ActiveSync limitation. Near the top of zimbra.php you can see an array that maps the contact attributes that ActiveSync supports. You are only allowed to have one of each item in the list in a contact record. Also, not all phones will support the full list of attributes. The only way to get all the other phone numbers onto your device is to use the other available fields as you have tried.

  6. #946
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    That is an ActiveSync limitation. Near the top of zimbra.php you can see an array that maps the contact attributes that ActiveSync supports. You are only allowed to have one of each item in the list in a contact record. Also, not all phones will support the full list of attributes. The only way to get all the other phone numbers onto your device is to use the other available fields as you have tried.
    Thank you!! Guess we´ll have to live with that then...

  7. #947
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Just installed z-push2 and zimbra backend on sles 11 SP2 server which is not our zimbra 8 server. When trying to go to https://ip.add.ress/Microsoft-Server-Activesync, i get:

    HTTP ERROR 500

    Problem accessing /service/extension/zimbrasync. Reason:

    system failure: Extension HTTP handler not found at /zimbrasync

    Powered by Jetty://
    like i said, z-push is on a different server than zimbra 8 is. Here are the z-push files/entries:
    config.php:
    Code:
    /**********************************************************************************
     *  Backend settings
     */
        // The data providers that we are using (see configuration below)
        define('BACKEND_PROVIDER', "BackendZimbra");
    
    
        // ************************
        //  BackendZimbra settings
        // ************************
        // Defines the server to which we want to connect
        define('ZIMBRA_URL', 'https://192.168.124.3'); //Please do not put a trailing forward slash at the end of the url
        define('ZIMBRA_USER_DIR', 'zimbra');
        define('ZIMBRA_SYNC_CONTACT_PICTURES', true);
        define('ZIMBRA_VIRTUAL_CONTACTS',true);
        define('ZIMBRA_VIRTUAL_APPOINTMENTS',true);
        define('ZIMBRA_VIRTUAL_TASKS',true);
        define('ZIMBRA_IGNORE_EMAILED_CONTACTS',true);
        define('ZIMBRA_HTML',true);
        define('ZIMBRA_ENFORCE_VALID_EMAIL',true);
        define('ZIMBRA_SMART_FOLDERS',true);
        define('ZIMBRA_DEBUG',true);
    default-server.conf:
    Code:
    Alias /Microsoft-Server-ActiveSync/ /srv/www/htdocs/sites/z-push/index.php
        
    <Directory /srv/www/htdocs/sites/z-push>
        AllowOverride All
    </Directory>
    I have z-push2 in (install from z-push):
    Code:
    The contents of this folder should be copied to /usr/share/z-push.
    In a case that /usr/share/z-push does not exist yet, create it with:
    I have made the state dir and the log dir and assigned wwwrun to the folder. I realize this post is a bit old, but have followed it for my flavor of linux:
    http://vblog.strutt.org.uk/2011/09/z...r-zimbra-foss/
    I am a little confused on step 11 of that post says to untar z-push2 to the backend folder. What backend folder?
    And do i put the alias entry in my default-server.conf or the SSL vhost file (this server is setup to use SSL)?
    Last edited by carnold; 11-24-2012 at 02:46 PM.

  8. #948
    Join Date
    Jun 2007
    Location
    Porto Alegre, RS, Brazil
    Posts
    96
    Rep Power
    8

    Default

    Quote Originally Posted by carnold View Post
    Just installed z-push2 and zimbra backend on sles 11 SP2 server which is not our zimbra 8 server. When trying to go to https://ip.add.ress/Microsoft-Server-Activesync, i get:

    HTTP ERROR 500

    Problem accessing /service/extension/zimbrasync. Reason:

    system failure: Extension HTTP handler not found at /zimbrasync

    Powered by Jetty://
    like i said, z-push is on a different server than zimbra 8 is. Here are the z-push files/entries:
    config.php:
    Code:
    /**********************************************************************************
     *  Backend settings
     */
        // The data providers that we are using (see configuration below)
        define('BACKEND_PROVIDER', "BackendZimbra");
    
    
        // ************************
        //  BackendZimbra settings
        // ************************
        // Defines the server to which we want to connect
        define('ZIMBRA_URL', 'https://192.168.124.3'); //Please do not put a trailing forward slash at the end of the url
        define('ZIMBRA_USER_DIR', 'zimbra');
        define('ZIMBRA_SYNC_CONTACT_PICTURES', true);
        define('ZIMBRA_VIRTUAL_CONTACTS',true);
        define('ZIMBRA_VIRTUAL_APPOINTMENTS',true);
        define('ZIMBRA_VIRTUAL_TASKS',true);
        define('ZIMBRA_IGNORE_EMAILED_CONTACTS',true);
        define('ZIMBRA_HTML',true);
        define('ZIMBRA_ENFORCE_VALID_EMAIL',true);
        define('ZIMBRA_SMART_FOLDERS',true);
        define('ZIMBRA_DEBUG',true);
    default-server.conf:
    Code:
    Alias /Microsoft-Server-ActiveSync/ /srv/www/htdocs/sites/z-push/index.php
        
    <Directory /srv/www/htdocs/sites/z-push>
        AllowOverride All
    </Directory>
    I have z-push2 in (install from z-push):
    Code:
    The contents of this folder should be copied to /usr/share/z-push.
    In a case that /usr/share/z-push does not exist yet, create it with:
    I have made the state dir and the log dir and assigned wwwrun to the folder. I realize this post is a bit old, but have followed it for my flavor of linux:
    http://vblog.strutt.org.uk/2011/09/z...r-zimbra-foss/
    I am a little confused on step 11 of that post says to untar z-push2 to the backend folder. What backend folder?
    And do i put the alias entry in my default-server.conf or the SSL vhost file (this server is setup to use SSL)?
    What does your apache error log file say?

  9. #949
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Quote Originally Posted by fviero View Post
    What does your apache error log file say?
    Well, i am getting to the site using 192.168.124.3/Microsoft-Server-ActiveSync, the error.log does not show anything passed 5:40 today. I know the connection is making to the zimbra server b/c the error that is returned says something about jetty (jetty only runs on the zimbra serve).....that error.log is on the apache2 server. Let me look at the zimbra server; nothing on that either. Looked at mailboxd.log and a few others.

    EDIT
    I tried to hit https://mail.domain.net/Microsoft-Server-ActiveSync and then look at that vhost log, nothing found there either. BTW, that returned the same error
    /EDIT
    Last edited by carnold; 11-24-2012 at 04:44 PM.

  10. #950
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    454
    Rep Power
    5

    Default

    Well, i am getting to the site using 192.168.124.3/Microsoft-Server-ActiveSync
    Just so we're all on the same page here, what are the IP addresses of your z-push server and your Zimbra server? Since the error you've listed indicates that you're hitting Zimbra's web server and not your Z-Push server's:

    http://www.zimbra.com/forums/mobilit...imbrasync.html

    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

Similar Threads

  1. z-push and zimbra backend problem
    By ben1967 in forum Mobility
    Replies: 9
    Last Post: 11-14-2012, 10:29 PM
  2. z-push and zimbra backend problem
    By ben1967 in forum Administrators
    Replies: 0
    Last Post: 11-11-2012, 01:11 PM
  3. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Mobility
    Replies: 6
    Last Post: 01-19-2012, 03:22 AM
  4. [SOLVED] Z-push Zimbra backend workaround
    By Inchoate in forum Administrators
    Replies: 0
    Last Post: 10-31-2010, 07:06 AM
  5. Replies: 348
    Last Post: 10-11-2010, 05:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •