Results 1 to 10 of 12

Thread: DROIDX will not corp sync

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Posts
    36
    Rep Power
    6

    Default DROIDX will not corp sync

    All, My new DROIDX will not corporate sync to my Zimbra server. Even tried Touch Down app. Older DROID had not issue with corporate sync and Samsungs have no issues with Active Sync. Any thoughts. Still not sure if its my Zimbra server or DROIDX although leaning towards the DROIDX. One thing I have noticed is the DROIDX does not give me a choice of connection security it is simply on or off. We use SSL....although it works without checking the security SSL radio button on the old DROID.

    !ERROR
    Could not connect to the server.

    DROIDX:
    System version: Version.1.13.516.MB810.Verizon.en.US
    Firmware version: 2.1-update1
    Baseband version: BP_C_01.09.02P

  2. #2
    Join Date
    Jul 2010
    Posts
    1
    Rep Power
    5

    Default

    Have Droix and have no problems syncing it with Zimbra corporate email

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by caseyg View Post
    All, My new DROIDX will not corporate sync to my Zimbra server. Even tried Touch Down app. Older DROID had not issue with corporate sync and Samsungs have no issues with Active Sync. Any thoughts. Still not sure if its my Zimbra server or DROIDX although leaning towards the DROIDX. One thing I have noticed is the DROIDX does not give me a choice of connection security it is simply on or off. We use SSL....although it works without checking the security SSL radio button on the old DROID.

    !ERROR
    Could not connect to the server.

    DROIDX:
    System version: Version.1.13.516.MB810.Verizon.en.US
    Firmware version: 2.1-update1
    Baseband version: BP_C_01.09.02P
    If you're using a self-signed certificate you need to be able to accept that on your phone, could that be the problem. If you've used Touchdown it has an option to accept an self-signed certificate automatically. Have you tried looking at the Zimbra log files or the Touchdown log when you try a connection (or even post on the Touchdown forums to see what the problem is). I actually use Touchdown on an HTC Desire connected to a Zimbra server without problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    we have several people using touchdown on the droid-x without problems.

  5. #5
    Join Date
    Feb 2007
    Posts
    6
    Rep Power
    8

    Default

    Quote Originally Posted by caseyg View Post
    All, My new DROIDX will not corporate sync to my Zimbra server. Even tried Touch Down app. Older DROID had not issue with corporate sync and Samsungs have no issues with Active Sync. Any thoughts. Still not sure if its my Zimbra server or DROIDX although leaning towards the DROIDX. One thing I have noticed is the DROIDX does not give me a choice of connection security it is simply on or off. We use SSL....although it works without checking the security SSL radio button on the old DROID.

    !ERROR
    Could not connect to the server.
    Same issue here. We don't use touchdown, but DroidX will not connect to the server (4 other 2.x android devices do, including Nexus One with 2.2).

    Having to change the settings in Exchange 2003 and 2007 as explained here: DROID - Exchange Email Troubleshooting probably explains why it isn't working for Zimbra, but I haven't been able to figure out how to change these same settings in Zimbra, yet.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by bzly2000 View Post
    ....probably explains why it isn't working for Zimbra, but I haven't been able to figure out how to change these same settings in Zimbra, yet.
    You make those changes in the Admin UI.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Feb 2007
    Posts
    6
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix View Post
    You make those changes in the Admin UI.
    Not obvious where that is in Zimbra 5, at least on my server. I've only found information for Zimbra 6: Enabling Zimbra Mobile for Smart Phones - Zimbra :: Wiki

  8. #8
    Join Date
    Feb 2007
    Posts
    6
    Rep Power
    8

    Default

    Well, we got it working!

    Here's what I did to allow Droid X to sync with Zimbra:

    1. Upgrade to Zimbra 6. We upgraded to 6.0.7. This may not be required, but that is the only way to get the "Zimbra Mobile" tab to appear in the Admin GUI. Even if the com_zimbra_mobilsync Admin GUI zimlet is installed in Zimbra 5, it won't ever show up. The mobile tab lets you set the security settings like you can in Exchange, specifically the "Allow non-provisionable devices" setting. I had to set this to get the Droid X to communicate with the server.

    Be careful, though, because the default setting is to require a PIN code on all devices. This can be confusing to users and we had one set it to random numbers and we had to do a factory reset on their Windows Mobile device to allow access again.

    Also, you have to restart the Zimbra server after the upgrade to get the mobile tab to show up. The other Admin GUI tabs showed up fine right after the upgrade, but Mobile is "special".

    2. You MUST have a way for the Droid X to communicate via SSL (https) with your server, even if you uncheck the box for SSL. It requires SSL on the initial connection and defaults it to require it, once it gets connected, regardless what you pick on the account setup window. After you get it set up, you can disable SSL on the phone, but you MUST have it to connect the first time.

    If https://192.168.1.99 (or whatever your local IP address is for your zimbra server) doesn't work on your local network, https isn't working on your server and you have to enable https for your zimbra server. Here's what did it for me:

    # su - zimbra
    $ zmtlsctl both
    $ zmcontrol restart
    You can use "mixed", "both", "redirect", or "https", depending on your situation. Each of those will allow https:// to work. You'll want to pick one that fits your situation. There's more information here on this command: CLI zmtlsctl to set Web Server Mode - Zimbra :: Wiki

    3. You have to be able to access the Zimbra server using SSL through whatever firewall you have. This was OK on ours, once we did step 2, but it is possible that your firewall is only passing http to your Zimbra server.

    Do the same test as above from a remote system to your zimbra server. Something like https://zimbra.yourdomain.com or https://mail.yourdomain.com should prove it works. If you try to test it this way from the same network that your Zimbra server is on and it works, but you still can't connect your Droid X, you could still have a problem with your firewall. Some firewalls detect that you are accessing a "firewalled" server from the same network and will go ahead and pass your packets to the server and it works, but will still be blocking your remote access. A great test would be to just use your Droid X's browser to get to your Zimbra server. If you can get to it from the Droid X's browser with https://, you are probably set to try setting up the account.

    4. You should have a current self-signed or commercial SSL certificate. (There are directions other places to get that working.) If you get the warning about "there is a problem with this website's security certificate", that's OK, but https HAS to work.

    We still have a problem with the Droid X where it requires a PIN to unlock, even if the option on the COS or user says it isn't required, but at least we are able to sync email, addresses, and calendar.
    Last edited by bzly2000; 08-16-2010 at 03:53 PM.

  9. #9
    Join Date
    Aug 2010
    Posts
    3
    Rep Power
    5

    Default

    On my other smart phones that I've had, I have just been entering all of the pop3 info to send and get email... I'm not even sure if we have this "corporate" email. When I log into my work email on a computer, I just go to our mail.myworkwebsite.com, and the Zimbra Collaboration Suite user name and login page and then log in.

    So on my Droid X, I've got 2 options as far as setting up this email... "corporate sync" and "email".... the corporate sync I am unfamiliar with and this seems to be what the OP is referring to? I have the following set up my info in my work profile email and all is well, except I can't send email.

    Email's incoming server settings:
    POP3
    server: mail.myworkemail.com
    Port: 110
    username: billys@myworkemail.com
    Password: the password
    secure connection and verify certficate are not checked.

    Email's outgoing server:
    SMTP server: mail.myworkemail.com (have also tried smtp.myworkemail.com)
    Port: 465
    Username: billys@myworkemail.com
    Password: the password
    secure connection and verify certifcate are checked.

    Now these above settings are the same ones I used on my last few blackberries and everything worked fine. This bug that everyone was talking about...that is referring to the corporate and not the pop3?

    I don't know about the corporate sync settings...but the fields for that are:
    Domain/Username: ? billys@myworkemail.com?
    Password: the password
    Use secure connection check box (checked)
    email address: billys@myworkemail.com
    server: ? the microsoft exhange server? i.e. myworkemail.com?

    Sorry for the long post, I just can't figure out why something so tried and true on previous phones can't work on my Droid X... thanks for the help!

Similar Threads

  1. Zimbra GAL and GALSync Questions Since Upgrading to 6.0
    By Chewie71 in forum Administrators
    Replies: 2
    Last Post: 01-13-2010, 12:31 PM
  2. Replies: 13
    Last Post: 11-20-2008, 12:42 PM
  3. Hangs on "Loading" screen
    By gbr in forum General Questions
    Replies: 16
    Last Post: 06-19-2008, 02:01 PM
  4. zdesktop issue report (2008-05-22 17:25:42): mail.NO_SUCH_MSG
    By John Marsden, FH Ba in forum Error Reports
    Replies: 0
    Last Post: 05-23-2008, 03:49 AM
  5. Z-Mobile & Motorola Q - sync issues
    By dwill in forum Zimbra Mobile
    Replies: 0
    Last Post: 11-17-2006, 09:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •