Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: General questions to Zimbra and Z-Push

  1. #1
    Join Date
    Feb 2012
    Posts
    12
    Rep Power
    3

    Default General questions to Zimbra and Z-Push

    Hello,

    first of all I want to say that IŽam very new to Zimbra and Z-Push.

    I run now a Zimbra OS 7 on a Ubuntu 10.04 LTS. Ubuntu was a clean install with DNS and SSH server - nothing more.

    I want to install Z-Push for Active Sync. So I found the following guide: Z-Push with Zimbra and HTML Support - vWiki


    My problem now: I canŽt find any /var/www folder or the apache ...

    What wrong there, did I miss something? IŽam really confused about the Zimbra installation regarding the Apache.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by pauLee View Post
    My problem now: I canŽt find any /var/www folder or the apache ...

    What wrong there, did I miss something? IŽam really confused about the Zimbra installation regarding the Apache.
    The 'missing' directory is nothing to do with your Zimbra installation, you are installing additional software and you need to follow the instructions in that wiki article - if you don't already have it then you need Apache or some other web server installed.
    Last edited by phoenix; 08-07-2012 at 11:01 PM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Feb 2012
    Posts
    12
    Rep Power
    3

    Default

    Ok, thank you. I didnŽt know that I need an additional Apache, so I will install it also.

  4. #4
    Join Date
    Feb 2012
    Posts
    12
    Rep Power
    3

    Default

    Ok, Apache is installed but can not start because Zimbra runs on port 80 ... I need to investigate a bit more.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by pauLee View Post
    Ok, Apache is installed but can not start because Zimbra runs on port 80 ... I need to investigate a bit more.
    Then change ZCS to use https, see zmtlsctl in the forum and wiki.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Quote Originally Posted by pauLee View Post
    Ok, Apache is installed but can not start because Zimbra runs on port 80 ... I need to investigate a bit more.
    That's one of the main reasons we typically suggest you run z-push on a separate server.

    Running it on a separate server also avoids any issues when performing zimbra upgrades. The z-push instance on it's own server will be left untouched.

  7. #7
    Join Date
    Feb 2009
    Location
    Manila, Philippines
    Posts
    66
    Rep Power
    6

    Default

    Hi Bill,

    Sorry if this is a bit off the topic but the thread says general questions.

    Just want to ask does the Z-Push server save all of the user's email and PIM information in its own storage? Because I've created a z-push server on a virtual machine with just 20GB of space and after using it for 2-3 weeks with 7 users it gets full and then it stops working.

    We are using Funambol before but it only acts as a mediator between the mobile phone and Zimbra and no messages are kept in its server.

  8. #8
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default

    Do you have debug logging turned on? There is no log rotation/trimming built in to z-push, so you could be running out of space due to logging. Look for debug.txt in the z-push root folder. Delete the file, and if it gets recreated, change the permissions on it to be read only.

    Apart from that, it stores state information locally which should not take up too much space.

  9. #9
    Join Date
    Feb 2009
    Location
    Manila, Philippines
    Posts
    66
    Rep Power
    6

    Default

    Quote Originally Posted by liverpoolfcfan View Post
    Do you have debug logging turned on? There is no log rotation/trimming built in to z-push, so you could be running out of space due to logging. Look for debug.txt in the z-push root folder. Delete the file, and if it gets recreated, change the permissions on it to be read only.

    Apart from that, it stores state information locally which should not take up too much space.
    Thanks for this, I haven't put attention yet to my offline Z-Push since I've been busy this week. I shall rebuild again my server.

  10. #10
    Join Date
    Feb 2009
    Location
    Manila, Philippines
    Posts
    66
    Rep Power
    6

    Default

    I'm doing the re installation of my z-push but it seems that this link svn://svn.berlios.de/z-push/branches/as12.1 is now dead. I'm using this guide for my installation: Z-Push with Zimbra and HTML Support - vWiki.

    Any ideas where to get the as12.1? Thanks

Similar Threads

  1. Some General Newb Questions
    By LoneCrowe in forum Administrators
    Replies: 2
    Last Post: 08-22-2012, 12:50 PM
  2. Lots of General Questions
    By eddiewu80 in forum Administrators
    Replies: 2
    Last Post: 09-29-2010, 12:34 PM
  3. Lots of General Questions
    By eddiewu80 in forum General Questions
    Replies: 1
    Last Post: 09-29-2010, 12:55 AM
  4. Couple general questions
    By krdell in forum Users
    Replies: 0
    Last Post: 04-25-2008, 01:33 PM
  5. Zimlet - pull/push to MySQL(or db in general)
    By pgp4privacy in forum Zimlets
    Replies: 2
    Last Post: 11-08-2006, 04:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •