Search found 5 matches

by fostah
Wed Aug 23, 2017 4:51 pm
Forum: Zimlets
Topic: [SOLVED] service/zimlet/res/Zimlets-nodev_all.js.zgz returning 500 error
Replies: 1
Views: 2024

Re: service/zimlet/res/Zimlets-nodev_all.js.zgz returning 500 error

For anyone else having this problem, This issue was caused by two issues: - YUI Compressor (used to package the JS) was not validating. Download the YUI compressor JAR to validate manually to see if your code passes. - Ensure you compile your code down to ES5. ES6+ will cause compilation errors. For...
by fostah
Tue Mar 14, 2017 8:51 pm
Forum: Zimlets
Topic: [SOLVED] service/zimlet/res/Zimlets-nodev_all.js.zgz returning 500 error
Replies: 1
Views: 2024

[SOLVED] service/zimlet/res/Zimlets-nodev_all.js.zgz returning 500 error

Platform: Zimbra Network Edition 8.6 I am developing a custom zimlet for a client, and the zimlet runs perfectly in ?dev=1 mode. However, in production mode, I am getting back a 500 error for the following requests while loading the zimlet: GET https://zimbra.diamond.dev/service/zimlet/res/Zimlets-n...
by fostah
Wed Nov 30, 2016 4:04 pm
Forum: Zimlets
Topic: Zimlet's in Mobile/Touch view
Replies: 2
Views: 3025

Zimlet's in Mobile/Touch view

Does Zimbra offer any way to create Zimlets for the mobile view of Zimbra? From what I have seen, Zimlets are not loaded at all in the mobile view. Is there a recommended way to inject extra Javascript for mobile view if Zimlets are not loaded? Additionally, does the Touch Client allow zimlets? Zimb...
by fostah
Mon Nov 28, 2016 11:31 pm
Forum: Zimlets
Topic: Zimbra's code minification is breaking zimlet
Replies: 1
Views: 1885

Zimbra's code minification is breaking zimlet

Platform: Zimbra 8.6 Problem: After installing an open source zimlet (ConverseJS: https://github.com/Zimbra-Community/com_zimbra_converse), I am getting unusual console errors. When running with ?dev=1, the zimlet works fine. Console Error: Uncaught TypeError: ee is not a function(…) Zimlets-nodev_...
by fostah
Mon Oct 24, 2016 8:59 pm
Forum: Zimlets
Topic: Error: zimlet description not found: com_zimbra_sms.xml
Replies: 2
Views: 2465

Re: Error: zimlet description not found: com_zimbra_sms.xml

I ran into this same problem, however on a Mac. For those of you googling like I did, I resolved this by making sure you use the command line zip program to create your zips. When using the GUI zip program you will get extra DS_Store and __MACOSX folders. Bad Zip: $ zipinfo com_zimbra_example_simple...

Go to advanced search