Page 7 of 8 FirstFirst ... 5678 LastLast
Results 61 to 70 of 77

Thread: Zimbra and Joomla Project

  1. #61
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Found it out myself.

    For those who are interested:

    Just leave Base DN blank and in Search String enter: mail=[search]

    Authorization Method is Bind and Search, Full Name is displayName, E-Mail is mail and User ID is uid.

    With these simple settings, users who enter their Email address as username and their zimbra password are logged in in Joomla.

    Chris

  2. #62
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Ok. Now that I have upgraded my Zimbra server to 5.0.8 I still can't get Joomla to login directly to Zimbra email server. When ever I click the link I get a page couldn't be displayed error.

    dj

  3. #63
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Never mind I got it. I had not put my key in and then had to change the PreAuth link to a http and not https.

    Works great now. Thanks.

    dj

  4. #64
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    I wanted to kind of bring this thread back out again. We are in the process of creating a second Joomla site in our organization but this time we only want one group of users be able to log in. All of the users will be Zimbra users also and will be included in one email distribution list.

    Is it possible to use that list name to authenticate against? If they are a part of that list, then let them in, if not then no.

    dj

  5. #65
    Join Date
    Nov 2010
    Posts
    6
    Rep Power
    4

    Default

    The website of richard is down, registration don't work, his email don't work anymore, so I can't download zimbra info mail module for joomla, someone can send me the file ?

    Thanks a lot

  6. #66
    Join Date
    Nov 2007
    Posts
    34
    Rep Power
    7

    Default All looks ok to me

    Hi just check the site and everything is working ok.
    Richard
    ----------------------------------------------
    Having signatures is a sign of having signatures.

  7. #67
    Join Date
    May 2009
    Posts
    46
    Rep Power
    6

    Unhappy Joomla 2.5.1 LDAP

    hello,

    i cannot get it working. i tried a lot of this forum, but nothing works.

    My system:
    Zimbra network edition, 7.1.3
    joomla 2.5.1

    domain: example.de
    url to zimbra: zimbra.example.de

    Users should be able to login into joomla using their zimbra account and password. I don't want to create new joomla users for each zimbra account. Is it still possible?

    What do I need to enter here? I wrote:
    Host: zimbra.example.de
    Port: 389
    LDAP V3: YES
    Negotiate TLS: NO
    Follow Referrals: NO
    Authorisation Method: Bind and Search
    Base DN: ou=people,dc=example,dc=de
    Search String:
    User's DN: mail=[search]
    Connect Username:
    Connect Password:
    Map Full Name: displayName
    Map email: mail
    Map User ID: uid

    Plugin is enabled. Trying to login with my accout testuser@example.de, it tells me that the user isn't found.

    I tried two ways:
    user: testuser@example.de
    password: mypassword

    and
    user: testuser
    password: mypassword

    Nothing works.

    What do I have to edit in my ldap configuration and what do i have to enter as user and password?

    Thanks for helping!

  8. #68
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    On mine I have nothing in the User's DN and uid=[search] in the search string. I think that is the only thing I have different than yours.

    dj


    Quote Originally Posted by Sprengel View Post
    hello,

    i cannot get it working. i tried a lot of this forum, but nothing works.

    My system:
    Zimbra network edition, 7.1.3
    joomla 2.5.1

    domain: example.de
    url to zimbra: zimbra.example.de

    Users should be able to login into joomla using their zimbra account and password. I don't want to create new joomla users for each zimbra account. Is it still possible?

    What do I need to enter here? I wrote:
    Host: zimbra.example.de
    Port: 389
    LDAP V3: YES
    Negotiate TLS: NO
    Follow Referrals: NO
    Authorisation Method: Bind and Search
    Base DN: ou=people,dc=example,dc=de
    Search String:
    User's DN: mail=[search]
    Connect Username:
    Connect Password:
    Map Full Name: displayName
    Map email: mail
    Map User ID: uid

    Plugin is enabled. Trying to login with my accout testuser@example.de, it tells me that the user isn't found.

    I tried two ways:
    user: testuser@example.de
    password: mypassword

    and
    user: testuser
    password: mypassword

    Nothing works.

    What do I have to edit in my ldap configuration and what do i have to enter as user and password?

    Thanks for helping!

  9. #69
    Join Date
    May 2009
    Posts
    46
    Rep Power
    6

    Default

    Quote Originally Posted by dljordaneku View Post
    On mine I have nothing in the User's DN and uid=[search] in the search string. I think that is the only thing I have different than yours.

    dj
    I have tried your way, but there is still the error "User cannot be found". I have no idea

  10. #70
    Join Date
    Sep 2007
    Location
    Richmond, Ky
    Posts
    281
    Rep Power
    8

    Default

    Are both of the servers in the same area, ie dmz, outside? Is port 389 accessible from the Joomla server? If it can't get to the port then it won't allow Joomla to pull the users.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •