Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Mailbox Stopped

  1. #11
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default tomcat

    Now you have to start tomcat

    su - zimbra
    tomcat start

  2. #12
    Join Date
    Nov 2005
    Posts
    18
    Rep Power
    9

    Default mailbox still stopped

    Hiya,

    Firstly, I appreciate the help, and I am hoping these experiences will eventually enrich the project and make it easier for those that follow.

    su - zimbra
    tomcat start

    mysql.server start &
    (have to control-z that)

    zmcontrol stop (just to make sure)
    zmcontrol start
    - all come up "done"

    zmcontrol status
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    mta Running
    snmp Running
    spell Running

  3. #13
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default Why?

    WHy are you doing it that way? Specifically, why start tomcat before sql, when tomcat won't run without sql?

    su - zimbra
    zmmailboxctl stop
    zmmailboxctl start
    sh -x zmmailboxctl status

    post the output of the last command.

  4. #14
    Join Date
    Nov 2005
    Posts
    18
    Rep Power
    9

    Default

    ok, done that:

    202:~ zimbra$ sh -x zmmailboxctl status
    + BASE=/opt/zimbra
    + SCRIPTS=tomcat mysql.server
    + STATUS=0
    + '[' tomcat = mysql.server ']'
    + /opt/zimbra/bin/tomcat status
    + R=1
    + '[' 1 -ne 0 ']'
    + STATUS=1
    + '[' mysql.server = mysql.server ']'
    + /opt/zimbra/bin/mysqladmin status
    + R=1
    + '[' 1 -ne 0 ']'
    + STATUS=1
    + exit 1

    Does that help at all?

  5. #15
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default mysql not starting

    su - zimbra
    mysql.server start
    mysqladmin status

    Any errors? Also check /var/log/zimbra.log

  6. #16
    Join Date
    Nov 2005
    Posts
    18
    Rep Power
    9

    Default

    202:~ zimbra$ zmcontrol status
    Host XXXreplacedXXX
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    mta Running
    snmp Running
    spell Running
    202:~ zimbra$ mysql.server start
    202:~ zimbra$ A mysqld process already exists
    mysqladmin status
    /opt/zimbra/mysql/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'
    202:~ zimbra$ tail -f -n 20 /var/log/zimbra.log

    no errors apparent in the log, only the status of things

  7. #17
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default mysql password recovery

    Kill your mysql process, and restart it with mysql.server - if the mysqladmin returns an errror after that, we'll have to reset your password:

    zmcontrol stop
    zmlocalconfig -e zimbra_mysql_password=newpasswd
    zmlocalconfig -e mysql_root_password=newrootpasswd

    edit /opt/zimbra/bin/mysql.server

    Change
    'start')
    # --defaults-file must be first argument
    cd ${mysql_directory}; \
    ${mysql_directory}/bin/mysqld_safe \
    --defaults-file=${mysql_mycnf} \
    --ledir=${mysql_directory}/bin &
    ;;

    to
    'start')
    # --defaults-file must be first argument
    cd ${mysql_directory}; \
    ${mysql_directory}/bin/mysqld_safe \
    --defaults-file=${mysql_mycnf} \
    --skip-grant-tables \
    --ledir=${mysql_directory}/bin &
    ;;

    su - zimbra
    mysql.server start

    mysql mysql
    update user set password=PASSWORD('newpasswd') where user='zimbra';
    update user set password=PASSWORD('newrootpasswd') where user='root';
    flush privileges
    exit

    mysql.server stop
    Change mysql.server back (remove --skip-grant-tables)
    mysql.server start
    mysqladmin status

  8. #18
    Join Date
    Nov 2005
    Posts
    18
    Rep Power
    9

    Default mysql pwd.

    hmmmm...

    zmcontrol stop
    zmlocalconfig -e zimbra_mysql_password=newpasswd

    Error: can not edit key zimbra_mysql_password

    even sudo'ing it I get the same...

  9. #19
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default forgot -f

    Add -f to both of those (zmlocalconfig -f -e ...)

    Sorry

  10. #20
    Join Date
    Nov 2005
    Posts
    18
    Rep Power
    9

    Default Wahoo!

    Sweet, all good now

    Ok, now onto configuration... oh, and at some point I will have to get this autostarting if it does end up meeting my needs, which it does look like it will

    Once again - Thanks!!!

Similar Threads

  1. Replies: 210
    Last Post: 01-17-2012, 12:19 AM
  2. mailbox stopped
    By rene.metaal in forum Installation
    Replies: 10
    Last Post: 06-20-2008, 05:15 AM
  3. Mailbox stopped
    By Phantasmagoria in forum Administrators
    Replies: 1
    Last Post: 01-05-2007, 09:50 AM
  4. Upgrade Trouble woooo
    By RobertW in forum Installation
    Replies: 3
    Last Post: 06-15-2006, 05:24 PM
  5. Tomcat hanging
    By Morg0 in forum Administrators
    Replies: 42
    Last Post: 04-19-2006, 08:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •