Results 1 to 10 of 10

Thread: problema con Zimbra...6.06 en vmware ubuntu

Hybrid View

  1. #1
    Join Date
    Jun 2010
    Posts
    12
    Rep Power
    5

    Default problema con Zimbra...6.06 en vmware ubuntu

    No se si os ha pasado a alguno, en alguna version pero cada cierto tiempo...con outlook o desde el mismo zimbra les dice que la contraseña, a los usuarios, es incorrecta de la red como si no funcionara el mailbox, cosa que si funciona, y reiniciando zimbra termina por funcionar...hasta la siguiente vez

    Exactamente, si es desde el outlook, pide introducir la contraseña de nuevo en el la cola de correo de zimbra, los correos quedan atascados y pone que mailbox no esta disponible o algo asi...

    No se si os ha pasado a algun antes

    EN zimbra, pone connection refuse o error o algo asi, con simbolos de interrogacion

    muchas gracias por la ayuda

  2. #2
    Join Date
    Mar 2010
    Posts
    23
    Rep Power
    5

    Default

    Quote Originally Posted by hatake_pablo View Post
    EN zimbra, pone connection refuse o error o algo asi, con simbolos de interrogacion
    mm no se.. pero yo miraría los log, para ver porque se cae.. (Mi primer instalación se caía a cada rato y era porque estaba mal configurada)
    mira Log Files - Zimbra :: Wiki

  3. #3
    Join Date
    Jun 2010
    Posts
    12
    Rep Power
    5

    Default

    mi instalacion no se cae cada rato...sino que tarda dias en caer pero el mailbox...lo demas funciona y ademas los servicios ponen que estan levantados y ningun error con el zmcontrol ni con el administrador web de zimbra...salvo que los emails se quedan en cola con el erro de que el mailbox esta caido...

    y creo recordar que en los logs no aparecia nada, pero la proxima vez que pase, que lo hara revisare todos los logs detenidamente

    muchas gracias :d y ya comento algo

  4. #4
    Join Date
    Jun 2010
    Posts
    12
    Rep Power
    5

    Default

    Estos son los errores que me salen en mailbox.log

    2010-08-19 15:28:34,668 INFO [LmtpServer-1759] [ip=172.16.10.5;] lmtp - 450 4.2.1 Mailbox disabled, not accepting messages (RCPT TO:<usuario@midominio.es>)
    2010-08-19 15:28:34,668 WARN [LmtpServer-1759] [ip=172.16.10.5;] lmtp - try again for address usuario2@midominio.es: exception occurred
    com.zimbra.common.service.ServiceException: system failure: ZimbraLdapContext
    ExceptionId:LmtpServer-1759:1282224514668:e1b468e4894ec80c
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:248)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.<init >(ZimbraLdapContext.java:391)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.<init >(ZimbraLdapContext.java:352)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getAcc ountByQuery(LdapProvisioning.java:584)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getAcc ountByNameInternal(LdapProvisioning.java:758)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getAcc ountByName(LdapProvisioning.java:736)
    at com.zimbra.cs.account.ldap.LdapProvisioning.get(Ld apProvisioning.java:644)
    at com.zimbra.cs.account.ldap.LdapProvisioning.get(Ld apProvisioning.java:629)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.getAddr essStatus(ZimbraLmtpBackend.java:102)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doRCPT(LmtpHa ndler.java:331)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:162)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCom mand(TcpLmtpHandler.java:66)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:175)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:132)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)
    Caused by: javax.naming.CommunicationException: Bad file descriptor [Root exception is java.net.SocketException: Bad file descriptor]
    at com.sun.jndi.ldap.LdapCtx.extendedOperation(LdapCt x.java:3213)
    at javax.naming.ldap.InitialLdapContext.extendedOpera tion(InitialLdapContext.java:164)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.<init >(ZimbraLdapContext.java:381)
    ... 14 more
    Caused by: java.net.SocketException: Bad file descriptor
    at java.net.SocketOutputStream.socketWrite0(Native Method)
    at java.net.SocketOutputStream.socketWrite(SocketOutp utStream.java:92)
    at java.net.SocketOutputStream.write(SocketOutputStre am.java:136)
    at java.io.BufferedOutputStream.flushBuffer(BufferedO utputStream.java:65)
    at java.io.BufferedOutputStream.flush(BufferedOutputS tream.java:123)
    at com.sun.jndi.ldap.Connection.writeRequest(Connecti on.java:393)
    at com.sun.jndi.ldap.LdapClient.extendedOp(LdapClient .java:1172)
    at com.sun.jndi.ldap.LdapCtx.extendedOperation(LdapCt x.java:3160)
    ... 16 more

  5. #5
    Join Date
    Mar 2010
    Posts
    23
    Rep Power
    5

    Default

    Quote Originally Posted by hatake_pablo View Post
    Estos son los errores que me salen en mailbox.log

    2010-08-19 15:28:34,668 INFO [LmtpServer-1759] [ip=172.16.10.5;]
    com.zimbra.common.service.ServiceException: system failure: ZimbraLdapContext
    ExceptionId:LmtpServer-1759:1282224514668:e1b468e4894ec80c
    Code:service.FAILURE

    Caused by: java.net.SocketException: Bad file descriptor
    at java.net.SocketOutputStream.socketWrite0(Native Method)
    at java.net.SocketOutputStream.socketWrite
    Hola hatake_pablo, realmente no se cual es la razon, pero los errores son muy similares a los que me pasaba a mi.. el error "ZimbraLdapContext" es muy genérico y no ayuda a buscar nada..
    En mi caso, creo que fue porque lo instale mal, puse mal los parámetros en la instalación y eso hacia que el ldap falle.
    Yo podia forzar la caida de zimbra con el Zimbra_Outlook_PST_Import_Wizard. fijate tal ves podes encontrar algo..

    Zimbra no se cae.. yo lo tengo andado hace meses.. (3-6)

    Saludos.

  6. #6
    Join Date
    Jun 2010
    Posts
    12
    Rep Power
    5

    Default

    muchas gracias, seguire investigando..

    aunque el error sea generico...es decir, se caiga el servicio ldap aunque zimbra diga que esta ok....tiene que ver con la parte bad file descriptor, creo

    saludos!!!

  7. #7
    Join Date
    Oct 2010
    Location
    Santiago
    Posts
    15
    Rep Power
    4

    Default

    Creo tener el mismo problema, comienza a denegar los accesos por web o cliente pop, los servicios permanecen todos en estado running.
    Al reiniciar los servicios vuelve a la normalidad, envío y recepción funcionan sin ningun problema.
    Alguna idea de cual puede ser el problema y alguna solución??

    Code:
    2010-11-23 06:45:29,310 INFO  [Pop3Server-7217] [] ProtocolHandler - Handler exiting normally
    2010-11-23 06:45:29,348 INFO  [Pop3Server-7159] [ip=200.27.232.XXX;] pop - connected
    2010-11-23 06:45:29,348 INFO  [Pop3Server-7159] [ip=200.27.232.XXX;] ProtocolHandler - Exception occurred while handling connection
    java.net.SocketException: Bad file descriptor
    	at java.net.SocketOutputStream.socketWrite0(Native Method)
    	at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
    	at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
    	at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65)
    	at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
    	at com.zimbra.cs.pop3.Pop3Handler.sendLine(Pop3Handler.java:364)
    	at com.zimbra.cs.pop3.Pop3Handler.sendResponse(Pop3Handler.java:353)
    	at com.zimbra.cs.pop3.Pop3Handler.sendOK(Pop3Handler.java:328)
    	at com.zimbra.cs.pop3.Pop3Handler.startConnection(Pop3Handler.java:117)
    	at com.zimbra.cs.pop3.TcpPop3Handler.setupConnection(TcpPop3Handler.java:42)
    	at com.zimbra.cs.tcpserver.ProtocolHandler.run(ProtocolHandler.java:137)
    	at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(Unknown Source)
    	at java.lang.Thread.run(Thread.java:619)

  8. #8
    Join Date
    Oct 2010
    Location
    Santiago
    Posts
    15
    Rep Power
    4

    Default

    Revisa el post 81 de este link

    https://bugzilla.zimbra.com/show_bug.cgi?id=42870#c81

    Aplique la solución indicada y no he tenido el problema en 5 días y contando..
    Vamos a ver si sigue asi

  9. #9
    Join Date
    Jun 2010
    Posts
    12
    Rep Power
    5

    Default

    Quote Originally Posted by hmayorga View Post
    Revisa el post 81 de este link

    https://bugzilla.zimbra.com/show_bug.cgi?id=42870#c81

    Aplique la solución indicada y no he tenido el problema en 5 días y contando..
    Vamos a ver si sigue asi
    Muchas gracias, me fue bien

Similar Threads

  1. Get emails out of zimbra or get it working again?
    By kingfeanor in forum Migration
    Replies: 9
    Last Post: 11-25-2008, 12:02 AM
  2. Zimbra spam system
    By rajahd in forum Administrators
    Replies: 9
    Last Post: 04-16-2008, 07:25 PM
  3. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 08:21 AM
  4. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  5. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •