SALUDOS A TODOS...

Mi problema es que tengo instalado un servidor zimbra que recibe y envia correos internos normalmente, de igual manera recibe correos de cuentas externas (hotmail, yahoo) el problema es que no envia correos a cuentas externas. No tengo un servidor DNS interno ya que eso lo contratamos de un proveedor... igualmente tengo un dominio que es midominio.com y el nombre del equipo es mail.midominio.com y con la IP publica estatica 200.56.98.23... he instalado correctamente el zimbra sobre el SO centos 6.4 en donde he configurado...

1.- El nombre de equipo... hostname
mail.midominio.com

2.- El archivo hosts
200.56.98.23 mail.midominio.com mail

3.- El archivo resolv.conf
nameserver 200.23.25.2 ------------- IP del servidor DNS de mi proveeedor
nameserver 200.23.25.3 -------------- IP del segundo servidor DNS de mi provedor

4.- Tengo deshabilitado el SeLinux
5.- Tengo habiertos los puertos de mi IPtables
-A INPUT -p tcp -m tcp -m state --dport 25 --state NEW -j ACCEPT
6.- Compruebo que funcione los DNS con dig midominio.com mx

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> midominio.com mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18089
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;midominio.com IN MX

;; ANSWER SECTION:
midominio.com. 86400 IN MX 0 mail.midominio.com

;; AUTHORITY SECTION:
midominio.com. 86400 IN NS io.proveedor.net.
midominio.com. 86400 IN NS uio.proveedor.net.

;; ADDITIONAL SECTION:
mail.midominio.com. 86400 IN A 200.56.98.23
io.proveedor.net. 86400 IN A 200.23.25.2
uio.proveedor.net. 86400 IN A 200.23.25.3

;; Query time: 14 msec
;; SERVER: 200.23.25.2#53(200.23.25.2)
;; WHEN: Mon Jul 1 12:38:28 2013
;; MSG SIZE rcvd: 153

Esa es toda la configuracion que he hecho la verdad no se donde esta el problema... Por otro lado les comento que al momento de instalar el zimbra se crea automaticamente el dominio mail.midominio.com de donde creo coge como dominio el nombre del equipo por lo cual las cuentas de correo se crean con user1@mail.midominio.com... En causa de esto cree un nuevo dominio llamado midominio.com y ahi si las cuentas se crean como user1@midominio.com... Como les comente ahi todo funciona bien internamente y de igual manera recibe correos de fuera el unico problema es que no puede enviar correos externos quedandose los correos en la cola de envio y con el estatus connect to mx4.hotmail.com[xxx.xxx.xxx.xxx]:25 connection time out.

Espero me puedan ayudar con este problema que ya llevo meses sin poder resolver gracias...