Results 1 to 3 of 3

Thread: RSS error when adding feed

  1. #1
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    10

    Default RSS error when adding feed

    When I try and add Planet Maemo to my Blogs folder I get the following error:

    Code:
    msg - parse error: could not parse feed
    com.zimbra.cs.service.ServiceException: parse error: could not parse feed
    	at com.zimbra.cs.service.ServiceException.PARSE_ERROR(ServiceException.java:117)
    	at com.zimbra.cs.service.FeedManager.retrieveRemoteDatasource(FeedManager.java:143)
    	at com.zimbra.cs.mailbox.Mailbox.importFeed(Mailbox.java:3543)
    	at com.zimbra.cs.mailbox.Mailbox.synchronizeFolder(Mailbox.java:3534)
    	at com.zimbra.cs.service.mail.CreateFolder.handle(CreateFolder.java:75)
    	at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEngine.java:249)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:163)
    	at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.java:84)
    	at com.zimbra.soap.SoapServlet.doPost(SoapServlet.java:226)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
    	at com.zimbra.cs.servlet.ZimbraServlet.service(ZimbraServlet.java:148)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:526)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:825)
    	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:738)
    	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:526)
    	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    	at java.lang.Thread.run(Thread.java:595)
    Caused by: org.dom4j.DocumentException: Error on line 92 of document  : The entity name must immediately follow the '&' in the entity reference. Nested exception: The entity name must immediately follow the '&' in the entity reference.
    	at org.dom4j.io.SAXReader.read(SAXReader.java:350)
    	at org.dom4j.io.SAXReader.read(SAXReader.java:264)
    	at com.zimbra.soap.Element.parseXML(Element.java:227)
    	at com.zimbra.soap.Element.parseXML(Element.java:225)
    	at com.zimbra.cs.service.FeedManager.retrieveRemoteDatasource(FeedManager.java:135)
    	... 25 more
    
    code - service.PARSE_ERROR
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Sender
    As I'm no programer I have no idea what it means.

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default Url?

    What URL are you using for the feed? The 2 I see on the page are
    http://planet.maemo.org/rss10.xml
    http://planet.maemo.org/rss20.xml

  3. #3
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    10

    Default Which feed?

    I'm trying both. I first tried the RSS2 feed, and when that moaned I tried the RSS1 feed. The error above is from the RSS2 feed.

Similar Threads

  1. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  2. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  3. Replies: 13
    Last Post: 10-31-2005, 04:22 PM
  4. Replies: 18
    Last Post: 10-30-2005, 09:12 PM
  5. Certify Error on (re)install
    By rodrigoccurvo in forum Installation
    Replies: 4
    Last Post: 09-23-2005, 10:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •