Results 1 to 6 of 6

Thread: Leopard Mail.app IMAP Issues

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Posts
    41
    Rep Power
    9

    Default Leopard Mail.app IMAP Issues

    Mail.app in Leopard has issues with moving mail with Zimbra.

    This is a complicated issue, as the problem does not appear if using other IMAP servers, and does not appear with Zimbra using other clients - therefore there is some weird combination.

    This issue is this:

    • Move a message from Folder A to Folder B
    • Now look through Mail.app - Folder A no longer has the message
    • Still in Mail.app - Folder B now has the moved message
    • Now in Zimbra Web client - Folder A has the message
    • AND Folder B has the message
    • And the message in Folder A is still marked Unread.


    Initially I thought this might be something to do with Inbox - as it is sort of special. So I started moving all my incoming mail to a normal folder, and then moving the messages from there - well same problem.

    Next time you run Mail.app it downloads and reads all the messages in that folder again - sometimes however it will skip them - somehow it knows they have been dealt with. Most of the time though they are loaded as brand new messages.

    This means you CAN NOT USE Mail.app - why because reading, moving, deleting mail, is all basically ignored.

    Because this does not appear with Mail.app with other servers - I have documented it here.

    There is also many other references to this on the internet.

    Scott

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Can you file a bug with exact reproduce steps? Might be a related bug here:

    Bug 21422 - MIME boundary seperator visible in Mail.app
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Scott-
    What version of server are you running?

  4. #4
    Join Date
    Mar 2006
    Posts
    41
    Rep Power
    9

    Default

    Hmmm... seems not the latest, I thought it was - 4.0.2_GA_362

    Should I still do a bug report if it is not the latest - seems there are other posts on the net like this one:

    Bagel Belly Blog: Zimbra + Mac OS X Leopard + Mail.app = WOE

    Which have the problem on 4.5.

    Scott

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    yeah
    file a bug anyway
    but you should also upgrade as 4.0 is almost end of life

  6. #6
    Join Date
    Mar 2006
    Posts
    41
    Rep Power
    9

    Default

    OK Bug entered - Bug 21658 - Leopard Mail.app and IMAP will not move files or mark as read

    I will try and upgrade to the latest stable this weekend and reproduce the problem.

    Scott

Similar Threads

  1. Replies: 37
    Last Post: 12-28-2010, 06:02 PM
  2. Mail.app: imap or exchange
    By ish in forum CalDAV / CardDAV / iSync
    Replies: 1
    Last Post: 05-12-2007, 08:06 AM
  3. Lost Messages Moving from POP3 to IMAP in Mail.app
    By soxfan in forum Administrators
    Replies: 1
    Last Post: 03-23-2007, 12:03 PM
  4. Error on IMAP - Tomcat crashes!
    By rodrigoccurvo in forum Administrators
    Replies: 5
    Last Post: 11-30-2005, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •