Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: RSS feed emails

  1. #11
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    22

    Default

    Dont' forget to vote for the actual RFE: Bug 16063 - Sharing Mail folder to External Guests/Public

    (Bug 18513 - Remove "external" and "public" options from the folder share dialog was opened as a temp solution from that because the 500 errors we're just confusing users.)

  2. #12
    Join Date
    Jul 2006
    Location
    Australia, ACT
    Posts
    197
    Rep Power
    10

    Smile Holy crap!

    Quote Originally Posted by mmorse View Post
    5.0.1 included the ability to get free busy info by visiting http:// server.domain.com/home/username?fmt=freebusy which will display an aggregate HTML calendar for all the user's free-busy data. (Of course you can always choose to select "exclude this calendar when reporting free/busy times" if you wish.)

    In 5.0, we added the ability to go to http:// server.domain.com/home/username/Calendar.html to see an easily readable day/week/month view. (The publisher must share the calendar specifically or publicly in order for you to see it.)
    Holy crap! That's a bloody awesome feature!

  3. #13
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    22

    Default

    Yup, would be why I highlighted it again

  4. #14
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    22

    Default

    For clarity:

    You can do /home/username?fmt=freebusy without needing to do any sharing setup - which we found way more intuitive and productive.
    (To hide that for privacy you can exclude it from FB reporting.)

    For /home/username/Calendar.html access it needs to be shared publicly or specifically.

  5. #15
    Join Date
    Jul 2006
    Location
    Australia, ACT
    Posts
    197
    Rep Power
    10

    Question RSS feed to Zimbra folders - URL login seems to be the problem

    Here's my situation, I am trying to get an RSS feed to my inbox and to a few other folders so that I can have an instant alert pop-up in my RSS reader (KDE Desktop, Akregator). I used to have these RSS feeds setup a while back when we were on Zimbra 4.5 and due to desktop upgrades (y'know how quickly Linux desktops come out) I lost those feeds. Anyway, in Zimbra 4.5 this worked and was a simple setup.

    The problem I am having is that the URL login method does not seem to be working with Zimbra 5.0.5. There is no authentication prompt in the browser and so I suspect that Firefox, Akregator etc. is not submitting the login/password as a result.

    For example: using wget from the command line does WORK.
    Code:
    wget --no-check-certificate --user='greenrenault' --password='ZimbraROCKS' https://webmail.australia.gov.au/zimbra/home/greenrenault/inbox?fmt=rss&query="in:inbox is:unread"
    However trying the same URL using Firefox, Konqueror (or Akregator) with the login/password encoded does not work.
    Code:
    https://greenrenault:ZimbraROCKS@webmail.australia.gov.au/zimbra/home/greenrenault/inbox?fmt=rss&query="in:inbox is:unread"
    or even simpler again using Firefox, Konqueror (or Akregator):
    Code:
    https://greenrenault:ZimbraROCKS@webmail.australia.gov.au/zimbra/home/greenrenault/inbox?fmt=rss
    When using Firefox, a warning is displayed 'You are trying to login to a website that does not require authentication. This may be an attempt to trick you, do you want to continue?' (or similar)

    I have even changed the password so that it does not include any special characters which may be buggered up in the URL.

    Any ideas? Am I a complete moron and missing something crucial?
    Last edited by greenrenault; 04-30-2008 at 02:41 PM.

  6. #16
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    22

    Default

    I can do it fine with a while bunch of different combinations of /zimbra/home/, /service/user/, with or without using the password on that line, and against https.

    Do you have more than one domain? Try adding %40domain.com to the line.

  7. #17
    Join Date
    Jul 2006
    Location
    Australia, ACT
    Posts
    197
    Rep Power
    10

    Default

    Just the one domain name, tried appending domain.com to the user name and still no luck.

  8. #18
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    22

    Default

    Reports currently working:
    Quote Originally Posted by greenrenault
    Hey buddy

    I'm at work now and it's working, which is really odd. Especially since requests go thru the same proxy server externally as internally. I did logout and re-login to the desktop so I wonder if closing Firefox and KDE caused something to be fixed.

    I'll try again tonight from home to see if it happens again.

    UPDATE: https://www.zimbra.com/forums/users/...s-via-rss.html
    Last edited by mmorse; 02-20-2010 at 07:42 PM.

  9. #19
    Join Date
    Jun 2007
    Posts
    7
    Rep Power
    9

    Default

    Hi

    After upgrading to 5.0.8 i have got some problems with rest -> rss

    In firefox 3
    using:
    https://mailserver/zimbra/home/usern...uery=is:unread

    just a blank rss-feed shows , no question for username and password

    Using:
    https://mailserver/zimbra/home/username/inbox?fmt=rss
    Question for username is shown and the an rss whith all mails..
    After that i can add &query=is:unread and it works ...


    So including query dos´nt show auth question...

Similar Threads

  1. RSS Feed for these forums?
    By DanCody in forum Developers
    Replies: 2
    Last Post: 11-01-2006, 08:47 AM
  2. Replies: 5
    Last Post: 07-20-2006, 05:24 AM
  3. Problem when adding new RSS feed
    By fmodola in forum Users
    Replies: 13
    Last Post: 04-11-2006, 06:42 AM
  4. RSS Feed for Calendar - need API or examples
    By cjhall in forum Developers
    Replies: 1
    Last Post: 03-03-2006, 10:31 AM
  5. RSS Feed Folders Delete Old Automatically
    By unilogic in forum Developers
    Replies: 1
    Last Post: 12-06-2005, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •