Results 1 to 3 of 3

Thread: IMAP Login Problem

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Location
    Ohio
    Posts
    39
    Rep Power
    9

    Default IMAP Login Problem

    I'm considering a migration from iPlanet Messaging Server to Zimbra. One piece I need to evaluate for my supervisor is the use of standard IMAP clients like Outlook Express and Thunderbird. I've already posted a question on the Mozillazine Thunderbird forum regarding my problem. I firmly believe the problem lies with Thunderbird, but haven't recieved a response so I'm wondering if anyone here has had a similar experience? I really want to try Zimbra with Thunderbird, but it's not working for me in my multidomain configuration. Below is a copy of my post from the Mozillazine Thunderbird forum:

    ----

    I'm a mail administrator for a medium sized organization. One of the rules that I put in place was that all users MUST use IMAP as their mail transport. For various reasons this is more desirable than POP. I took over the mail system when we migrated to iPlanet Messaging Server (now SunOne). On my desktop (Linux), I used to use Mozilla Mail and now use Firefox as my mail client. One of the first problems I ran into when we moved from Netscape Mail 3.0 to iPlanet Messaging Server was IMAP logins. Before I posted this, I did a bit of Googling and also searched the forums here, but have found no satisfactory solution for the problem, which I believe to be a design issue in Thunderbird. (Unless there is some obscure setting in user.js or prefs.js I'm not aware of) For clarity, I'll try to break this down within my example:

    My e-mail address on a test server is: eno2001@ztest.myorganization.com
    My username on the test server is: eno2001@ztest.myorganization.com
    My IMAP/SMTP server host name is: zimbratest.myorganization.com

    Since this server will host multiple mail domains, the username format MUST be user@domain.com. There is no way around this and it is pretty standard practice with every mail server I've seen that handles multiple mail domains. So I fill in my account information using the above info. However when I attempt to log in, Thunderbird appends the server name to the username which prevents the login from working:

    eno2001@ztest.myorganization.com@zim... nization.com

    This results in a login failure since the mail server will never recognize the above as a proper login. Support folks at iPlanet gave me a workaround for this by changing an obscure setting to allow a '+' to be used in place of the '@' in the username. That would present:

    eno2001+domain.com@server.domain.com

    This worked. But it occurs to me that this shouldn't be an issue at the server end. It is a CLIENT end issue. Thunderbird's behavior is correct for servers that only host one domain. If my account info were:

    e-mail address: eno2001@domain.com
    un: eno2001
    server: domain.com

    The result 'eno2001@domain.com' would be correct. I've been seeing this issue since 2000 and it still pops up to bite me from time to time. The workaround on the iPlanet server worked. I use CourierIMAP at home which also appears to just accept the the user@domain.com@server.domain.com format. I am now starting to test with Zimbra to move away from SunOne and I've run into the same problem again. While it might be convenient to have Thunderbird formulate the login by appending the server name to the user name, it's not correc in every instance. Why not add a checkbox next to the UN field that says "Send UN exactly as entered (do not append server name)". This would allow users to configure whether or not the login gets sent in that way or not. The default could be that this box is unchecked since it doesn't always happen. Does anyone know if this is a setting in prefs.js or user.js? None of the Knowledgbase or Forum articles mention a way around this.

    ----

    Note: I've already searched the Zimbra forums here for all thunderbird related questions and I haven't found any answers.

    Thanks,
    Deck

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    I'm using Thunderbird 1.5 and this seems to work fine for me. I have the following set:

    server: xxx.zimbra.com
    user: user@zimbra.com
    pass: ********

    So the server name and the domain are different and this seems to work just fine.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Feb 2006
    Location
    Ohio
    Posts
    39
    Rep Power
    9

    Default Doh! Fixed

    It WASN'T Thunderbird as I'd originally suspected. I was so used to having a problem logging into various IMAP servers with Mozilla Mail and this looked identical that I assumed it was the same problem. I tried another mail client to test (KMail in Gentoo Linux) and I got a better error message: "cleartext logins are disabled". I went to the Zimbra configuration page and enabled cleartext logins and restarted ZImbra. Then I tried to log in again and it worked just fine. The two things that threw me were the "user@domain.com@server.com" username that Thunderbird displayed and the error message "login failed", which is exactly what the old problem used to produce.

Similar Threads

  1. login screen problem
    By randyg in forum Administrators
    Replies: 1
    Last Post: 02-07-2007, 08:38 PM
  2. problem while building perl
    By ravinder in forum Developers
    Replies: 7
    Last Post: 05-29-2006, 09:38 AM
  3. Problem with IMAP
    By kernelpanic in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 03-10-2006, 04:44 AM
  4. Zimbra M3-270 Admin login problem
    By phoenix in forum Administrators
    Replies: 0
    Last Post: 12-09-2005, 05:29 AM
  5. Error on IMAP - Tomcat crashes!
    By rodrigoccurvo in forum Administrators
    Replies: 5
    Last Post: 11-30-2005, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •