Results 1 to 8 of 8

Thread: Attachment problems

  1. #1
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    9

    Default Attachment problems

    We are trying zim.

    .ppt attachments from two people were corrupted - ppt could not read them. One msg had multiple attachments and only one attachment appeared in zim - corrupted.

    These were forwarded from our current operational imap server and are ok when viewed with tb on the imap server.

    Works the same with firefox or ie on winxp.

    If I send myself (to operational server forwarded to zim) a couple of ppts through yahoo or gmail it works fine.

    Some cacheing problem? Sigh! Thanks,
    bill

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    zimbra version? OSS or network? Downloading attachments, or viewing as html? Can you access them via IMAP from Zimbra (not from the old system) and view them, or are they still corrupted. How large are they?

  3. #3
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    9

    Default

    - version presented by admin server is 3.0.0_GA_156REHL4 Feb 6, 2006

    - network version

    - error is downloading attachments (although html view says "Error occurred when retrieving the document.")

    - I can download and view/use <one> of the ppts viewed through imap on zim. This one is the first one in the multiple-attachment msg. But I still dont see the other two attachments in this msg. Looking at the msg source, it appears to indeed only have one mime attachment.

    In the other msg which did not work when viewing through zim itself, I still see the .ppt as corrupted viewing through imap on zim.

    The ppt which works using imap on zim is about 6 meg as it arrived on zim; about 8 meg on the old server.

    The (single) ppt which does not work in any way is 2377kb on the old server and 1016kb when view through imap on zim.

    thanks!

  4. #4
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Any errors in /var/log/zimbra.log or /opt/zimbra/log/zimbra.log around the time these were received?

    Also:

    [shell]# rpm -qa | grep compat-lib
    compat-libstdc++-33-3.2.3-47.3
    compat-libstdc++-296-2.96-132.7.2

    you got those installed?

  5. #5
    Join Date
    Dec 2005
    Posts
    4
    Rep Power
    9

    Default

    [root@zimtest log]# rpm -qa | grep compat-lib
    compat-libstdc++-33-3.2.3-47.3
    compat-libstdc++-296-2.96-132.7.2

    Here is the error I found in our logs:

    2006-02-23 09:31:58,164 WARN [LmtpServer-437] [] TransformationClient - Error sending document; tell convertd never mind
    java.io.IOException: Error in encoded stream: needed 4 valid base64 characters but only got 1 before EOF, the 10 most recent characters were: "Xvfuvde\r\n9"
    at com.sun.mail.util.BASE64DecoderStream.decode(BASE6 4DecoderStream.java:218)
    at com.sun.mail.util.BASE64DecoderStream.read(BASE64D ecoderStream.java:116)
    at java.io.FilterInputStream.read(FilterInputStream.j ava:111)
    at java.io.PushbackInputStream.read(PushbackInputStre am.java:161)
    at java.io.FilterInputStream.read(FilterInputStream.j ava:90)
    at com.zimbra.cs.convert.TransformationClient.copyChu nks(TransformationClient.java:107)
    at com.zimbra.cs.convert.TransformationClient.extract (TransformationClient.java:141)
    at com.zimbra.cs.convert.SocketTransformationStub.doE xtract(SocketTransformationStub.java:95)
    at com.zimbra.cs.convert.SocketTransformationStub.ext ract(SocketTransformationStub.java:151)
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:85)
    at com.zimbra.cs.mime.MimeHandler.getContent(MimeHand ler.java:254)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:492)
    at com.zimbra.cs.mime.ParsedMessage.analyzeMessage(Pa rsedMessage.java:410)
    at com.zimbra.cs.mime.ParsedMessage.analyze(ParsedMes sage.java:155)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:185 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:109)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:420)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:197)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:231)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:198)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)
    2006-02-23 09:31:58,220 WARN [LmtpServer-437] [] ParsedMessage - Parse error on MIME part 2 (application/vnd.ms-powerpoint, Message-ID: <200602231731.k1NHVkNB025438@mail.wildpackets.com> )
    com.zimbra.cs.mime.MimeHandlerException: cannot extract text
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:90)
    at com.zimbra.cs.mime.MimeHandler.getContent(MimeHand ler.java:254)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:492)
    at com.zimbra.cs.mime.ParsedMessage.analyzeMessage(Pa rsedMessage.java:410)
    at com.zimbra.cs.mime.ParsedMessage.analyze(ParsedMes sage.java:155)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:185 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:109)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:420)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:197)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:231)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:198)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.EOFException
    at java.io.DataInputStream.readUnsignedShort(DataInpu tStream.java:310)
    at java.io.DataInputStream.readUTF(DataInputStream.ja va:545)
    at java.io.DataInputStream.readUTF(DataInputStream.ja va:522)
    at com.zimbra.cs.convert.TransformationClient.extract (TransformationClient.java:149)
    at com.zimbra.cs.convert.SocketTransformationStub.doE xtract(SocketTransformationStub.java:95)
    at com.zimbra.cs.convert.SocketTransformationStub.ext ract(SocketTransformationStub.java:151)
    at com.zimbra.cs.mime.handler.DefaultHandler.getConte ntImpl(DefaultHandler.java:85)
    ... 12 more
    2006-02-23 09:31:58,221 WARN [LmtpServer-437] [] ParsedMessage - Message had parse errors in 1 parts (Message-Id: <200602231731.k1NHVkNB025438@mail.wildpackets.com> , Subject: XXXXXXXXXXXXXXXXXXXXX )
    2006-02-23 09:31:58,507 INFO [LmtpServer-437] [name=XXXXX@XXXXXX.wildpackets.com;] FileBlobStore - Stored size=1039089 wrote=1039089 path=/opt/zimbra/store/incoming/1140653932079-508.msg vol=1 digest=KsTfCUssf1paPDmPPT4NUQp6q6Y=
    2006-02-23 09:31:58,507 INFO [LmtpServer-437] [name=XXXXX@XXXXXX.wildpackets.com;] FileBlobStore - Renamed id=4233 mbox=2 oldpath=/opt/zimbra/store/incoming/1140653932079-508.msg newpath=/opt/zimbra/store/0/2/msg/1/4233-5308.msg
    2006-02-23 09:31:58,541 INFO [LmtpServer-437] [name=XXXXX@XXXXXX.wildpackets.com;] mailbox - Added message id=4233 digest=KsTfCUssf1paPDmPPT4NUQp6q6Y= mailbox=2 rcpt=XXXXX@XXXXXX.wildpackets.com

  6. #6
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    My engineers are telling me:
    The base64 data was malformed in the original email message.
    The attachment was actually never sent to convertd.

    So it looks like the attachment got munged somewhere in the forward.

  7. #7
    Join Date
    Feb 2006
    Posts
    9
    Rep Power
    9

    Default

    this is fixed. our problem. thanks

  8. #8
    Join Date
    Dec 2005
    Posts
    4
    Rep Power
    9

    Default

    Same here...

Similar Threads

  1. more Connector problems
    By dlochart in forum Zimbra Connector for Outlook
    Replies: 0
    Last Post: 05-31-2007, 11:42 AM
  2. Attachment problems - global only?
    By dlochart in forum Administrators
    Replies: 1
    Last Post: 11-29-2006, 11:37 AM
  3. Replies: 2
    Last Post: 10-19-2006, 10:26 PM
  4. Problems with attachments and Outlook
    By bjdraw in forum Administrators
    Replies: 9
    Last Post: 09-27-2006, 07:23 AM
  5. Message forwarded as attachment problem
    By wildstyle in forum Users
    Replies: 13
    Last Post: 06-20-2006, 04:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •