Results 1 to 10 of 10

Thread: Empty Junk Folder

  1. #1
    Join Date
    Oct 2005
    Location
    Hong Kong
    Posts
    95
    Rep Power
    9

    Default Empty Junk Folder

    "Emtpy Junk" cannot work, those email still here, need to move to Trash folder to do it, but no any error message. I am using IE...

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It's working on my IE6 and Windows Server 2003. Are you able to right-click and Empty Junk? Do you get the warning message? If you got both of those messages did you refresh the browser, you sometimes need to do that to see that they've gone. If you still have problems, which version of IE & operating system are you using? Which version of Zimbra is installed? Do you have Firefox installed and does it happen with that?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2005
    Location
    Peterborough, UK
    Posts
    140
    Rep Power
    9

    Default

    I get an issue with trying to empty more than about 30 messages, also if I have sent a folder to the trash that has messages inside it - I would have to delete the messages and then I can delete the folder. This is using IE6, FireFox1.07 & 1.5, Galeon and Konquerer. OSes used are WinXP, SUSE10, RHEL3/4 Ubuntu and FC3/4 - ZCS is Version 3.0.1_GA_160.RHEL4 running on CentOS4.2

    If I remember there was a bug in the past (M2 or M3) about the trash, but I might be dreaming.

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Can you load the app with ?debug=3 and then watch the output of that when trying to empty your folder. Also on Firefox check the JavaScript console to see if you have any errors.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Oct 2005
    Location
    Hong Kong
    Posts
    95
    Rep Power
    9

    Default

    Yes...I am right-click, no any warning/error message, but when I refresh the browser, it still here but disappear after right-click and Empty Junk again, anyway now it seems works well...strange...


    Quote Originally Posted by phoenix
    It's working on my IE6 and Windows Server 2003. Are you able to right-click and Empty Junk? Do you get the warning message? If you got both of those messages did you refresh the browser, you sometimes need to do that to see that they've gone. If you still have problems, which version of IE & operating system are you using? Which version of Zimbra is installed? Do you have Firefox installed and does it happen with that?

  6. #6
    Join Date
    Apr 2006
    Location
    Cl-Fd, France
    Posts
    28
    Rep Power
    9

    Default

    I have a similar problem

    My configuration:
    - Server FC4 zcs-3.1.0_GA_322
    - Client Windows 2000 Pro SP4 IE6 (french)
    - or Client Ubuntu FF 1.5.0 (english)

    Test 1
    When I empty first Trash using right-click and Empty Trash -> "Empty Trash" works
    But I want to umpty Junk using right-click and Empty Junk -> "Empty Junk" does not work

    I log off from zimbra

    Test 2
    When I empty first Junk using right-click and Empty Junk -> "Empty Junk" works
    But I want to umpty Trash using right-click and Empty Trash -> "Empty Trash" does not work

    ...

  7. #7
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Can you try with ?debug=3 and try to see if you can tell a difference in the SOAP calls the client makes. Maybe post the results here as an attachment.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #8
    Join Date
    Apr 2006
    Location
    Cl-Fd, France
    Posts
    28
    Rep Power
    9

    Default

    Here is the debug result:

    Test 1 : First Empty Trash
    Empty Trash OK
    <FolderActionRequest xmlns="urn:zimbraMail">
    <action xmlns="" op="empty" id="3"/>
    </FolderActionRequest>

    Second click Empty Junk and no good result
    Empty Junk NO OK
    <FolderActionRequest xmlns="urn:zimbraMail">
    <action xmlns="" op="empty" id="3"/>
    </FolderActionRequest>


    Zimbra Log off

    Test 2 : First Empty Junk
    Empty Junk OK
    <FolderActionRequest xmlns="urn:zimbraMail">
    <action xmlns="" op="empty" id="4"/>
    </FolderActionRequest>

    Second click Empty Trash and no good result
    Empty Trash NO OK
    <FolderActionRequest xmlns="urn:zimbraMail">
    <action xmlns="" op="empty" id="4"/>
    </FolderActionRequest>

  9. #9
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Looks like a bug. Nice catch. Please file it in bugzilla.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  10. #10
    Join Date
    Apr 2006
    Location
    Cl-Fd, France
    Posts
    28
    Rep Power
    9

    Default

    Looks like a bug. Nice catch. Please file it in bugzilla.
    OK that's done bug 7495 (http://bugzilla.zimbra.com/)

Similar Threads

  1. spam management (external mx & junk folder)
    By Artturi in forum Administrators
    Replies: 5
    Last Post: 06-20-2008, 07:02 PM
  2. Spam training and Junk folder behavior
    By flyerguybham in forum Administrators
    Replies: 9
    Last Post: 02-14-2007, 11:09 AM
  3. Junk folder and IMAP
    By richard-hdd in forum Installation
    Replies: 3
    Last Post: 09-17-2006, 02:46 AM
  4. Empty trash folder function configuration
    By fmodola in forum Users
    Replies: 7
    Last Post: 04-07-2006, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •